Download it now!
Bug 42227 - FILEOPEN: rotated objects all in top left slide corner
Summary: FILEOPEN: rotated objects all in top left slide corner
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Windows (All)
: medium blocker
Assignee: Radek Doulik
URL:
Whiteboard:
Keywords: regression
: 41808 43287 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-10-25 08:38 UTC by Regina Henschel
Modified: 2011-12-23 13:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (36.48 KB, application/vnd.oasis.opendocument.graphics)
2011-10-25 22:34 UTC, Rainer Bielefeld Retired
Details
Writer sample document (8.40 KB, application/vnd.oasis.opendocument.text)
2011-10-25 23:19 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2011-10-25 08:38:42 UTC
Take a Draw document.
Enter a drawing object in the middle of the page, for example a rectangle or a textbox.
Rotate the object, for example 30°.
Save the document.
Reload the document.
Notice, the rotated object has its corner at position 0|0.

I see this bug in a self-compiled LibO3.5 on WinXP. So please try it with an actual build, to verify that it is nothing special for my build. My build is made from 5ad4d151dac1eb887d92200330e31af269d8d1fd
Comment 1 Regina Henschel 2011-10-25 11:37:48 UTC
Additional comment: The saved file has the correct positions, so the error happens while loading.
The bug is not in my previous build of LibO3.5. I don't know the commit id, but it was before 2011-08-30.
Comment 2 Rainer Bielefeld Retired 2011-10-25 22:30:23 UTC
[Reproducible] with parallel installation of MinGW Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  308b7a2-e916bf9-9c6ea62-e1a2fb3)] (daily/MinGW_cross-compilation 2011-10-18_22.56.49)"

Not reproducible with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  d3d1481-3f8994a-2ba0a9f)]" (110909). Only latest Master versions or only MinGW affected?

It's indeed a FILEOPEN problem, pls. see my attached sample created with LibO 3.4.3. Opening it with an affected Master Version shows all objects at the top left slide corner. Saving document with Master 3.5. will destroy it, opening it again with 3.4.3 will also show all objects at top left corner.
Comment 3 Rainer Bielefeld Retired 2011-10-25 22:34:09 UTC
Created attachment 52775 [details]
Sample Document

See Comment 2!
Comment 4 Rainer Bielefeld Retired 2011-10-25 23:19:04 UTC
Created attachment 52776 [details]
Writer sample document

Not only DRAW is affected, I see the same problem with rotated DRAW objects in WRITER, please compare view in 3.4 and latest Master.
Comment 5 Petr Mladek 2011-10-26 01:16:52 UTC
Raked, I wonder if it is related to your work on shapes. Could you please have a look?

It guess that it is related to the bug 41888.
Comment 6 Radek Doulik 2011-11-25 01:34:10 UTC
AFAICS it is not. This bug completely avoids pptx paths.
Comment 7 Radek Doulik 2011-11-25 01:38:01 UTC
it adds unwanted translation to odf output:

-        <draw:custom-shape draw:style-name="gr1" draw:text-style-name="P1" draw:layer="layout" svg:width="6.604cm" svg:height="6.604cm" svg:x="8.128cm" svg:y="6.35cm">
+        <draw:custom-shape draw:style-name="gr1" draw:text-style-name="P1" draw:layer="layout" svg:width="6.604cm" svg:height="6.604cm" draw:transform="rotate (-0.516442925665122) translate (10.189cm 5.15cm)">

will try to look at it
Comment 8 Radek Doulik 2011-11-25 01:39:40 UTC
the translation is OK, because it also removes svg:[xy], looks like odf import doesn't import correctly the transformation
Comment 9 m.a.riosv 2011-11-25 14:38:21 UTC
Why is mark as blocker?.

http://wiki.documentfoundation.org/Release_Criteria
Comment 10 Rainer Bielefeld Retired 2011-11-25 23:43:08 UTC
@mariosv:
Dataloss, unusable function, reproducible by more users, broken functionality is regression against the last released version, affect most users.
Comment 11 Radek Doulik 2011-11-28 09:38:28 UTC
fortunately it wasn't loosing data. just the import was broken.

the problem is now fixed in master
Comment 12 Rainer Bielefeld Retired 2011-11-29 10:49:08 UTC
I can NOT confirm a fix with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: a653e50-1f92ab1-3bd0388]" Win-x86@6  - 111128)
Comment 13 Radek Doulik 2011-12-01 07:06:15 UTC
the fix was committed in master on Nov 28th

commit 7bf1fa3757133f12cf6ca624f8cee6ba5363e7d8
Author: Radek Doulik <rodo@novell.com>
Date:   Mon Nov 28 18:24:11 2011 +0100

I am closing the bug, please reopen if it doesn't work with newer builds.
Comment 14 Rainer Bielefeld Retired 2011-12-12 22:52:44 UTC
*** Bug 41808 has been marked as a duplicate of this bug. ***
Comment 15 Roman Eisele 2011-12-13 03:14:32 UTC
Sorry, but this bug seems still alive in LibreOffice 3.5 beta 0:

Reopened because bug is still REPRODUCIBLE following Regina Henschels descriptions, using
LibreOffice 3.5.0 [beta 0]
Build-ID: ef91e38-b1d4df6-090bcba-45cf606-05891e7
German UI installed
running on MacOS X 10.6.8 German

Could someone else please test Windows and/or Linux?
Comment 16 Roman Eisele 2011-12-13 03:26:31 UTC
Sorry again: the bug is really present in LibreOffice 3.5 beta 0, as I wrote, but it is fixed on master -- testet with two of the newest Master builds.

So I hope this bug will be fixed in 3.5 beta 1 or 2, too.
May I propose to leave the Status set to 'REOPENED' until we are sure (by simple end-user testing) that the fix really made it into beta 1 or 2?
Comment 17 Regina Henschel 2011-12-13 03:29:06 UTC
For me it is fixed. I'm on WinXP using LOdev 3.5.0 
Build-ID: f923851-7f15fca-1f1fd1a-ca8e46d-5bcbce4
Comment 18 Rainer Bielefeld Retired 2011-12-13 23:19:19 UTC
Also WFM with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta1 - WIN7 Home Premium (64bit) German UI [Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4] Windows_Release_Configuration  11-Dec-2011 06:51". So closing again.
Comment 19 Roman Eisele 2011-12-14 02:44:41 UTC
Fix confirmed with beta 1 on MacOS X 10.6.8:

LOdev 3.5.0 [should be: LibreOffice 3.5.0 beta 1; on MacOS, the file name of
the beta 1 build is 'LOdev']
Build-ID: 1ce7995-7f15fca-1f1fd1a-ca8e46d-5bcbce4
Installation file:
libreoffice-3-5~2011-12-13_04.48.06_LibO-Dev_3.5.0beta1_MacOS_x86_install_en-US

Sorry for the confusion my report may have caused! In beta 0, the bug was still present, it has been fixed in beta 1. So everything is good now ...
Comment 20 Rainer Bielefeld Retired 2011-12-21 22:31:24 UTC
*** Bug 43287 has been marked as a duplicate of this bug. ***
Comment 21 Björn Michaelsen 2011-12-23 13:26:45 UTC
Since all new unconfirmed bugs start in state UNCONFIRMED now and old unconfirmed bugs were moved to NEEDINFO with a explanatory comment, all bugs promoted above those bug states to NEW and later are automatically confirmed making the CONFIRMED whiteboard status redundant. Thus it will be removed.