Download it now!
Bug 42252 - FILEOPEN docx CRASH
Summary: FILEOPEN docx CRASH
Status: RESOLVED DUPLICATE of bug 41679
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-10-25 21:21 UTC by christian.buhtz
Modified: 2016-05-01 15:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
file that occures the crash (338.76 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2011-10-25 21:21 UTC, christian.buhtz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christian.buhtz 2011-10-25 21:21:10 UTC
Created attachment 52773 [details]
file that occures the crash

I tried to open the attached docx file on two different Win7 32bit machines with the current release.

It occures in a crash. No concret error message.
Comment 1 Rainer Bielefeld Retired 2011-11-04 03:44:55 UTC
Might be related to or DUP of Bug 38514, Bug 39384,  Bug 40579,  Bug 40588, 
Bug 41679,  Bug 42252,  Bug 42450,  Bug 42486,  Bug 42583,  Bug 42583.

@Reporter:
Why do you expect that this report contains completely new information?
Comment 2 christian.buhtz 2011-11-04 05:14:19 UTC
I don't know what you mean.

My information is that the attached file cause a crash. That is everything what I know.

You (the devs) know the LibOf internals. You can analyse the problem.
Comment 3 Rainer Bielefeld Retired 2011-11-04 05:42:53 UTC
[Reproducible] with reporter's sample and "LibreOffice 3.4.4RC2  - WIN7 Home
Premium (64bit) German UI [OOO340m1 (Build:402)]" Workaround from  Bug 39384#6 will not
work.

No crash with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium
(64bit) English UI [(Build ID:  d3d1481-3f8994a-2ba0a9f)]" (110909)

No crash with parallel installation of MinGW Master "LibO-dev 3.5.0 – WIN7 Home
Premium (64bit) English UI [(Build ID:  2ba5d12-e8c71c5-41e7bcd-4b83b90)]
(daily/MinGW_cross-compilation2011-10-25_00.12.09)"

So WFM, I believe it's too hard to check for DUPs.

@reporter:
Please feel free to reopen this bug if you find out that the problem still
exists with 3.5 (Available in December / January)
Comment 4 Rainer Bielefeld Retired 2011-11-11 23:25:44 UTC
But again [Reproducible] with parallel installation of MinGW Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  2ba5d12-e8c71c5-41e7bcd-4b83b90)] (daily/MinGW_cross-compilation2011-10-25_00.12.09)". s REOPENED
Comment 5 Rainer Bielefeld Retired 2011-11-11 23:51:57 UTC
NOT reproducible with "LibreOffice 3.4.4RC2  - WIN7 Home Premium (64bit) German
UI [OOO340m1 (Build:402)]". No crash, but I see an empty page.

Now AGAIN [Reproducible] with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home
Premium (64bit) German UI [(Build ID: 
6b0de40-0bc4ff4-ca7e6f5-9125509-ce71330)]" (111111), LibO stops responding when
I try to open (from LibO start dialog).

Worked fine with "LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit)
German UI [OOO330m19 (Build:301  Tag 3.3.3.1)]", so it seems we have a
regression here. 

That all looks very similar to "Bug 41679 - FILEOPEN: file open docx crash", so I mark this one as a DUP for now. 

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 41679 ***
Comment 6 Jean-Baptiste Faure 2016-05-01 15:49:30 UTC
regression keyword set from comment #5.