Bug 42450 - FILEOPEN: Writer crashes while processing docx file [backtrace with symbols attached]
Summary: FILEOPEN: Writer crashes while processing docx file [backtrace with symbols a...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: BSA target:3.7.0 target:3.5.7 target:...
Keywords:
: 44850 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-10-31 12:24 UTC by Mario J. Borgnia
Modified: 2012-10-11 10:49 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample Thai file (19.47 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2012-03-20 10:31 UTC, panyazone
Details
Error message when LibO crashes (196.40 KB, image/pjpeg)
2012-03-20 11:12 UTC, panyazone
Details
backtrace with symbols produced in selfcompiled 3.6.1 on Fedora 64 bit (244.75 KB, text/plain_text)
2012-09-12 09:55 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mario J. Borgnia 2011-10-31 12:24:49 UTC
Problem description: 

Steps to reproduce:
1. Open Microsoft Docx (I used http://www.ott.nih.gov/docs/EIR-WORD-2007.docx)
2. OR download said file and run ooconvert
3. ....

Current behavior:
> oowriter EIR-WORD-2007.docx 
crashes with no message

> > ooconvert EIR-WORD-2007.docx EIR.odt
Starting LibreOffice...
Doing the conversion...
Traceback (most recent call last):
  File "/usr/share/libreoffice/program/DocumentConverter.py", line 161, in <module>
    converter.convert(argv[1], argv[2])
  File "/usr/share/libreoffice/program/DocumentConverter.py", line 93, in convert
    document = self.desktop.loadComponentFromURL(inputUrl, "_blank", 0, self._toProperties(Hidden=True))
__main__.DisposedException: Binary URP bridge disposed during call
soffice.bin: no process found

Expected behavior:
oowriter is expected to open the file and start editor while ooconvert is supposed to produce a proper Open Document Text File

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 1 Rainer Bielefeld Retired 2011-11-11 23:32:26 UTC
Normal opening reporter's sample works fine with "LibreOffice 3.4.4RC2  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]" and with 
Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) German UI [(Build ID:  6b0de40-0bc4ff4-ca7e6f5-9125509-ce71330)]" (111111)

ooconvert not tested
Comment 2 sasha.libreoffice 2012-03-07 02:04:39 UTC
@ Mario J. Borgnia
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
And which version of Linux used?
Comment 3 panyazone 2012-03-20 10:31:22 UTC
Created attachment 58772 [details]
Sample Thai file
Comment 4 panyazone 2012-03-20 11:09:37 UTC
(In reply to comment #3)
> Created attachment 58772 [details]
> Sample Thai file

My writings are gone after attaching the Sample Thai file (attachment 58772 [details]).

I found similar problem using LibreOffice 3.5.1.2 Build ID: dc9775d-05ecbee-0851ad3-1586698-727bf66 under Windows 7 Professional. I opened the reporter's sample file, and there is no problem. But when I open the Sample Thai file (attachment 58772 [details]), I got problems in an unconsistent way. The following is a sample of series of events.

First I open the file and do nothing, nothing happens. When I scroll up-down repeatedly for a while, Libo crashes with a pop-up wisndows saying LibreOffice is not responding. I opened the file again and scroll up and down by clicking the vertical scroll bar, Libo crashes again. The screen shot will be shown as "Screen shot 1" in the attachment of the next comment. Then I open the file again. This time Libo crash immediately showing the pop-up saying "The following files will be recovered, but LibO is not responding. When I click to close this pop-up, the pop-up like "screen shot 1" appears ontop, this time with different problem detail from "screen shot 1", as follows. 

Description:
  A problem caused this program to stop interacting with Windows.

Problem signature:
  Problem Event Name:	AppHangB1
  Application Name:	soffice.bin
  Application Version:	3.5.0.102
  Application Timestamp:	4f55e306
  Hang Signature:	1e61
  Hang Type:	513
  OS Version:	6.1.7600.2.0.0.256.48
  Locale ID:	2057
  Additional Hang Signature 1:	1e614c4307192717090268bf5150da2e
  Additional Hang Signature 2:	7ce8
  Additional Hang Signature 3:	7ce834d6f38a52c7fb0e1c07a12d0097
  Additional Hang Signature 4:	1e61
  Additional Hang Signature 5:	1e614c4307192717090268bf5150da2e
  Additional Hang Signature 6:	7ce8
  Additional Hang Signature 7:	7ce834d6f38a52c7fb0e1c07a12d0097

I shut down and restart Windows, and start the test again with similar, but not exactly the same series of events.
Comment 5 panyazone 2012-03-20 11:12:31 UTC
Created attachment 58774 [details]
Error message when LibO crashes
Comment 6 Mario J. Borgnia 2012-03-20 12:39:25 UTC
As of LibreOffice 3.4.5 OOO340m1 (Build:1505) the problem seems solved
I am running OpenSUSE 12.1: Linux 3.1.9-1.4-desktop #1 SMP PREEMPT Fri 
Jan 27 08:55:10 UTC 2012 (efb5ff4) x86_64 x86_64 x86_64 GNU/Linux




On 03/07/2012 05:04 AM, bugzilla-daemon@freedesktop.org wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=42450
>
> sasha.libreoffice@gmail.com changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |sasha.libreoffice@gmail.com
>
> --- Comment #2 from sasha.libreoffice@gmail.com 2012-03-07 02:04:39 PST ---
> @ Mario J. Borgnia
> Thanks for bugreport
> Please, verify if in last version of LibreOffice still reproducible
> And which version of Linux used?
>
Comment 7 panyazone 2012-03-20 19:29:37 UTC
(In reply to comment #6)
> As of LibreOffice 3.4.5 OOO340m1 (Build:1505) the problem seems solved
> I am running OpenSUSE 12.1: Linux 3.1.9-1.4-desktop #1 SMP PREEMPT Fri 
> Jan 27 08:55:10 UTC 2012 (efb5ff4) x86_64 x86_64 x86_64 GNU/Linux
> On 03/07/2012 05:04 AM, bugzilla-daemon@freedesktop.org wrote:
> > https://bugs.freedesktop.org/show_bug.cgi?id=42450
> >
> > sasha.libreoffice@gmail.com changed:
> >
> >             What    |Removed                     |Added
> > ----------------------------------------------------------------------------
> >                   CC|                            |sasha.libreoffice@gmail.com
> >
> > --- Comment #2 from sasha.libreoffice@gmail.com 2012-03-07 02:04:39 PST ---
> > @ Mario J. Borgnia
> > Thanks for bugreport
> > Please, verify if in last version of LibreOffice still reproducible
> > And which version of Linux used?
> >

May be my problem,which relates to Thai text and page scrolling, is different from yours. Since your problem was solved, I may need to report it as another bug report. Can you test my sample file with your OpenSUSE?
Comment 8 Vicente Rafael Estévez Vacas 2012-04-15 07:47:00 UTC
[Reproducible] with "LibreOffice 3.4.6 - Debian Squeeze (32bit) Spanish
UI"

I open http://www.ott.nih.gov/docs/EIR-WORD-2007.docx and Writer Crash
Comment 9 Xavi Escriche Galindo 2012-04-20 17:07:33 UTC
[Not reproducible] Works fine with "LibreOffice 3.5.2.2 - Mac OS X 10.5.8 (32bits) Catalan UI"
Comment 10 Julien Nabet 2012-05-16 15:55:24 UTC
On pc Debian x86-64, with 3.5 branch updated yesterday, I don't reproduce these problems :
- crash with the thai file
- crash with http://www.ott.nih.gov/docs/EIR-WORD-2007.docx

About ooconvert, i didn't know this but if I didn't misunderstand, it's not part from LO since it's there http://sourceforge.net/projects/ooconvert/.

Could you try to reproduce crashes with last LO version 3.5.3 and a brand new LO profile (see http://wiki.documentfoundation.org/UserProfile) ?
Comment 11 sasha.libreoffice 2012-09-11 09:10:12 UTC
in 3.6.1 on Fedora 64 bit still crashes
Comment 12 sasha.libreoffice 2012-09-12 09:55:54 UTC
Created attachment 67032 [details]
backtrace with symbols produced in selfcompiled 3.6.1 on Fedora 64 bit
Comment 13 Julien Nabet 2012-09-12 11:39:26 UTC
Sasha: thank you for this useful bt

Michael: one for you?
Comment 14 Michael Stahl (CIB) 2012-09-12 19:58:22 UTC
the crash on the libreoffice-3-6 branch was introduced between beta-2 and beta-3,
by the following writerfilter commits:

 ca555c596043c88894b964ac5e21f5a7271d5f3b
 2992b53f39ea3d61d4acbe7f7c494f90228ce377

(probably the first one but reverting only that doesn't build)

the reason why it crashes is that a section is inserted with a
text range that partially overlaps an existing section;
that is easily fixed, and needs fixing in any case.

however i'm not sure if there are other problems here,
as with the fix there are ~2 fewer sections than there were
in 3.6 beta2, but it's of course possible that that is an
improvement; Miklos could investigate that if he has time :)
Comment 15 Not Assigned 2012-09-12 20:04:57 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5bc6c7b2e170a35914d7cd07347c77a9c9d23664

fdo#42450: fix crash in SwXTextSection::attach:



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 16 Not Assigned 2012-09-12 20:27:15 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2940a697dce2292e9c5b118feb8ec4159e3606fa

fdo#42450: also end undo on error condition



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Not Assigned 2012-09-13 10:44:25 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d026212d51cd7fe0dbcfe3a28bd15675528723ff&g=libreoffice-3-5

fdo#42450: fix crash in SwXTextSection::attach:


It will be available in LibreOffice 3.5.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 18 Not Assigned 2012-09-13 10:44:46 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=525127d5b605bf34a8ff0b71f4b169fa7b72c435&g=libreoffice-3-6

fdo#42450: fix crash in SwXTextSection::attach:


It will be available in LibreOffice 3.6.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Not Assigned 2012-09-21 12:19:11 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-6-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=04e34c9876c25be047c1b26c489d4185bacc54b5&g=libreoffice-3-6-2

fdo#42450: fix crash in SwXTextSection::attach:


It will be available already in LibreOffice 3.6.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Michael Stahl (CIB) 2012-10-11 10:49:16 UTC
*** Bug 44850 has been marked as a duplicate of this bug. ***