Bug 44850 - FILEOPEN libreoffice crashes when opening a docx file
Summary: FILEOPEN libreoffice crashes when opening a docx file
Status: RESOLVED DUPLICATE of bug 42450
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Linux (All)
: medium major
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-01-16 21:25 UTC by Andreas Rudin
Modified: 2012-10-11 10:49 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt + console msgs on master (25.70 KB, text/plain)
2012-07-08 12:08 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Rudin 2012-01-16 21:25:33 UTC
Here is a link to a sample file, that makes LibreOffice 3.4.3 ( OOO340m1 (Build:302) from Debian squeeze backports ) crash when trying to open it:

http://rochen.revamp-it.ch/test/docx_crash.docx

(It comes from MS Office 2007 within Windows Vista Home Edition)

(Crashing happens with many more docx-files though!)

No error message even when starting libreoffice from a terminal.

P.S. with the command "man libreoffice" I don't see any option to start libreoffice in verbose or debug modus to get more information about the crash.
Is there a way to do so? Where do I find an instruction for this?

Best wishes

Andreas
Comment 1 tester8 2012-01-25 02:23:57 UTC
I can't download document. Can you please upload it to another hosting?
Comment 2 sasha.libreoffice 2012-05-08 05:00:26 UTC
can not reproduce crash in 3.3.4 and 3.5.3 on Fedora 64 bit
Comment 3 Valek Filippov 2012-07-07 06:59:46 UTC
linux x86, works fine in 3.5.2, crashes in 3.6beta2.
Comment 4 Julien Nabet 2012-07-08 12:08:06 UTC
Created attachment 63979 [details]
bt + console msgs on master

On Pc Debian x86-64, with master sources updated today, I reproduced the crash.

I attached logs + bt.
Comment 5 Roman Eisele 2012-07-09 07:00:35 UTC
Please note that the Version field should always the FIRST version in
which a bug is known to exist, and NOT the last one. So please don’t "update"
the version field, only state in your comments that a bug is still reproducible
in a specific new version of LibreOffice. Thank you!
Comment 6 Michael Stahl (allotropia) 2012-10-11 10:49:16 UTC

*** This bug has been marked as a duplicate of bug 42450 ***