Bug 42387 - RTL EDITING: merge cell destroys table, borders incorrect for new table
Summary: RTL EDITING: merge cell destroys table, borders incorrect for new table
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium normal
Assignee: gokul
URL:
Whiteboard: BSA target:4.1.0 target:4.0.1
Keywords: regression
Depends on:
Blocks: RTL-CTL 59117 60554
  Show dependency treegraph
 
Reported: 2011-10-30 00:53 UTC by Hojjatollah
Modified: 2013-02-09 18:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
merge.odp (123.56 KB, application/vnd.oasis.opendocument.presentation)
2011-11-05 03:52 UTC, Hojjatollah
Details
Border Missing on merging the cells (102.77 KB, application/vnd.oasis.opendocument.presentation)
2013-02-04 06:13 UTC, gokul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hojjatollah 2011-10-30 00:53:13 UTC
Problem description: 
after insert table when merg 2 or more cell table is not correct.
Steps to reproduce:
1. ....
2. ....
3. ....

Current behavior:

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Comment 1 Rainer Bielefeld Retired 2011-10-30 08:15:57 UTC
I can't imagine what the problem might be.

@reporter:
May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully?
Then please:
- Write a meaningful Summary
- Attach a sample document (not only screenshot)
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- what exactly is unexpected
  -- and why do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC 
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO localization (UI language)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  -- everything else crossing your mind after you read linked texts

- Reported with Bug Submission Assistant -
Comment 2 Rainer Bielefeld Retired 2011-10-30 08:46:14 UTC
Created attachment 53181 [details]
merge.odp

DUP of or related to "Bug 34403 - FORMATTING: borders wrong for merged cells with overlapping line segments"?
Comment 3 Hojjatollah 2011-11-05 03:52:39 UTC
merge cell bug in impress

On 10/30/11, bugzilla-daemon@freedesktop.org
<bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=42387
>
> Rainer Bielefeld <LibreOffice@bielefeldundbuss.de> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>          OS/Version|All                         |Windows (All)
>                  CC|                            |LibreOffice@bielefeldundbus
>                    |                            |s.de
>            Keywords|                            |NEEDINFO
>
> --- Comment #1 from Rainer Bielefeld <LibreOffice@bielefeldundbuss.de>
> 2011-10-30 08:15:57 PDT ---
> I can't imagine what the problem might be.
>
> @reporter:
> May I ask you to read  hints on
> <http://wiki.documentfoundation.org/BugReport>
> carefully?
> Then please:
> - Write a meaningful Summary
> - Attach a sample document (not only screenshot)
> - Attach screenshots with comments if you believe that that might explain
> the
>   problem better than a text comment. Best way is to insert your screenshots
>   into a DRAW document and to add comments that explain what you want to
> show
> - Contribute a step by step instruction containing every key press and every
>   mouse click how to reproduce your problem (and if possible how to created
> a
>   sample document from the scratch)
> - add information
>   -- what exactly is unexpected
>   -- and why do you believe it's unexpected (cite Help or Documentation!)
>   -- concerning your PC
>   -- concerning your OS (Version, Distribution, Language)
>   -- concerning your LibO localization (UI language)
>   –- Libo settings that might be related to your problems
>   -- how you launch LibO and how you opened the sample document
>   -- everything else crossing your mind after you read linked texts
>
> - Reported with Bug Submission Assistant -
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
Comment 4 Rainer Bielefeld Retired 2011-11-05 05:06:56 UTC
Tested merge.odp, I believe it's a "Right to Left" issue. When I create a table in a new document everything looks fine (borders around all cells), but when I insert a new table into reporter's sample document (simply default 5 columns 2 rows) borders around cells of right column are missing. Even when I copy paste a table from a self created LtR spreadsheet it gets the "missing borders damage".

I am sure that that problem is related to the merge issue.

@Hojjatollah:
I am a little clueless concerning right-to-left. Where can I switch your document from RtL to LtR? Can you do an additional test for Left-toRight, and also a test in DRAW? And may be WRITER?
Comment 5 Rainer Bielefeld Retired 2011-11-05 05:41:57 UTC
@Hojjatollah:
My request might have been rather imprecise. Can you tell me how to bring my German LibO into a right-to-left mode for a new presentation?
Comment 6 Hojjatollah 2011-11-07 22:29:54 UTC
Salam
Yes this bug apeare in RTL but only in presentation and draw

comment5:
in windows RTL enable after enable asian language in control
panel->religion and languages  or

In linux also need to enable rtl in desktop environment and apply wide system

On 11/5/11, bugzilla-daemon@freedesktop.org
<bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=42387
>
> --- Comment #5 from Rainer Bielefeld <LibreOffice@bielefeldundbuss.de>
> 2011-11-05 05:41:57 UTC ---
> @Hojjatollah:
> My request might have been rather imprecise. Can you tell me how to bring my
> German LibO into a right-to-left mode for a new presentation?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 7 Rainer Bielefeld Retired 2011-11-07 22:54:46 UTC
@Hojjatollah:
Thank you for explication, but it seems I can't find the wood among all the trees ;-)   Can you please attach a screenshot from English UI or an other guide how I can find that "panel->religion and languages"

And can you please try to delete useless citations from other comments before you submit new comments? Thank you!
Comment 8 Hojjatollah 2011-11-07 23:08:16 UTC
in these pages:
http://forum.persiantools.com/t31635.html

http://www.daryasoft.com/index.php?option=com_content&view=article&id=149:-xp&
catid=37:1388-12-11-11-02-18&Itemid=80

show step by step with screenshot
-----
how i can try to delete useless citation
i use gmail client



On 11/8/11, bugzilla-daemon@freedesktop.org
<bugzilla-daemon@freedesktop.org> wrote:
> https://bugs.freedesktop.org/show_bug.cgi?id=42387
>
> Rainer Bielefeld <LibreOffice@bielefeldundbuss.de> changed:
>
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>           Component|Presentation                |Drawing
>
> --- Comment #7 from Rainer Bielefeld <LibreOffice@bielefeldundbuss.de>
> 2011-11-07 22:54:46 PST ---
> @Hojjatollah:
> Thank you for explication, but it seems I can't find the wood among all the
> trees ;-)   Can you please attach a screenshot from English UI or an other
> guide how I can find that "panel->religion and languages"
>
> And can you please try to delete useless citations from other comments
> before
> you submit new comments? Thank you!
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 9 Rainer Bielefeld Retired 2011-11-07 23:37:04 UTC
Found it!
Steps to reproduce:

0. Start LibO, open new DRAW document from Start Center
1. Menu 'Tools -> Options -> Language settings -> Languages - Enhanced
  language support' check both if they are not checked, <ok>
2. Menu 'Format -> Page -> Page Tab - Text direction' = left to right  (if
   necessary) <ok>
3. Meneu 'Insert -> Table' <ok>
   a table 2 rows 5 columns will be inserted, everything looks fine
4. Drag and drop table to top of the page, <Esc> 
5. Menu 'Format -> Page -> Page Tab - Text direction' = Right to Left <ok>
6. Meneu 'Insert -> Table' <ok>
   a table 2 rows 5 columns will be inserted, 
   Expected: looks as table from step 3
   actual: borders in right column are missing

@Thorsten:
Can you help?
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 10 Michael Stahl (CIB) 2012-05-23 14:26:11 UTC
can reproduce the bug with LO 3.5.4, OOo 3.4beta, OOo 3.3,
but not OOo 3.0.1 => regression
Comment 11 gokul 2012-07-23 10:56:43 UTC
I Still find the bug exist in master branch, i am working on this bug.
Comment 12 Julien Nabet 2012-10-28 15:20:11 UTC
Just for information, on pc Debian x86-64 with master sources updated today, I reproduce this bug.
Comment 13 Not Assigned 2013-01-16 10:37:41 UTC
Gokul committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bd20b86ee762d4a14766a755d44efdeb50cef7e7

fdo#42387 Fixed Merging of cells in RTL Tables in impress



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Ahmad Harthi 2013-01-27 08:17:08 UTC
Tested, works good.
Comment 15 Lior Kaplan 2013-01-27 20:44:53 UTC
I can still reproduce with master on Debian 64. Need another one to confirm this...
Comment 16 gokul 2013-01-28 05:02:22 UTC
(In reply to comment #15)
> I can still reproduce with master on Debian 64. Need another one to confirm
> this...

It Works Good for me, Are you able to reproduce the problem with merging of cells. That i have fixed and it works fine.

Their is another BugID for problem with incorrect cell border, Bug #59117.
Comment 17 Lior Kaplan 2013-01-28 23:30:50 UTC
Verified on master, although problems from bug #59117 are still here for the right most cells.

@gokul - thanks, I got confused with comment #15 and check the wrong scenario.
Comment 18 Not Assigned 2013-01-31 15:04:16 UTC
Gokul committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b8c9c63cdc44eba348b52dd3cb2e70d379d23187&h=libreoffice-4-0

fdo#42387 Fixed Merging of cells in RTL Tables in impress


It will be available in LibreOffice 4.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 Lior Kaplan 2013-02-03 19:17:30 UTC
bug #59117 been fixed, but some merge issues are still present on master:

With an RTL table in impress (2 row, 5 columns) merge the two left most columns in the first row - the right border disappears. Merge the two right most columns in the second row - the left border disappears. Couldn't reproduce with a different set of cells to merge.
Comment 20 gokul 2013-02-04 06:13:42 UTC
Created attachment 74161 [details]
Border Missing on merging the cells
Comment 21 gokul 2013-02-04 06:16:18 UTC
Yes Even I am able to reproduce the same. The problem exist with RTL table irrespective of number of rows and columns.

Their is another problem. When we select 2 or more cells in First column or last column it also merges the cells in other end.

Check the attachment for details.

(In reply to comment #19)
> bug #59117 been fixed, but some merge issues are still present on master:
> 
> With an RTL table in impress (2 row, 5 columns) merge the two left most
> columns in the first row - the right border disappears. Merge the two right
> most columns in the second row - the left border disappears. Couldn't
> reproduce with a different set of cells to merge.
Comment 22 gokul 2013-02-04 06:21:21 UTC
Correcting my Previous Comment. on merging the cells in First or last column,Does not merge cells in other end, Instead The borders are missing for intermediate table.
Comment 23 Karthikeyan Krishnamurthi 2013-02-06 11:11:38 UTC
(In reply to comment #19)
> bug #59117 been fixed, but some merge issues are still present on master:
> 
> With an RTL table in impress (2 row, 5 columns) merge the two left most
> columns in the first row - the right border disappears. Merge the two right
> most columns in the second row - the left border disappears. Couldn't
> reproduce with a different set of cells to merge.

@Lior kaplan can we file it as a (new)bug? 

  I checked the above issue with Libreoffice Version 3.6.3.2 (Build ID: 58f22d5) on Ubuntu 12.04 (precise), and yes, I can reproduce it.  So, I hope neither the patch of bug #59117 nor #42387 responsible for this.  

  Yes, I agree with @gokuls comment 21 & 22 with RTL table
  "Their is another problem. When we select 2 or more cells in First column or       
   last column"

  "on merging the cells in First or last column,Does not merge cells in other 
   end, Instead The borders are missing"

   Irrespective of first or last column, it is reproducible with other columns also except the exact middle column(if the table have odd number of columns).

  So, i think it is better to put it as a separate bug... Sugestions/comments are welcomed.
Comment 24 Lior Kaplan 2013-02-09 18:02:31 UTC
(In reply to comment #23)
> (In reply to comment #19)
> > bug #59117 been fixed, but some merge issues are still present on master:
> > 
> > With an RTL table in impress (2 row, 5 columns) merge the two left most
> > columns in the first row - the right border disappears. Merge the two right
> > most columns in the second row - the left border disappears. Couldn't
> > reproduce with a different set of cells to merge.
> 
> @Lior kaplan can we file it as a (new)bug? 

Bug 60554