Bug Hunting Session
Bug 60554 - Borders disappear while merging some cells in RTL tables (impress/draw)
Summary: Borders disappear while merging some cells in RTL tables (impress/draw)
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Karthikeyan Krishnamurthi
URL:
Whiteboard: target:4.1.0 target:4.0.3
Keywords:
Depends on: 42387
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2013-02-09 18:01 UTC by Lior Kaplan
Modified: 2013-03-26 17:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lior Kaplan 2013-02-09 18:01:16 UTC
A follow up on bug 42387: 

Bug #59117 been fixed, but some merge issues are still present on master:

With an RTL table in impress (2 row, 5 columns) merge the two left most columns in the first row - the right border disappears. Merge the two right most columns in the second row - the left border disappears. Couldn't reproduce with a different set of cells to merge.
Comment 1 Commit Notification 2013-03-04 11:44:58 UTC
K_Karthikeyan committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=45a5dad0460a1a7d1a44716968b8c9ff4a23e04b

Resolves fdo#60554



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Lior Kaplan 2013-03-07 15:13:41 UTC
Fix verified on master build.
Comment 3 Commit Notification 2013-03-14 13:26:06 UTC
K_Karthikeyan committed a patch related to this issue.
It has been pushed to "libreoffice-4-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4c13903e61017b3d7869882aac1ec272a2c4474c&h=libreoffice-4-0

Resolves fdo#60554


It will be available in LibreOffice 4.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.