Bug Hunting Session
Bug 42448 - Data label are not located correctly on 3D pie charts
Summary: Data label are not located correctly on 3D pie charts
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-10-31 12:12 UTC by Muriel de Souza Godoi
Modified: 2014-12-15 11:06 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
testcase: months & seasons (190.59 KB, application/vnd.oasis.opendocument.presentation)
2012-01-06 19:46 UTC, Serge Stroobandt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Muriel de Souza Godoi 2011-10-31 12:12:24 UTC
Create an 3D pie chart and add the data labels
Notice that the positioning of data labels are not correct.

The error persists even changing the positioning option on Data Label Format Dialog (Best fit, in, out,center)

PS: I'm using Brazilian-Portuguese translation here. So, I'm not sure about the original English strings on the GUI.

I observed this issue on Linux and Windows 7.
Comment 1 Christian Lohmaier 2011-12-28 04:16:55 UTC
confirmed
Comment 2 Serge Stroobandt 2012-01-06 19:46:28 UTC
Created attachment 55230 [details]
testcase: months & seasons
Comment 3 Serge Stroobandt 2012-01-06 19:48:54 UTC
The bug is due to the fact that the labels hover at too large a distance from the top surface of the 3D pie chart.

I have not found any way to change this distance in the user interface.

A testcase file is attached.
Comment 4 Markus Mohrhard 2012-03-05 14:13:23 UTC
Ok, this one is a bit tricky. The problem is the algorithm calculating the position of all labels if the chart is rotated.
Comment 5 retired 2014-05-04 12:12:17 UTC
Muriel: Can you please specify exactly what is not displayed correctly here? Please create a screenshot clearly showing what the issue is. From your description I am not sure what to look for. All I can say file opens ok and looks fine in LO 4.2.3.3 + latest nightly on OSX. But I'm sure I'm missing something here.

Is this bug still valid / reproducible with the latest LO release?  Currently 4.2.3: http://www.libreoffice.org/download/libreoffice-fresh/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED. Should this issue be solved set it to WORKSFORME.

Setting to NEEDINFO until more detail is provided.
Comment 6 Muriel de Souza Godoi 2014-05-05 00:54:02 UTC
That issue used to affect 3.4 builds but seens to be solved on 4.3.2.2 build.
I also opened the same file and now it's fine.

You can close this one.

Thanks.
Comment 7 ign_christian 2014-06-17 15:31:42 UTC
@Muriel, based on your comment this should be WORKSFORME.

Please REOPENED if you still experience this in latest stable release & attach screenshot.