Download it now!
Bug 42465 - FILEOPEN RTF: import-export error after change font
Summary: FILEOPEN RTF: import-export error after change font
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:3.6.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-11-01 03:05 UTC by Ákos
Modified: 2013-11-25 14:51 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
rtf document, writed in Hungarian (58.45 KB, application/rtf)
2011-11-01 03:05 UTC, Ákos
Details
pdf export with LO 3.5.0 beta-1 (89.11 KB, application/pdf)
2011-12-18 08:42 UTC, Jean-Baptiste Faure
Details
Save errors after resave in RTF. (90.09 KB, application/pdf)
2011-12-18 09:39 UTC, Ákos
Details
Same resaved file opened with Word 2003 and LibO 3.4.4 (chinese characters) (279.39 KB, application/x-7z-compressed)
2012-01-26 11:07 UTC, s-joyemusequna
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ákos 2011-11-01 03:05:39 UTC
Created attachment 52988 [details]
rtf document, writed in Hungarian

I attach an example file, writed in hungarian. I opened the file, and change the font, in ubuntu linux 11.10 to Ubuntu and in Windows XP sp3 to Times New Roman, and save the file. After I reopened it the hungarian specific characters changed to unreadable characters both in windows and linux.
Comment 1 Fahad Al-Saidi 2011-11-01 07:30:05 UTC
It works fine with LibreOffice 3.3.4
Comment 2 Jean-Baptiste Faure 2011-12-18 08:42:40 UTC
Created attachment 54540 [details]
pdf export with LO 3.5.0 beta-1

I attached a pdf export of your RTF file produced by LO 3.5.0 beta-1 (LibreOffice 3.5.0beta1+ Build ID: ddc7af3-7f15fca-8eae9f1-ca8e46d-5bcbce4) under Ubuntu 10.04 x86_64

Does my PDF export looks correct for you? If not, please attach a PDF showing what the file should look.

Best regards. JBF
Comment 3 Ákos 2011-12-18 09:37:59 UTC
(In reply to comment #2)
> Created attachment 54540 [details]
> pdf export with LO 3.5.0 beta-1
> 
> I attached a pdf export of your RTF file produced by LO 3.5.0 beta-1
> (LibreOffice 3.5.0beta1+ Build ID: ddc7af3-7f15fca-8eae9f1-ca8e46d-5bcbce4)
> under Ubuntu 10.04 x86_64
> 
> Does my PDF export looks correct for you? If not, please attach a PDF showing
> what the file should look.
> 
> Best regards. JBF

Your attachment is OK, I try the same think in windows 7 x64, with LibreOffice 3.5 beta1 Build ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4, and the result is NOT fine. I download the rtf file, insert a single space at the begining of file, and I save it in RTF. After I reopen, the hungarian characters was changed. I attache the PDF export of results.
For tomorrow, I make some tests in linux and windows xp.
Comment 4 Ákos 2011-12-18 09:39:43 UTC
Created attachment 54541 [details]
Save errors after resave in RTF.
Comment 5 Ákos 2011-12-19 04:33:36 UTC
I test the error in linux (xubuntu 10.10, x32, LO3.5-beta1). I open the RTF file, insert a space before the 1st character, and I save it in RTF too. After I open it, everything is OK, the hungarian specific characters was appear correct.

I make the same test in Windows XP English, with LO3.5 Beta1 and after I reopen the changed RTF the file is changed, like in Windows 7, and the result is the same, like in attached PDF (Save errors after resave in RTF).
Comment 6 s-joyemusequna 2012-01-26 11:07:22 UTC
Created attachment 56195 [details]
Same resaved file opened with Word 2003 and LibO 3.4.4 (chinese characters)


The attachment "54541: Save errors after resave in RTF." displays the file when opened with LibO 3.5 RC1.

When the resaved file is opened with LibO 3.4.4 or Word 2007 (Windows XP and Windows Vista 64), it displays partly chinese characters.

resaved_file_opened_with_LibO_3_4_4.pdf (resaved file opened with LibO 3.4.4)
resaved_file_opened_with_Word_2007.pdf (resaved file opened with Word 2007)

This is a regression. If the file is re-saved with LibO 3.4.4, it is displayed correctly with LibO 3.4.4, LibO 3.5 RC1, and Word 2007.
Comment 7 Michael Meeks 2012-02-22 03:40:13 UTC
hungarian characters in RTF export, surely one for Miklos :-)
Comment 8 Miklos Vajna 2012-02-22 07:41:40 UTC
As the summary says, this sounds like more an import issue. Will have a look.
Comment 9 Not Assigned 2012-02-22 08:16:20 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0915f1b3d77afa694a2ca692aec307846827da99

fdo#42465 fix RTF import of unicode characters with backwards compatibility
Comment 10 Miklos Vajna 2012-02-22 08:24:53 UTC
So I could not reproduce this with 3.5.0, I think the problem of the reporter is a duplicate of bug 42109 (which is already fixed in 3.5.0). However the problem was re-introduced in master with a fix for bug 45543, the above commit fixes that.

I'll make sure to backport the fix for bug 45543 and this bug at the same time to -3-5 to avoid regressions in that branch.
Comment 11 Not Assigned 2012-02-22 09:02:02 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=938ddf379004d9696a005ed612994576e2d7cca0

testcase for fdo#42465
Comment 12 Jean-Baptiste Faure 2012-03-19 14:46:47 UTC
Fix confirmed in LO 3.5.1. Closing. Thank you.