Bug 42473 - FILEASSOC During execution of group policy Libreoffice associates with Word files
Summary: FILEASSOC During execution of group policy Libreoffice associates with Word f...
Status: RESOLVED DUPLICATE of bug 39791
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 48301 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-11-01 05:51 UTC by Michail Pappas
Modified: 2012-05-30 21:53 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
install log (587.19 KB, application/octet-stream)
2012-03-14 09:10 UTC, Lionel Elie Mamane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michail Pappas 2011-11-01 05:51:01 UTC
I had a deployment of Openoffice, either alone on windows or alongside MS Office. Deployment was performed via two different policies, one that associates MS Office files with Oo (for those systems where MS office is not installed) and one that does fiddle with associations for the other systems.

I am now gradually moving into Libreoffice. I have two group policies. The problem is for the one that is not associating MS office files with libreoffice. In this case I have a single transform file that specifies the following in property:
* ADDLOCAL = ALL
* REMOVE = gm_o_Quickstart,gm_o_jf_Palm,gm_o_jf_Palm_Aportisdoc,gm_o_jf_Pocketpc,gm_o_jf_Pocketpc_Pocket_Word,gm_o_jf_Pocketpc_Pocket_Excel,gm_o_Xsltfiltersamples,gm_o_Testtool

End result (and problem): after application of this policy where MS office is installed, .doc files are associated with Libreoffice. However .xls files remain associated with Libreoffice.

Tested these on Windows XP SP3 clients (Greek locale). Server is Windows Server 2003.
Comment 1 Michail Pappas 2011-11-01 05:52:36 UTC
Pardon my mistake: in paragraph "End result (and problem): after application of this policy where MS office is installed, .doc files are associated with Libreoffice. However .xls files remain associated with Libreoffice." the last words should be "...However .xls files remain correctly associated with MS Office."
Comment 2 Michail Pappas 2011-11-01 05:56:58 UTC
Additional info: setting via policy also REGISTER_NO_MSO_TYPES to "1" does not resolve the issue, Libreoffice again steals associations...
Comment 3 Michail Pappas 2011-11-01 06:28:34 UTC
Ok, there is definitely something broken here. Even installing via msiexec /i \\path_to_admin_installation\libreoffice34.msi has .DOC files associated with LibreOffice, although in the .msi file Property REGISTER_ALL_MSO_TYPES is set to false (0) and also the various REGISTER_DOC properties are all set to false as well...
Comment 4 Chris Woollard 2011-12-15 03:30:19 UTC
I also have this issue on Libreoffice 3.4.4

thanks
chris
Comment 5 Michail Pappas 2012-01-20 02:12:25 UTC
Can someone confirm whether this is also applicable for 3.5.0 beta3?

I consider this bug to be a blocker for parallel installations of LibO alongside MS Office...
Comment 6 Denis Chebotarev 2012-03-01 22:28:08 UTC
(In reply to comment #5)
> Can someone confirm whether this is also applicable for 3.5.0 beta3?
> 
> I consider this bug to be a blocker for parallel installations of LibO
> alongside MS Office...

Confirmed @ LibreOffice 3.5.0rc3
Comment 7 Lionel Elie Mamane 2012-03-14 09:10:48 UTC
Created attachment 58440 [details]
install log

Got the same problem on unattended install of 3.5.1rc2 from machine startup script (executing as SYSTEM account). Here's the msiexec log.
Comment 8 sauron99 2012-04-13 01:18:12 UTC
Same problem here and this is my bug report to this https://bugs.freedesktop.org/show_bug.cgi?id=48301

It's a really really bad bug and Im not able to deploy LibO anymore until this is fixed. A lot of users are mad with me due to this :).

Please tell us how we can help to resolve this.
Comment 9 Michail Pappas 2012-04-13 03:27:41 UTC
*** Bug 48301 has been marked as a duplicate of this bug. ***
Comment 10 Michail Pappas 2012-04-18 22:52:05 UTC
Can someone please report whether this persists with the released 3.5.2?
Comment 11 sasha.libreoffice 2012-04-19 01:33:42 UTC
May be someone can provide REG files for user can easily fix this problem. Those files can be created, i.e. by exporting appropriate branches of registry from correctly worked computer. And user will just run REG file and fix problem. (Just my IMHO)
Comment 12 sauron99 2012-04-23 22:59:37 UTC
(In reply to comment #10)
> Can someone please report whether this persists with the released 3.5.2?

I have tested it yesterday at 4 PC´s. One of them failed again and lost all file associations like .doc .odt .xls and so on. The other ones worked fine.
Comment 13 Michail Pappas 2012-04-24 00:08:39 UTC
(In reply to comment #12)
> (In reply to comment #10)
> > Can someone please report whether this persists with the released 3.5.2?
> 
> I have tested it yesterday at 4 PC´s. One of them failed again and lost all
> file associations like .doc .odt .xls and so on. The other ones worked fine.

Please clarify whether your issue is the one described in this thread, that is installation via group policy or via /qn, associates LibO with .doc, regardless of user settings.

Please report whether you've tested this in the following manner and if not, please re-test using the procedure below: find a system where openoffice/libreoffice is not installed and make sure that .doc files are opened by Windows wordpad. Then do the following:

1) Download the Libreoffice installation (.msi) file to your desktop
2) Start->Programs->Accessories->Command prompt
3) In the box that will open, make a "cd" to the desktop directory. Then enter:
msiexec /i nameoflibreoffice.msi REGISTER_NO_MSO_TYPES=1 /qn

Nothing will be displayed, but you can tell when installation is finished when a Libreoffice icon will appear on screen.

Then double click a .doc file. Does it open with Libreoffice or with Wordpad?
Comment 14 sauron99 2012-04-24 03:55:05 UTC
I have done the installation via GPO in two different ways. 
One client got LibO with a .mst file selected REGISTER_NO_MSO_TYPE , that worked out. The other three clients got it with REGISTER_ALL_MSO_TYPE. Two of them worked as well, but the third one lost all Office related associations. 

Thats exactly the same behavior as I have had it with 3.5.1. Some clients accepted the changes and some not. Even when you install it manually it happens from time to time. But I haven't thested the manually installation with 3.5.2 yet.
Comment 15 sauron99 2012-04-29 00:41:28 UTC
So now I have tested the manually installation as well.
The Bug is still showing up when I install it as you mentioned it to me.
He lost all office related associations.
Comment 16 sauron99 2012-05-01 04:41:31 UTC
Now I have done the installation manually again on a Windows XP SP3 with no LibreOffice installed before. Microsoft Office 2003 was installed on this system.
After LibreOffice he associates Writer with all .doc files. The .odt .xls stuff and so on worked fine.
Comment 17 Michail Pappas 2012-05-01 08:24:11 UTC
(In reply to comment #16)
> Now I have done the installation manually again on a Windows XP SP3 with no
> LibreOffice installed before. Microsoft Office 2003 was installed on this
> system.
> After LibreOffice he associates Writer with all .doc files. The .odt .xls stuff
> and so on worked fine.

Did you use:
    msiexec /i <liboffice.msi> /qn

or something else? Because in my tests it seems like this issue has been resolved in 3.5.2...
Comment 18 sauron99 2012-05-01 21:13:51 UTC
In this case I used the GUI.
Comment 19 Michail Pappas 2012-05-01 21:56:00 UTC
(In reply to comment #18)
> In this case I used the GUI.

Since this bug report is about a problem exhibited in group policy installation / msiexec, would you be so kind and check if installing libO with:
   msiexec /i <liboffice.msi> /qn

...on the system with windows xp/office 2k3, associates word files with LibO?
Comment 20 Michail Pappas 2012-05-03 01:55:54 UTC
Well something fishy happens with domain computers. Installation on my domain computers results stolen associations for Word files. Please see https://bugs.freedesktop.org/show_bug.cgi?id=39791#c6 for which I have provided MSI logs.

Perhaps bug 42473 should be marked a duplicate of bug 39791?
Comment 21 Rainer Bielefeld Retired 2012-05-03 02:21:55 UTC
I think we have enough observations to get this one s CONFIRMED.
I believe this one and "Bug 39791 - FILEASSOC LibreOffice installation steals .doc association from MS Office by default" are concerning the same problem, so I agree with Michael Pappas' DUP suggestion.

@Michael Pappas:
Thank you for your strategic thoughts, but your comment in Bug 37361 was not optimum. If you are sure that it's a MAB cite the Bug subject line and leave maximum 1 line reasoning (as you see in the comment before). If you do not know ask for help in the Bug itself, may be by adding someone from QA-Team to CC.

Please feel free to reopen this Bug if after fix for bug 39791 a problem is remaining.

*** This bug has been marked as a duplicate of bug 39791 ***
Comment 22 Michail Pappas 2012-05-03 03:43:39 UTC
(In reply to comment #21)
> @Michael Pappas:
> Thank you for your strategic thoughts, but your comment in Bug 37361 was not
> optimum. [...]

Sorry about that, my description was inappropriate in the specific bug context. Will try to be more careful next time.
Comment 23 sauron99 2012-05-03 06:42:50 UTC
I have tested it now with 3.5.3 on 3 computers. So far it seems to work, even if the changelog from 3.5.3 does not say anything related to this bug. 
I will do some further test's on different machines right now and will report it as soon as I can.
Comment 24 sauron99 2012-05-03 11:05:48 UTC
Hi,
so far I have tested it with two further system's which already had installed LibO 3.5.2 before. On these clients it worked as well. 

So it would be nice if someone who is packaging LibO would have a look into this. Some preferences or something seemed to have a side effect which solved this bug.
Comment 25 sauron99 2012-05-29 23:12:56 UTC
Yesterday I had to update LibreOffice on a Windows Server 2k3 R2. It was an update from 3.4.X to 3.5.3 and sadly I have to tell you that he associates LibreOffice with .doc, after installation. 

The excel things went well, but .doc was broken. I have choosen the normal installation way with the GUI.

So it seems that this is still present in some cases.
Comment 26 Michail Pappas 2012-05-30 21:53:21 UTC
@Sauron: Which version of Microsoft Office was installed in the systems on which the bug appeared? Since this bug has been marked a duplicate of bug# 39791, I would suggest to continue reporting and discussion in the latter bug report.