Bug Hunting Session
Bug 42577 - RTL UI toolbar view mirrored (docking and expand at the wrong side) when Insert Object Formula
Summary: RTL UI toolbar view mirrored (docking and expand at the wrong side) when Inse...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2011-11-03 21:07 UTC by Ibrahim
Modified: 2012-12-04 09:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot 2/2 (320.34 KB, image/jpeg)
2011-11-03 21:07 UTC, Ibrahim
Details
LibreOffice 3.5.4.2-ScreenShot (49.58 KB, image/png)
2012-06-12 03:34 UTC, Faisal Menawer
Details
LibreOffice 3.5.4.2-ScreenShot 2 (57.98 KB, image/png)
2012-06-13 02:48 UTC, Faisal Menawer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ibrahim 2011-11-03 21:07:33 UTC
Created attachment 53137 [details]
screenshot 2/2

Problem description: 
When insert a formula by (Insert > Object > Formula) in Writer or Impress or Calc or Draw, the menu buttons of toolbars appear in wrong side. (see below screenshots)
http://i290.photobucket.com/albums/ll251/ibraheem_alex/Untitled-1-1.jpg
http://i290.photobucket.com/albums/ll251/ibraheem_alex/Untitled-2-1.jpg


Steps to reproduce:
1. Open Writer or Impress or Calc or Draw.
2. Change the language of UI to Arabic language.
3. Insert a formula by (Insert > Object > Formula).
4. Note: the menu buttons of toolbars appear at right of toolbar while must be appear at left of toolbar in Arabic UI.

Current behavior:
The menu buttons of toolbars appear at right of toolbar while must be at left of toolbar in Arabic UI.

Expected behavior:
same as Current behavior.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Comment 1 Rainer Bielefeld Retired 2011-11-04 01:59:12 UTC
[Reproducible] with "LibreOffice 3.4.4RC2  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]"

- Reported with Bug Submission Assistant -
Comment 2 Rainer Bielefeld Retired 2011-12-18 21:39:44 UTC
Related to "Bug 43901 - RTL Toolbar icons order becomes opposite when in OLE object edit mode"?
Comment 3 Lior Kaplan 2011-12-19 00:37:01 UTC
Yes, related but not duplicate (unless the problem comes from the same code)
Comment 4 Faisal Menawer 2012-06-12 03:34:22 UTC
Created attachment 62926 [details]
LibreOffice 3.5.4.2-ScreenShot

the bug not found on Fedora 16 64bit-LibreOffice 3.5.4.2
Comment 5 Lior Kaplan 2012-06-12 06:29:34 UTC
@Faisal - Your screen shot doesn't show any attempt to enter a formula, but seems to be just showing the RTL UI.

I can reproduce described bug in 3.5.4.2 on Debian 64bit.
Comment 6 Faisal Menawer 2012-06-13 02:48:37 UTC
Created attachment 62957 [details]
LibreOffice 3.5.4.2-ScreenShot 2

Sorry about the first Screenshot.

the bug still exist on Fedora 16 64bit-LibreOffice 3.5.4.2.
Comment 7 Lior Kaplan 2012-12-04 09:36:51 UTC
Verified on a private build. Fix was done in commit aa61177f1d339422acb3322c8851962cd1ca7466