Bug 42604 - Crash on moving tabs
Summary: Crash on moving tabs
Status: RESOLVED DUPLICATE of bug 40298
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected)
3.4.4 release
Hardware: Other Linux (All)
: high major
Assignee: Not Assigned
Depends on:
Reported: 2011-11-04 15:43 UTC by Robert Downing
Modified: 2011-12-22 13:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:

Screenshot of Spreadsheet workbook details (properties) (260.50 KB, image/jpeg)
2011-12-08 21:37 UTC, Robert Downing

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Downing 2011-11-04 15:43:58 UTC
Multi-tab workbook, no graphics, named tabs. Try to move tabs to change order in workbook, calc crashes IMMEDIATELY! EVERY TIME!
Comment 1 vitriol 2011-11-04 22:48:39 UTC
Probably duplicate of Bug 41073. Do you have installed the extension ""Default Settings For Japanese"?
Comment 2 Robert Downing 2011-11-05 05:32:55 UTC
No, do not have that extension installed. 

This is new behavior, just having started, with no accompanying update or extension installation.
Comment 3 Robert Sharp 2011-11-22 08:08:45 UTC
I have experienced this bug as well. Happens when I drag a workbook tab from one place to another. Crashes when you release the tab in the new location. Note this happens on every spreadsheet I have tried, including a new one. I have no fancy add-ons.
Comment 4 Markus Mohrhard 2011-12-08 18:24:28 UTC
Can you give some more details, please. I can't reproduce it here. Neither with my 3-4, 3-5 nor my master build.

Did you edit a cell while moving sheets?
Comment 5 Markus Mohrhard 2011-12-08 18:24:42 UTC
And do you use Ubuntu?
Comment 6 Robert Downing 2011-12-08 21:37:04 UTC
Created attachment 54263 [details]
Screenshot of Spreadsheet workbook details (properties)

Only way to show document properties without sending workbook. Workbook is proprietary & confidential.
Comment 7 Robert Downing 2011-12-08 21:37:44 UTC
Sorry it took so long...

KDE 8.0
LibreOffice 3.4.4 
OOO340m1 (Build:402)
Name     Firefox
Version  8.0
User Agent Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0

Just tried it again. Workbook has ~ 32 tabs, moved one, took down both Spreadsheet & Writer. [Document details in attached screenshot]

This is different workbook than last test.
Comment 8 Markus Mohrhard 2011-12-09 11:06:43 UTC
I suspect either a bug in the KDE integration or in one of ubuntu/debian patches?

Could you try to get a stack trace with debugging symbols?
Comment 9 Robert Downing 2011-12-09 11:54:43 UTC
As this is not ever caught by the crash handler, I'm going to need help in capturing the info you need.

I have no problem in providing the supporting information needed, I just need to be cognizant of the confidentiality of the document(s) in question.
Comment 10 Markus Mohrhard 2011-12-09 12:53:43 UTC
Here is a short log how to do that: http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29

The corresponding Ubuntu package should be libreoffice-dbg
Comment 11 Robert Downing 2011-12-14 11:08:32 UTC
Have installed libreoffice-dbg debug package 1:3.4.4-0ubuntu1

Crashes *are not* caught, no debug information is created. Ever. No matter what Libre app crashes, nothing is ever caught.

Yes, this problem is still reproducable.
Comment 12 Gaba 2011-12-20 10:15:30 UTC
I can reproduce this easily in LibreOffice Calc. I just open a fresh new document and try to move any tab anywhere. Immediate crash.

LibreOffice 3.4.4 
OOO340m1 (Build:402)

Ubuntu 11.10 + KDE 4.7.4
Comment 13 Gaba 2011-12-20 11:18:37 UTC
Reinstalled LibreOffice with NO KDE integration package (libreoffice-kde) and the issue is gone (along with another one where the caption on mouse-over wouldn't show; only a black rectangle)
Comment 14 Markus Mohrhard 2011-12-20 13:33:43 UTC
KDE related.

Comment 15 Robert Downing 2011-12-20 14:13:27 UTC
In evaluating the comment from Gaba [2011-12-20] performed the following:

1. Completely removed LibreOffice-kde
2. Did *NOT* remove or reinstall LibreOffice
3. Rebooted
4. Tested with 3.4.4 of LibreOffice

Problem is resolved. No further crashes. No further annoying little black boxes instead of tool-tips.

Problem is almost certainly with LibreOffice-kde

Closed as far as I'm concerned.

Thanks, Gaba!
Comment 16 Luboš Luňák 2011-12-22 03:35:53 UTC

*** This bug has been marked as a duplicate of bug 40298 ***
Comment 17 Björn Michaelsen 2011-12-22 05:52:34 UTC
Comment 18 Robert Downing 2011-12-22 13:20:58 UTC
Sorry, didn't know that I was to close this.