Bug Hunting Session
Bug 42660 - Significant slow startup times and increased memory utilization compared to Oo 3.3 (FILEOPEN)
Summary: Significant slow startup times and increased memory utilization compared to O...
Status: CLOSED DUPLICATE of bug 40481
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86 (IA32) Windows (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-07 02:03 UTC by Michail Pappas
Modified: 2011-12-24 04:32 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michail Pappas 2011-11-07 02:03:23 UTC
PLEASE NOTE THAT THE FOLLOWING AFFECTS BOTH THE WORD PROCESSOR AS WELL AS THE SPREADSHEET COMPONENTS AND NOT ONLY THE LATTER ONE

Problem description:
====================
I have been operating an installation of approximately 150+ pc's having OpenOffice/LibreOffice deployed via active directory group policy. Recently, I made a large switch to LibreOffice 3.4.3. Ever since I have been receiving tons of complains for slow loading times, from former Oo users. The Oo version that was installed was 3.3.

Checking things out I can see that the Libreoffice installation is mammoth: ~1Gb on disk. Of course this might not have anything to do with the startup times. OTOH though:

* watching event viewer I can see it takes more than 10" for the Libreoffice splash screen to appear. This happens after soffice.bin has allocated memory in the region of 120-140Mbytes... The application finally opens after some more 10-15". At that time LibO consumes around 120Mb of RAM. Note that my PCs mostly have 512Mb of RAM (Windows XP 32-bit clients, with the Panda AV bloat). And yes, I know that is not much, however we are running a very tight budget here.
* we did not have the same behavior with Oo 3.3

Some tests:
a) Blank worksheet document:
122Mb RAM used by LibO (3.4.3 final) and 110 by Oo (3.3)
b) A two worksheet small (~57Kbyte) Excel file: 186Mbyte used by LibO compared to 106 used by Oo! Obviously here the system starves for system RAM and swaps much faster compared to Oo.

To reproduce:
=============
1) Fire up a loaded 512Mbyte RAM machine (or a VM) running Windows XP 32-bit and an AV 

2) Disable quickstarter for both Oo and LibO (to avoid memory getting wasted in a 512Mb system)

3) Use a simple document/worksheet to compare memory utilization for these two software packages and their difference.

I was under the impression that LibO (3.3) had undergone some serious optimization/cleaning that I'd expect would produce a smaller memory footprint. Not a larger one and definitely not that bigger.
Comment 1 Michail Pappas 2011-11-13 22:35:32 UTC
Please consider handling this issue with an increased priority: complaints from my users have reached the point where I am seriously considering replacing LibO with Oo...
Comment 2 Michail Pappas 2011-11-30 23:00:43 UTC
I know this is collaborative software and asking for something free to be fixed is straining things. But I must say that it is a pity indeed that a critical issue like this one did not end up in the hands of a developer...

Once more: OpenOffice on 512Mb RAM systems is just fine. Libreoffice 3.4.3 is, comparatively, a RAM-starved behemoth. Loading times suffer a lot.

Please do have a look at this issue, I am sure it can easily be reproduced in a 512Mbyte Virtual machine!

Remember that LibO requirements state "256 Mb RAM (512 Mb RAM recommended);"...
Comment 3 Michail Pappas 2011-12-05 23:15:07 UTC
Seems duplicate of #40481

*** This bug has been marked as a duplicate of bug 40481 ***
Comment 4 Björn Michaelsen 2011-12-24 04:32:21 UTC
closing