Download it now!
Bug 42979 - Wrong application icon on the MSVC Master
Summary: Wrong application icon on the MSVC Master
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-11-16 02:47 UTC by Pedro
Modified: 2011-12-07 12:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2011-11-16 02:47:34 UTC
The icon displayed on the top left corner of the LibreOffice window is a strange "house" instead of the application icon. The same "house" icon shows on all LO modules.

Here is a screenshot from another bug report
https://bugs.freedesktop.org/attachment.cgi?id=53537

In this case the icon on the top left corner should be the Calc icon.
Comment 1 Rainer Bielefeld Retired 2011-11-16 11:16:22 UTC
[Reproducible] with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [(Build ID:  d38713d-5d03837-ca7e6f5-c4bb9bd-ce71330)]" (Voreppe 111115). 

Not in MinGW.

I will try to find out whether it's intended or a bug
Comment 2 Rainer Bielefeld Retired 2011-11-24 03:10:28 UTC
Seems to cause no bigger problems, but not acceptable for release
Comment 3 Petr Mladek 2011-11-24 06:30:22 UTC
I agree that we should fix this before the final release => it is perfectly fine to keep it in most annoying bugs. On the other hand, it is rather cosmetic problem. It is far from blocking anyone using the application => lovering the severity.

Thorsten, you usually take care of the icon's related bugs. Could you please have a look?
Comment 4 Pedro 2011-11-24 07:43:34 UTC
It is not simply cosmetic. It is also functional.

The icon in the program window is reflected in the icon displayed on the taskbar.

This means that you can not visually identify your open spreadsheets from your text documents in the taskbar.

IMO this is a functional blocker and since it is a regression it must be a blocker?
Comment 5 Thorsten Behrens (CIB) 2011-11-25 15:31:05 UTC
Hrm - that's the old Star default application icon - I wonder who played with that ...
Comment 6 Andras Timar 2011-12-05 00:19:35 UTC
(In reply to comment #5)
> Hrm - that's the old Star default application icon - I wonder who played with
> that ...

It was the side effect of wrong linker switch of subsystem of soffice.exe, see bug 42914. BTW I removed the old icon from source tree, it was not used normally.
Comment 7 Andras Timar 2011-12-07 04:53:36 UTC
Well, I see this problem coming back in the build I completed this morning. I have no clue at the moment.
Comment 8 Andras Timar 2011-12-07 08:40:52 UTC
So, after some investigation, I don't really understand why I saw this fixed in my build, it must have been some temporary effect. Application icons are supposed to come from soffice.bin which does not have resources at the moment. Maybe it was result of some size optimization, because the same icon set is duplicated in soffice.exe (and Explorer use icons from soffice.exe). I'll try optimize for both size and functionality. :) BTW why do we have soffice.exe and soffice.bin instead of a single soffice.exe?
Comment 9 Andras Timar 2011-12-07 12:12:07 UTC
For 3.5 beta1 I made a quick fix, I link the icons to soffice.bin, too. Bug number 37740 deals with the duplicated icons, I'll fix that, too, later.
It is not worse, than that we have in 3.4.x.