Download it now!
Bug 42914 - Terminal (command) window is opened when launching any executable
Summary: Terminal (command) window is opened when launching any executable
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86 (IA32) Windows (All)
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 43845 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-11-14 04:34 UTC by Pedro
Modified: 2011-12-15 10:39 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of error message on master install (6.38 KB, image/png)
2011-11-14 06:59 UTC, Pedro
Details
Screenshot 'fdo#42914' (74.81 KB, image/png)
2011-11-14 09:26 UTC, manj_k
Details
Screenshot of command window (65.34 KB, image/png)
2011-11-24 07:25 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro 2011-11-14 04:34:38 UTC
Launching any executable opens a terminal (command) window before starting the executable. The terminal window shows the following message

NOTE: you should run 'diskperf -y' to enable the disk statistics

Obviously the terminal window can not be closed, otherwise it will terminate the program window.

This occurs for the Master MSVC (2011-11-09) and for Master MinGW (2011-11-13)

NOTE: Kendy asked me to add the link to the MinGW bugs (41883) but this is a general bug on the Master build running in Windows
Comment 1 Pedro 2011-11-14 06:59:09 UTC
Created attachment 53530 [details]
Screenshot of error message on master install

Correction: the message in the terminal window only shows with the MinGW binaries. The terminal window launched by the MSVC binaries is empty.

During install of the MSVC version I got the error shown in the attached image (I have no idea if this is related)
Comment 2 Regina Henschel 2011-11-14 08:38:11 UTC
I eee the same error with my LO3.5 build. I see in the WinXP task manager only one soffice.exe and one soffice.bin, as it should be. Closing either the terminal window or the Office will close the other part too.
Comment 3 manj_k 2011-11-14 09:25:51 UTC
LibO-dev 3.5.0 Build ID: 3f170f2-533e3c6-ca7e6f5-9125509-ce71330
[master~2011-11-13_04.17.45... (Voreppe_Win32_Tinderbox)]
on WinXP 32b

Starting 'scalc.exe' in 'program' folder shows "bar size width 759" in the command window (see attached screenshot 'fdo#42914').

See also 'Bug 42826 - Error message during installation'.
Comment 4 manj_k 2011-11-14 09:26:42 UTC
Created attachment 53537 [details]
Screenshot 'fdo#42914'
Comment 5 Pedro 2011-11-14 11:34:39 UTC
As a comment to manj_k's screenshot: please notice that the application icon on the top left corner is not the Calc icon. Independently of the module opened it always shows that same odd icon in the MSVC binaries. On the MinGW binaries the Windows standard icon is displayed, as reported in Bug 41898
Comment 6 Rainer Bielefeld Retired 2011-11-14 13:14:45 UTC
DUP of or related to "Bug 42826 - Error message during installation"?

I see various messages also with MSVC version.

Definitively not "Depends on: 41883", that one is only for MinGW specific bugs, so deleted. 

Lasting bug should be marked as 'Blocks "Bug 37361 LibreOffice 3.5 most annoying bugs"'
Comment 7 GerardF 2011-11-16 10:09:44 UTC
Add CC.
Comment 8 Rainer Bielefeld Retired 2011-11-24 03:08:17 UTC
Seems to cause no bigger problems, but not acceptable for release
Comment 9 Fridrich Strba 2011-11-24 06:27:28 UTC
Basically, one should add -mwindows to the linker flags for the exes. Will look at it if someone else does not look before.
Comment 10 Don't use this account, use tml@iki.fi 2011-11-24 06:47:48 UTC
Sigh, so this bug report now mentions at least five different problems. Why is it so hard to report just one thing in each bug report...?

Also, the corret term is "console window". Not "command window", not "terminal window". (And especially not "DOS box", although luckily nobody has even tried to use that term here...)

1) Starting the MSVC-built LO, an empty console window opens. Please, could we have a screenshot of that, or at least tell what the title of the console window says.

2) Starting a MinGW-built LO, a console window with the mysterious "NOTE: you should run 'diskperf -y' to enable the disk statistics" text appears. Again, screenshot pleast, or at least tell what the window title is.

3) Then in some cases during *installation*, the error message shown in the screenshot in comment #1 appears.

4) Then according to comment #3 a console window with the text "bar size width 759" appears when running Calc. (Without doing anything in it?)

5) Then some complaints about the "icon" displayed in the title bar in comment #5.

Now, I *think* we should in *this* bug concentrate on problem 1).
Comment 11 Regina Henschel 2011-11-24 07:25:27 UTC
Created attachment 53831 [details]
Screenshot of command window

The text in the title bar of the command window is the string, which I put in the property of the link, from which I launch soffice.exe.

I have compiled it with MSCV 2008 Express on WinXP (32bit).
Comment 12 Pedro 2011-11-24 07:37:21 UTC
(In reply to comment #10)
> Sigh, so this bug report now mentions at least five different problems. Why is
> it so hard to report just one thing in each bug report...?

It's not. I was just being lazy :)
 
> Also, the corret term is "console window". Not "command window", not "terminal
> window". (And especially not "DOS box", although luckily nobody has even tried
> to use that term here...)

Thank you for the correction. It's not really relevant since it's easily understandable. Are there physical punishments for users who use the expression "DOS box"? :)

> 1) Starting the MSVC-built LO, an empty console window opens. Please, could we
> have a screenshot of that, or at least tell what the title of the console
> window says.

The title of the console is the same as the filename of the link file. If I start LibO-Dev the console title is LibO-Dev and remains so even if the program window name changes (e.g. when starting a new Text Document.
Comment 13 Andras Timar 2011-11-30 03:21:30 UTC
I fixed it with an ugly hack for MSVC builds. 
http://cgit.freedesktop.org/libreoffice/core/commit/?id=d76479654748454e280ac48217fb0036bc5940a1
Comment 14 Andras Timar 2011-12-01 01:26:18 UTC
(In reply to comment #13)
> I fixed it with an ugly hack for MSVC builds. 
> http://cgit.freedesktop.org/libreoffice/core/commit/?id=d76479654748454e280ac48217fb0036bc5940a1

Just for the record, Bjoern fixed it a few hours later in the correct way for both MinGW and MSVC.
Comment 15 Pedro 2011-12-01 01:42:38 UTC
I can confirm that it is indeed fixed in MSVC build 130028f-b211287-090bcba-45cf606-05891e7 and in MinGW build 93e3a869-b211287-090bcba-45cf606
Comment 16 Rainer Bielefeld Retired 2011-12-01 02:30:18 UTC
Yes, works fine with Server installation of  Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) GERMAN UI [Build ID: 130028f-b211287-090bcba-45cf606-05891e7]" Win-x86@9-Voreppe - 111130).

@pedlino:
From what tinderbox did you get your build? 

I'm currently observing strange differences between the builds from different tinderboxes, but it also might be that we have big changes from build to build.
Comment 17 Pedro 2011-12-01 03:04:36 UTC
@Rainer

The MSVC from Win-x86_9 and the MinGW from Win-x86_7

And as you notice, the MSVC build "numbers" aren't even comparable with the MinGW

That is why I submitted this request
https://bugs.freedesktop.org/show_bug.cgi?id=43031

I think it's fairly important that not only developers but also people in QA can understand if the build they downloaded is based on a newer or older source...
Comment 18 Rainer Bielefeld Retired 2011-12-01 03:24:37 UTC
@pedlino
I know. I decided to do no further MinGW tests because it's too buggy. I would be interested to check whether there are differences (concerning general bugs) between Win-x86@6 and Win-x86@9
Comment 19 Pedro 2011-12-01 04:11:31 UTC
(In reply to comment #18)
> @pedlino
> I know. I decided to do no further MinGW tests because it's too buggy. I would
> be interested to check whether there are differences (concerning general bugs)
> between Win-x86@6 and Win-x86@9

The only obstacle is that tinderbox #6 hasn't been able to finish successfully since the 28th so the builds aren't based on the same source code...
Comment 20 Rainer Bielefeld Retired 2011-12-02 11:26:35 UTC
Fix is not in Server Installation of  "LibreOffice 3.5.0 Beta0  - WIN7 Home Premium (64bit) German UI [Build:ef91e38-b1d4df6-090bcba-45cf606-05891e7]"
Comment 21 Andras Timar 2011-12-05 00:22:17 UTC
(In reply to comment #20)
> Fix is not in Server Installation of  "LibreOffice 3.5.0 Beta0  - WIN7 Home
> Premium (64bit) German UI [Build:ef91e38-b1d4df6-090bcba-45cf606-05891e7]"

Yes, it is not there, because beta0 was tagged before the fix was committed. Yet, it is fixed. I saw it fixed in my own build.
Comment 22 Rainer Bielefeld Retired 2011-12-05 03:25:22 UTC
In between I know, thanks for closing
Comment 23 Rainer Bielefeld Retired 2011-12-15 10:39:01 UTC
*** Bug 43845 has been marked as a duplicate of this bug. ***