Bug 43007 - Writer vanishes on opening document (no crash report, just dies) - FILEOPEN
Summary: Writer vanishes on opening document (no crash report, just dies) - FILEOPEN
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL: http://nic.gen.nz/temp/AOAMember3Fold...
Whiteboard: target:3.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-11-16 19:38 UTC by Walter Nicholls
Modified: 2012-01-09 14:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
bt with symbols on 3.4.4 (11.55 KB, text/plain)
2011-12-01 13:47 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Walter Nicholls 2011-11-16 19:38:21 UTC
I managed to create a document which now causes LO Writer to explode open opening.

Previously while editing the document,  did have Writer vanish a couple of times, while moving a frame: I conclude therefore that frames have something to do with it! Finally it reached a point where my saved version was no longer openable.  Document is attached.

Ubuntu Oneiric, Libreoffice is Version: 1:3.4.3-3ubuntu2;  This document was created while still running +Ubuntu Natty (and LO 3.4 from PPA from memory), and the same behaviour occurred then.  I haven't had any problems of this kind with any other documents.

Running soffice from the console, I did once see this printed after the crash.

LibreOffice(9091)/kio (KDirModel) KDirModelPrivate::_k_slotDeleteItems: No node found for item that was just removed: KUrl("file:///data/organ/aoa/brochure/Organ 15") 
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x6c004cf

Usually the message starts at the "X Error: Badwindow" .. which is probabl

The url it refers to points to a JPEG file, which exists. renaming this file did not change behaviour, and I do not expect any images to be linked - although regardless LO should no explode like this.

How to reproduce.
1. Start LibreOffice
2. File -> Open -> select the document. Click OK

Observed:
 Document appears to open and shows for a fraction of a second, before the entire LO application (including other open windows with other documents!) completely disappears 

Expected:
File to open and be editable. No crash. possibly error message about file being corrupt, if this indeed is the case.

I've tagged as Major because, while only one document so far, the effects are catastrophic (no recovery document, other open documents destroyed).
Comment 1 Walter Nicholls 2011-11-16 19:42:45 UTC
File that caused the crash is over attachment size limited: I have set in the URL for this bug, and also here it is: http://nic.gen.nz/temp/AOAMember3Fold_Crashed_Libreoffice.odt
Comment 2 Walter Nicholls 2011-11-16 19:53:21 UTC
This file opened, without crashing, using Openoffice.org 3.2.1 running on Windows XP. I made a small change (moved one of the frames), resaved it, and then tried to open again with the Linux machine.
Same results: LO Writer exploded.
Comment 3 Walter Nicholls 2011-11-17 00:17:34 UTC
I have also now tried on my wife's computer - Ubuntu "natty" - Libreoffice 3.3.4: no crash. (Toshiba laptop, Intel graphics)
So far only on my computer .. Asus M51S laptop, nvidia graphics) if that helps.
Comment 4 Walter Nicholls 2011-11-17 00:48:15 UTC
See also bug #42147  which sounds an awful lot like the same problem. My file has large frames (1/3 of A4 page: it's trying to do DTP); also bugs #42534, possibly #40608.
Comment 5 Walter Nicholls 2011-11-17 16:58:59 UTC
I installed libreoffice 3.3 via Deb files and this opens this document
From Help->About:
  LibreOffice 3.3.4 
  OOO330m19 (Build:401)
  tag libreoffice-3.3.4.1

So LibO 3.3 ok, 3.4 broken?
Comment 6 Julien Nabet 2011-12-01 13:35:57 UTC
No crash here on 3.4.4 with PC Debian x86-32.
Have you reproduce this pb with 3.4.4 ?
Comment 7 Julien Nabet 2011-12-01 13:47:55 UTC
Created attachment 54041 [details]
bt with symbols on 3.4.4

I made a mistake on the previous message. I didn't reproduce the pb with master branch (future 3.5) but I reproduced the pb with 3.4.4.
I attached the bt of the this pb.
Sorry for the confusion.
Comment 8 Julien Nabet 2011-12-01 13:52:51 UTC
According to the bt, it may be the same as fdo#42147
Comment 9 Walter Nicholls 2011-12-12 18:10:08 UTC
Sounds like good news .. I'm looking forward to 3.4.5.  (In the meantime, I am able to fire up 3.3 on any problem documents).
Comment 10 tester8 2012-01-09 14:30:11 UTC
LOdev 3.5.0beta2 
4ca392c-760cc4d-f39cf3d-1b2857e-60db978
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic Russian UI
Comment 11 tester8 2012-01-09 14:31:37 UTC
NOT reproduced.