Download it now!
Bug 43030 - Cannot upscale video files inserted into an Impress presentation
Summary: Cannot upscale video files inserted into an Impress presentation
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: medium trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 42183 (view as bug list)
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2011-11-17 08:52 UTC by Nick Sharp
Modified: 2013-08-16 13:32 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
LO Impress 3.3.4 showing video size dropdown set to "Scaled" (187.83 KB, image/jpeg)
2012-03-22 11:14 UTC, Nick Sharp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Sharp 2011-11-17 08:52:07 UTC
Prior to 3.4.3, I could scale videos once inserted into a presentation by selecting the dropdown box in the Media Playback toolbar.
Now that dropdown box is greyed out.
The option to selected "Scaled" is present in 3.3 and, according to other users, in 3.4 under Linux. So this could be just a problem in Windows.
Comment 1 Gene Kohlenberg 2012-01-05 06:37:27 UTC
I also have this problem on my XP Home SP3 and XP Media Center SP3 computers for both 3.4.3 and 3.4.4.
Comment 2 sasha.libreoffice 2012-03-22 10:28:14 UTC
> Prior to 3.4.3, I could scale videos once inserted into a presentation by
> selecting the dropdown box in the Media Playback toolbar.
Please, attach screenshot of this working dropdown box if still available somewhere old installation. I agree that it was in OpenOffice. But I can not find it in 3.4.3 and 3.5.1 on Windows and in 3.3.4 and 3.5.1 on Linux.
Comment 3 Nick Sharp 2012-03-22 11:14:53 UTC
Created attachment 58884 [details]
LO Impress 3.3.4 showing video size dropdown set to "Scaled"
Comment 4 sasha.libreoffice 2012-03-22 22:12:04 UTC
Thanks for screenshot. Changing status to New and adding status Regression
Comment 5 sasha.libreoffice 2012-04-17 03:46:51 UTC
*** Bug 42183 has been marked as a duplicate of this bug. ***
Comment 6 Gary 2012-04-18 12:25:35 UTC
(In reply to comment #5)
> *** Bug 42183 has been marked as a duplicate of this bug. ***

Does this mean that a solution has been determined or is being actively worked on?
Comment 7 sasha.libreoffice 2012-04-18 22:06:55 UTC
At least I hope on it. Without this Impress almost unusable.
Comment 8 Michael Meeks 2012-05-29 02:20:54 UTC
Can't scale video - sounds most annoying to me.
Comment 9 Michael Meeks 2012-05-29 02:52:25 UTC
It seems the right-click, position & size settings dialog still allows sizing, but something has got busted with in-sheet object sizing & that combo-box.
Comment 10 Julien Nabet 2012-11-01 07:36:59 UTC
Could someone give a link to a video file supported by Impress?
When trying to reproduce, I've got only the file format is not supported.
Comment 11 sasha.libreoffice 2012-11-01 08:22:01 UTC
> Could someone give a link to a video file supported by Impress?
Impress supports all video formats on Linux. It is because it uses Gstreamer. On Windows not tested yet. Just use Linux distros made in Europe, there Gstreamer and FFmpeg are not corrupted.

What about initial description of problem: reproduced in 3.6.2
Comment 12 Julien Nabet 2012-11-01 08:27:41 UTC
Sasha: I'm on pc Debian x86-64 testing updated today.
ffmpeg: Version: 6:0.8.3-7
Which gstreamer package should I install?
Comment 13 sasha.libreoffice 2012-11-01 09:08:37 UTC
> Which gstreamer package should I install?
I do not know. Sorry for this. In original Fedora video also not working. In RFR it working by default. I just switched from using Fedora to using RFR and problem with video and audio disappeared. I do not know how to solve this problem manually. May be exist such analogue of Debian, where all working by default, without manually repairing. Sorry for can not tell something useful. 
IMHO video should working by default in Mandriva and Mageia, because they made in France (no patents problem).
Comment 14 Michael Meeks 2012-12-20 19:31:43 UTC
I appear not to be able to use the combo-box in Linux either - which is somewhat strange. Then again - reading the code it looks (to my mind) somewhat horrific. In an age of GPU-based video scaling - is there any real need for magic multiples-of-two scaling anymore anyway ? it should be interpolated anyway in those cases.

So - I'm struggling for a use-case for this beyond overcoming some (I hope long dead) performance issue around media-playback.

I'd be inclined to remove the zoom feature and kill the complexity - unless someone is desperate for it ?

Why can the video not be scaled manually to the required size ? (quite possibly I'm missing the point of course but ... ;-)
Comment 15 sasha.libreoffice 2012-12-21 06:15:29 UTC
IMHO full screen mode means that video will scaled to entire screen automatically depend-less of resolution of screen. It means that presentation created on computer with one resolution will correctly working on computer with different resolution.
Manually scaling means some certain resolution, for exactly 800x600 and no other. If unless resolution provided in percents. But then problem will be with different ratio of screen.
Comment 16 Joel Madero 2013-02-12 17:15:41 UTC
3.5 has come to the end of its life cycle. Multiple duplicates of this bug, regression, plus confirmation from Michael that this is a MAB - moving this to 3.6 MAB.

@Nick - thanks for your ongoing patience, hopefully Michael can tackle this one soon :)
Comment 17 Gene Kohlenberg 2013-06-10 16:45:19 UTC
Until LO4.1.0.0.Beta1 I could use the "Position and Size" to scale a video by typing a number in either the vertical or horizontal box with the "Keep Scale" checked (ticked).

With version 4.1 the vertical size of the video will not change even though the Position and Size option shows a change in the height when I type a change in the horizontal box.  This is confirmed by opening "Position and Size" again to see that the value for the vertical size has not changed.

Now I can only scale the height of the video by dragging the center green box on the top or bottom of the video image on the slide.  This is quite inconvenient.
Comment 18 Michael Meeks 2013-07-25 14:19:47 UTC
Min - I guess this is something that is VLC relevant ...
Comment 19 tommy27 2013-08-11 07:21:33 UTC
@Nick Sharp 
do you still experience this issue with recent 4.0.4 or 4.1.0 releases?
Comment 20 Nick Sharp 2013-08-16 12:05:13 UTC
I can now resize videos, but the controls on the toolbar are greyed out.


On 11 August 2013 08:21, <bugzilla-daemon@freedesktop.org> wrote:

>  tommy27 <barta@quipo.it> changed bug 43030<https://bugs.freedesktop.org/show_bug.cgi?id=43030>
>  What Removed Added  CC   barta@quipo.it
>
>  *Comment # 19 <https://bugs.freedesktop.org/show_bug.cgi?id=43030#c19>on bug
> 43030 <https://bugs.freedesktop.org/show_bug.cgi?id=43030> from tommy27<barta@quipo.it>
> *
>
> @Nick Sharp
> do you still experience this issue with recent 4.0.4 or 4.1.0 releases?
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 21 tommy27 2013-08-16 12:21:15 UTC
(In reply to comment #20)
> I can now resize videos, but the controls on the toolbar are greyed out.
> 
> 

so how do you resize video without toolbar controls? 
do you use mouse right click menu?

do you agree if I mark this bug report as RESOLVED?
you could open a separate report for the greyed out toolbar controls.
Comment 22 Nick Sharp 2013-08-16 12:43:46 UTC
Yes, mark it RESOLVED - I've overcome my problem.

I use right click menu to resize.

Thanks,

Nick


On 16 August 2013 13:21, <bugzilla-daemon@freedesktop.org> wrote:

>   *Comment # 21 <https://bugs.freedesktop.org/show_bug.cgi?id=43030#c21>on bug
> 43030 <https://bugs.freedesktop.org/show_bug.cgi?id=43030> from tommy27<barta@quipo.it>
> *
>
> (In reply to comment #20 <https://bugs.freedesktop.org/show_bug.cgi?id=43030#c20>)
> > I can now resize videos, but the controls on the toolbar are greyed out.
> >
> >
>
>
> so how do you resize video without toolbar controls?
> do you use mouse right click menu?
>
> do you agree if I mark this bug report as RESOLVED?
> you could open a separate report for the greyed out toolbar controls.
>
>  ------------------------------
> You are receiving this mail because:
>
>    - You reported the bug.
>
>
Comment 23 tommy27 2013-08-16 13:32:35 UTC
according to user feedback video files are now scalable in Impress 4.x releases.

marking this as RESOLVED WORKSFORME since we don't know exactly which committ did actually fix it.