Bug Hunting Session
Bug 43082 - FILEOPEN: impossible for DXF
Summary: FILEOPEN: impossible for DXF
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-11-19 00:33 UTC by Rainer Bielefeld Retired
Modified: 2013-11-25 15:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample Document (24.72 KB, image/vnd.dxf)
2011-11-19 00:33 UTC, Rainer Bielefeld Retired
Details
Sample_dxf in OSX (265.83 KB, application/zip)
2011-11-19 05:54 UTC, rk601
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-11-19 00:33:51 UTC
Created attachment 53682 [details]
Sample Document

Steps to reproduce with Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [(Build ID:  4f11d0a-adcf6d5-c4bb9bd)]" Windows_2008R2 - 111118):
0. Download attached "Sample.dxf"
1. Start LibO
2. LibO Start Center 'New Drawing'
3. Drawing menu 'File -> Open - "Sample.dxf"'
   Expected: Document will be opened
   Actual: error message "Unknown graphics format" and following
           "General Error, General input/output error"

Additional Information:
'Insert -> Picture -> From File' works without problems for "Sample.dxf"

This one might be related to or DUP of "Bug 34721 - FILEOPEN. Can't open svg file.", "Bug 39600 - FILEOPEN SVG impossible, Error message", "Bug 41137 - FILEOPEN PDF Import "General error. General input/output error.""

- Reported with Bug Submission Assistant -

              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20110928 Firefox/7.0.1 SeaMonkey/2.4.1
Comment 1 Rainer Bielefeld Retired 2011-11-19 00:39:31 UTC
Currently only observed with WIN
Worked with 3.4.4, so REGRESSION
Comment 2 rk601 2011-11-19 05:54:03 UTC
Created attachment 53688 [details]
Sample_dxf in OSX

We tested the desired functionality in the Master:

LibO-dev 3.5.0 
Build ID: 8f87c3d-5d03837-adcf6d5-c4bb9bd
On OSX 10.6.8

Located at:

http://dev-builds.libreoffice.org/daily/MacOSX_10.6.7_Intel_no-moz/master/2011-11-16_01.40.47/

with

master~2011-11-16_01.40.47_LibO-Dev_OOO350m1_MacOS_x86_install_en-US.dmg

Follow Rainer Bielefeld's steps to reproduce:
0. Download attached "Sample.dxf"
1. Start LibO
2. LibO Start Center 'New Drawing'
3. Drawing menu 'File -> Open - "Sample.dxf"'
   Expected: Document will be opened
   Actual: error message "Unknown graphics format" and following
           "General Error, General input/output error"

Additional Information:
'Insert -> Picture -> From File' works without problems for "Sample.dxf"
Comment 3 Rainer Bielefeld Retired 2011-11-19 07:53:08 UTC
Confirmed due to Comment 2

Thorsten
You are already saddled with Bug 39600 ...
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 4 Caolán McNamara 2011-12-15 13:48:25 UTC
bibisect suggests good..bad of
37f23f7d0d38e298f30b4810b651786cfe0a89bb..cf16ef6c250a2755155a02f24bad861b35a1f92b
Comment 5 Caolán McNamara 2011-12-19 05:55:44 UTC
c0913d78c258f7e49b52f45909b2cebbd9fb6103

the completely correct looking 

-        if( !ImpPeekGraphicFormat( rStream, aTmpStr, sal_True ) )
+        if( !ImpPeekGraphicFormat( rStream, aTmpStr.ToUpperAscii(), sal_True ) )

which is basically a correct bug fix, now makes the DXF detector get used, which it wasn't previously, and the dxf detector decides the .dxf isn't one