Download it now!
Bug 43145 - EDITING: Including a table on a Draw worksheet
Summary: EDITING: Including a table on a Draw worksheet
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 47514 (view as bug list)
Depends on:
Blocks: ImpressDraw-Tables
  Show dependency treegraph
 
Reported: 2011-11-21 12:43 UTC by drc
Modified: 2018-06-17 07:17 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip file of folder containing 2 files: tabletest.odt and worksheets.odg (25.78 KB, application/zip)
2011-11-21 12:43 UTC, drc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description drc 2011-11-21 12:43:42 UTC
Created attachment 53749 [details]
Zip file of folder containing 2 files:  tabletest.odt and worksheets.odg

Problem description: 

Cannot create required table on worksheet prepared using LO-Draw.  Tried within text frame and naked in drawing frame.

Then tried copy and paste from a writer document.  

Because trying to use the native Draw facility was so totally unproductive, quite unsuitable for a nice bug report, only the copy-and-paste experience is recorded here.  I haven't time at the moment to follow up the more complicated native issues - if you want to follow that up, try it.  Respond here or by email in the unlikely event you need help finding the problem! 

Steps to reproduce:
1. open attached worksheets.odg
2. open attached tabletest.odg
3. copy whole table and paste into drawing sheet 2 (outside the text frame)

Current behavior:
(Build 402)
Most table settings are ignored or misinterpreted, especially:
merged cells not supported? (ugh!)
Imported text font size ignored.
Table layout (eg column widths) determined by an unrecognised algorithm - copied column widths are clearly having an effect but not the one expected.
Aspects of Draw default table formatting are applied, changing the appearance and overriding, for example, background colouring and border decisions on the original.


Expected behavior:
A table visually approximating the original.


Platform (if different from the browser): 
XP Media Center SP3 (same as for Firefox & bug report)
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:8.0) Gecko/20100101 Firefox/8.0

Possibly related 422387 and 34403 referring to Impress and borders behaviour.

PS - It would be really nice if we could use the same table object in all applications, then we would only have to get it right in one place, and we would have a consistent UI :)
Comment 1 sasha.libreoffice 2012-02-10 05:35:51 UTC
reproduced in 3.3.4 and 3.5.0 rc 3 on Fedora 64 bit
so change version to 3.3.4 as most early reproduced

@ drc@openoffice.org
Meanwhile try paste table into Draw by press Ctrl-Shift-V and selecting "LibreOffice Writer document. Then double click resulting object, appears additional handles for resizing. Increase size of object. It will look ok.
Comment 2 sasha.libreoffice 2012-02-10 05:38:10 UTC
or copy-paste table into Calc. Then select it there, copy and in Draw press Ctrl-Shift-V and select GDI metafile or Bitmap
Comment 3 QA Administrators 2015-04-01 14:42:26 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-04-24 16:28:25 UTC
*** Bug 47514 has been marked as a duplicate of this bug. ***
Comment 5 Heiko Tietze 2016-06-14 06:41:30 UTC
Table style was introduced recently that may help with preserving the formatting. Perhaps it makes sense to split the issue into formatting (color, font etc.) and cell properties (merged, lines etc.)
Comment 6 QA Administrators 2017-09-01 11:20:09 UTC Comment hidden (obsolete)
Comment 7 Roman Kuznetsov 2018-06-16 14:54:26 UTC
>merged cells not supported? (ugh!)

supported in 6.0.4

>Imported text font size ignored.

does not ignored in 6.0.4

but fill and border color are still ignored in 6.0.4
but you are change both in tollbar Table in Draw

and name of this bug need change to "Wrong copying of table from Writer to Draw", because in Draw yu can create and change options of table, include merge cell, now

my opinion is close it as WFM
Comment 8 Heiko Tietze 2018-06-17 07:17:16 UTC
The point here is that Writer has different tables than Draw/Impress (and copy/paste still doesn't result in an exact copy). But the solution is simple: paste special and use LibreOffice Text Document. You can modify the inserted OLE object easily after double-click.