Bug 43249 - FILEOPEN: Frame borders not shown in .doc file
Summary: FILEOPEN: Frame borders not shown in .doc file
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: All All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: bibisected35 bibisected35older target...
Keywords: regression
Depends on:
Blocks: 44768
  Show dependency treegraph
 
Reported: 2011-11-25 14:18 UTC by jwbacon
Modified: 2012-08-03 09:12 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
MS Office doc that is not handled well (109.50 KB, application/vnd.ms-word)
2011-11-25 14:18 UTC, jwbacon
Details
here's a screenshot of word 2010 (134.88 KB, image/png)
2012-06-12 04:04 UTC, Caolán McNamara
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jwbacon 2011-11-25 14:18:30 UTC
Created attachment 53858 [details]
MS Office doc that is not handled well

The attached document fails to load properly.  Attempts to clean it up and edit it result in further corruption.
Comment 1 Rainer Bielefeld Retired 2011-11-26 01:12:26 UTC
There are several problems here, due to "1 problem - 1 report" I will reduce the report to 1 very visible problem: The borders of the frame around the Paragraph starting with "The mornings at Woodlands ..." are invisible / lost when I open reporter's sample  with "LibreOffice 3.4.4  - WIN7 Home Premium (64bit) German UI [OOO340m1 (Build:402)]".

It seems that this problem has already reported, but there it was always a part of a filesave problem, this here is the first report I see the problem in a native MS Office document.

Regression, borders were visible and shown correctly with "LibreOffice Portable 3.3.3  - WIN7  Home Premium (64bit) German UI [OOO330m19 (Build:301  Tag 3.3.3.1)]".

Still visible with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [(Build ID:  4f11d0a-adcf6d5-c4bb9bd)]" Windows_2008R8 - 111118)

Might be related to "Bug 42570 - EDITING: Frame Border Gone under 3.4.3"

@jwbacon@tds.net:
Please check with 3.4.3! I have no 3.3.0 available and will not check problems for that particular version.
May I ask you to read  hints on <http://wiki.documentfoundation.org/BugReport> carefully?
For additional problems you observe and report please:
- Write a meaningful Summary
- Attach a sample document or refer to the document attached here
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (and if possible how to created a 
  sample document from the scratch)
- add information 
  -- what EXACTLY is unexpected
  -- and WHY do you believe it's unexpected (cite Help or Documentation!)
  -- concerning your PC (video card, ...)
  -- concerning your OS (Version, Distribution, Language)
  -- concerning your LibO version and localization (UI language)
  –- Libo settings that might be related to your problems 
    (video hardware acceleration ...)
  -- how you launch LibO and how you opened the sample document
  –- If you can contribute an OOo Issue that might be useful
  -- everything else crossing your mind after you read linked texts

@Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 2 Michael Stahl (CIB) 2012-02-03 10:31:59 UTC
it looks like Rainer wanted to assign this to Cédric,
and he has my full agreement on that :)
Comment 3 Michael Stahl (CIB) 2012-06-11 12:10:48 UTC
this was mostly fixed by e652ba3c7357e0396498629891a1391ace67c4d7,
except that the border on the central frame is now 2.60pt wide,
while OOo 3.3 shows it as 1.10pt wide.

i'm not sure what is going on here:
the border is apparently 33020 EMU / 52 twips wide and double.

but weirdly Word Viewer 2003 displays it as a single border?
Comment 4 Caolán McNamara 2012-06-12 04:04:14 UTC
Created attachment 62927 [details]
here's a screenshot of word 2010

Microsoft Word 2010 shows a 2.6pt weight double border
Comment 5 Not Assigned 2012-06-12 06:48:50 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=36e43b52992735c622833e923faa63774b9e2f76

fdo#43249: WW8: fix double border import:
Comment 6 Not Assigned 2012-06-12 06:54:48 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2930a1abf8ba74d9bba0be808c1172ea7cd8e149&g=libreoffice-3-6

fdo#43249: WW8: fix double border import:


It will be available in LibreOffice 3.6.
Comment 7 Michael Stahl (CIB) 2012-06-12 07:36:34 UTC
thanks for the screenshot; amazing that Word Viewer 2003 displays
this differently than Word itself; or perhaps it's Wine's fault,
but surely running Viewer on Wine shouldn't have such an effect...

so it looks like we import the double border correctly
until it gets converted to a SvxBorderLine, at which point
the width is tripled; commit in comment #5 should fix it.

the fact that OOo imported it as 1.10pt is actually a bug.
Comment 8 Not Assigned 2012-06-12 08:20:58 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=56214e02055862f196900be9a7318cbe54a48f1c&g=libreoffice-3-5

fdo#43249: WW8: fix double border import:


It will be available in LibreOffice 3.5.5.
Comment 9 Rainer Bielefeld Retired 2012-08-03 09:12:56 UTC
We need exact and correct target information for automated lists in Wiki and LibO Web Site.