Bug 43283 - Words which are added to the personal wordbook and ignored words are not remembered as such
Summary: Words which are added to the personal wordbook and ignored words are not reme...
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
(earliest affected)
3.4.3 release
Hardware: All All
: medium minor
Assignee: Not Assigned
: 53720 (view as bug list)
Depends on:
Reported: 2011-11-27 14:51 UTC by Mark
Modified: 2016-09-20 10:34 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Note You need to log in before you can comment on or make changes to this bug.
Description Mark 2011-11-27 14:51:47 UTC
I am using LibreOffice 3.4.3 on Kubuntu Natty in German. I have noticed that words which I have added to the wordbook, words which should be ignore every time and words which should should be changed all the time are simply ignored, so that I get prompted by the same words again. Since I am using German, this happens with the German spell checking, but I would assume this to be a generic problem (but I can not know).
I have check in Libreoffice-seetings: It seems like the personal wordbook as well as the ignore-wordbook is checked so that it should be used.
Please tell me if you need more information.
Comment 1 sasha.libreoffice 2012-04-27 03:40:01 UTC
Thanks for bugreport
Please, verify if in last version of LibreOffice still reproducible
Comment 2 Thomas Hackert 2012-09-30 08:22:18 UTC
Hello Mark, *,
I cannot confirm your issue with LO Version (Build ID: da8c1e6) under Debian Testing x86 ... :( Have you tested it with a newer version than LO 3.4.3 as Sasha has asked you 5 months ago?
Sorry for the inconvenience
Comment 3 Urmas 2012-11-17 10:25:17 UTC
*** Bug 53720 has been marked as a duplicate of this bug. ***
Comment 4 Urmas 2012-11-17 10:26:19 UTC
Confirmed by independent report.
Comment 5 Rainer Bielefeld Retired 2012-11-17 11:24:14 UTC
@Urmas: Thank you for finding the DUP!

More or less [Reproducible] with "LibreOffice" German UI/ German Locale [Build-ID: 58f22d5] on German WIN7 Home Premium (64bit) or "Ignore All" list. I had a text with several "screenshot" and "screenshots", during spell check with <f7> I marked both as "Always ignore" and that worked fine, and I saw those 2 words (as the only ones) in menu 'Tools -> Options -> Language Settings -> Writing Aids  Options - Ignore all list [All Languages]'. After exit LibO / Relaunch the Ignore all list is empty again.

But my user dictionary works fine, words I added remain.

So I think this one is not NEW, because we still are far away from understanding the problem. 

May be we should focus to the "Ignore all" problem and find out at what action it looses the entries. Exit LibO, Launch Libo or when else?

Can someone do the same tests for the user dict?
Comment 6 Rainer Bielefeld Retired 2012-11-17 11:24:30 UTC
I also will do my own tests some later.
Comment 7 Rainer Bielefeld Retired 2012-11-17 12:05:59 UTC
To be honest, I have no idea where I can find thes "Ignore all" list. Can somebody help me?
Comment 8 Urmas 2012-11-17 12:22:21 UTC
Apparently he means the exclusion dictionary, which can be created by a checkbox on custom dictionary creation.
Comment 9 Rainer Bielefeld Retired 2012-11-17 15:55:15 UTC
"Ignore all" never worked for me back until OOo 1.1.5. 

Please also see "Bug 57227 - LOCALHELP: wrong for Spell Check 'Ignore All'"!
Comment 10 Florian Reisinger 2013-04-21 07:10:49 UTC
Setting to new, because I can confirm the behavior with Version (Build ID: a67943cd4d125208f4ea7fa29439551825cfb39) @ Win 7 x64
Comment 11 Andrej 2013-07-07 09:48:07 UTC
I use version and the problem persist. 

When I mark some words, that are underlined as wrong spelling, as ignore or ignore all, that word is not underlined anymore. But after saving the document and reopen it, the words are again underlined as wring spelling so I have to right click and select "Ignore" or "Ignore All" again and again... 

It is very annoying. Please do something about it.
Thank you
Comment 12 Andrej 2013-07-07 09:55:51 UTC
And I use windows 7 64 bit.
Comment 13 QA Administrators 2015-04-01 14:41:16 UTC Comment hidden (obsolete)
Comment 14 Buovjaga 2015-04-23 11:51:17 UTC
Had to close LibO and not just the file to repro.

Ubuntu 14.10 64-bit 
Build ID: 40m0(Build:2)
Locale: en_US
Comment 15 QA Administrators 2016-09-20 09:33:59 UTC Comment hidden (obsolete)
Comment 16 Andrej 2016-09-20 10:34:38 UTC
Tested on linux, libreoffice 5.1.4