Bug Hunting Session
Bug 57227 - LOCALHELP: wrong for Spell Check 'Ignore All'
Summary: LOCALHELP: wrong for Spell Check 'Ignore All'
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
3.6.4.1 rc
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL: http://help.libreoffice.org/Common/Sp...
Whiteboard: target:4.0.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-11-17 15:54 UTC by Rainer Bielefeld Retired
Modified: 2012-11-24 16:23 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Test Kit (13.79 KB, application/x-zip-compressed)
2012-11-17 15:54 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-11-17 15:54:54 UTC
Created attachment 70191 [details]
Test Kit

Localhelp for 'Ignore All' is wrong (you can find it in WIKIHELP under a.m. URL)

Is: 
"Skips all occurrences of the unknown word in the entire document and continues with the spellcheck."

Should Be:
"Skips all occurrences of the unknown word in the entire document and continues with the spellcheck. For the rest of the current LibO sessionn this misspelled word will be ignored in all other documents."

I believe the misspelled word should be ignored in all documents also in later sessions, because a "Ignore all" list looks as if that "ignore" decision becomes stored in the dictionary system. But see "Bug 43283 - Words which are added to the personal wordbook and ignored words are not remembered as such"


Steps how to reproduce with "LibreOffice 3.6.4.1 rc" German UI/ German Locale [Build-ID: a9a0717] on German WIN7 Home Premium (64bit)

1. Open sample1.odt from attached test kit
2. <f7> to start spell check 
   (If you want, <Help> so that you can read the help for that
3. At "nonnnnsenseword": <Ignore all>
4.  Open sample2.odt from attached test kit
5. <f7> to start spell check 
   > "nonnnnsenseword" will be ignored

"Ignore all" also stays active for a newly opened spreadsheet document with "nonnnnsenseword" in it.
Comment 1 Not Assigned 2012-11-24 16:22:29 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=7be4495e86db83bb0fd27b36629a378d957f7ba9

fdo#57227 Amend help text of 'Ignore All' button



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 2 Andras Timar 2012-11-24 16:23:21 UTC
(In reply to comment #0)
> I believe the misspelled word should be ignored in all documents also in
> later sessions [...]

I disagree, that is what the 'Add' button is for. I.e. to add the word to user dictionary.