Bug 43650 - UI: Disable the scrollbar tooltip when scrolling with Mouse Wheel
Summary: UI: Disable the scrollbar tooltip when scrolling with Mouse Wheel
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other All
: medium enhancement
Assignee: Ruslan Kabatsayev
URL:
Whiteboard: target:4.1.0
Keywords: difficultyInteresting, easyHack, skillCpp, skillDebug, topicUI
: 54966 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-08 17:53 UTC by camillo.lugaresi+freedesktop
Modified: 2015-12-15 23:24 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description camillo.lugaresi+freedesktop 2011-12-08 17:53:25 UTC
While scrolling using a trackpad, a tooltip showing the current page and section flickers next to the cursor. This is very distracting and annoying when trying to read a document. The tooltip should be removed; if you don't want to remove it, at least make it appear briefly only when a page boundary is crossed.
Comment 1 stragu 2011-12-15 12:50:40 UTC
Same thing on Ubuntu 11.10. This really is an annoyance when reading a document. Plus, it often overlaps the text zone because it shows the title of the page.
Comment 2 Ed O'Loughlin 2012-02-04 14:17:47 UTC
I opened a similar bug on OpenOffice in 2004. It has had a number of people request the ability to disable the scrollbar tooltip independently of other tooltips but there's been no movement on it.

https://issues.apache.org/ooo/show_bug.cgi?id=25945
Comment 3 Ruslan Kabatsayev 2012-05-24 11:51:26 UTC
I completely agree with those who commented. I'd be glad if this tooltip didn't appear. It's redundant to tell the user current section name when he is already reading it and scrolling with such a relatively slow way as mouse wheel.

On the other hand, there's a useful tooltip when scrolling using the scrollbar. But it still has some annoyances: it tries to put all the section name in one line, no matter how long the name is. I'd suggest to change this behavior so that the tooltip tried to remain small in horizontal direction (and to position not above the page if possible) by splitting its text and clipping it if it's too long. Something like this is done by e.g. MS Word 2003 (which also doesn't have the tooltip while scrolling by mouse wheel).
Comment 4 Roman Eisele 2012-07-21 12:55:40 UTC
This issue is well-reproduced (BTW, I can easily reproduce it with LibreOffice 3.5.5.3) and platform-independend, therefore I change the settings accordingly.

But many people will certainly disagree about if the complete tooltip is a bug; on the one hand, some people will consider the tooltip as "very distracting and annoying when trying to read a document" (so the original reporter), but others will find this tooltip useful. Therefore, we should not consider the mere presence of this tooltip as a bug ;-)

Therefore, I propose to change this bug report into an enhancement request: All people would be happy if we had "the ability to disable the scrollbar tooltip independently of other tooltips", as comment #2 put it. Therefore:


Enhancement request:

Please add a new option to LibreOffice options which allows us to disable/enable the special tooltip (showing the page number) which appears near the vertical scrollbar when scrolling through pages!
Comment 5 Roman Eisele 2012-07-21 12:58:34 UTC
@Cédric Bosdonnat,
@Michael Stahl:

Could you take a look at this simple enhancement request? It is not urgent, of course (most bugs are far more urgent ;-), but this one seems simple and should be rather easy to implement. Thank you very much!
Comment 6 Samuel Mehrbrodt (CIB) 2013-01-24 14:53:15 UTC
*** Bug 54966 has been marked as a duplicate of this bug. ***
Comment 7 Samuel Mehrbrodt (CIB) 2013-01-24 15:47:10 UTC
This has been done in Apache OpenOffice:
http://svn.apache.org/viewvc?view=revision&revision=1419993

Do we really want to have this setting or should we just remove that feature (the current page number can also be seen in the footer status bar)?
Comment 8 Tarver 2013-01-24 15:54:53 UTC
I would say this "feature" could be removed, and I suspect few would miss it except a few who might notice that an annoying noise has stopped. The key is that it be *possible* to turn it off. I think if it can be toggled, it should definitely be off by default.
Comment 9 Ruslan Kabatsayev 2013-01-24 15:56:03 UTC
(In reply to comment #7)
> Do we really want to have this setting or should we just remove that feature
> (the current page number can also be seen in the footer status bar)?

Well, page number is in status bar, but section name isn't.
Ideally I'd like to have it as is in Word 2003: nothing when you scroll via wheel, but a tooltip when you scroll by scrollbar - AND - the tooltip should be multiline, so that it doesn't span the whole screen width when section name appears long.
This feature is useful when you do fast scrolling as when using scrollbar, so IMHO it shouldn't be removed, just needs improvement.
Comment 10 Samuel Mehrbrodt (CIB) 2013-01-24 17:40:51 UTC
(In reply to comment #9)
> Ideally I'd like to have it as is in Word 2003: nothing when you scroll via
> wheel, but a tooltip when you scroll by scrollbar - AND - the tooltip should
> be multiline, so that it doesn't span the whole screen width when section
> name appears long.
> This feature is useful when you do fast scrolling as when using scrollbar,
> so IMHO it shouldn't be removed, just needs improvement.

I agree that it could be improved. But the question is who can do it? And is it worth that?

For larger documents one can use the Navigator - there you can navigate using the headlines.

I would prefer to just remove the tooltip. If then a lot of people cry, we can think about re-adding it and improving it.
Comment 11 camillo.lugaresi+freedesktop 2013-01-25 00:05:14 UTC
(In reply to comment #10)
> I would prefer to just remove the tooltip. If then a lot of people cry, we
> can think about re-adding it and improving it.

I agree. I guess this has not been fixed so far because adding an option or making the tooltip's behavior more sophisticated would take some resources, but simply removing the tooltip should be a trivial change. So let's just rip it out now: if nobody complains, we're done; if someone does, then there is a justification for investing time into adding an option or adapting the behavior. I think this is the path that gives the greatest benefit with the least likelihood of misplaced effort.
Comment 12 Urmas 2013-01-25 08:22:51 UTC
Of course the tooltip when dragging the scrollbar thumb itself should stay.
Comment 13 Samuel Mehrbrodt (CIB) 2013-01-26 10:08:54 UTC
Agreed - that makes really sense for large documents.
Comment 14 Samuel Mehrbrodt (CIB) 2013-02-07 15:20:36 UTC
Marking this as Easy Hack.
The code where the tooltip is created can be seen in this OpenOffice commit: http://svn.apache.org/viewvc?view=revision&revision=1419993

Then, instead of depending on a configuration setting, we need to get the information whether the mouse wheel is used or not.

Citing Cedric:
> The ScollbarHdl doesn't tell you how this has been triggered. I think
> you'll have to have a look at the ScrollBar vcl control to add that
> information... Some debugging may also help to see the difference
> between scrolling with the wheel or by dragging the lift. 

This is the VCL Scrollbar Control: http://opengrok.libreoffice.org/xref/core/vcl/source/control/scrbar.cxx
Comment 15 Samuel Mehrbrodt (CIB) 2013-02-07 15:28:49 UTC
Whoever fixes this gets some bounty: http://www.freedomsponsors.org/core/issue/156/ui-disable-the-scrollbar-tooltip-when-scrolling-with-mouse-wheel

Whoever wants this fixed, add your bounty there ;)
Comment 17 Samuel Mehrbrodt (CIB) 2013-02-08 09:28:41 UTC
Thank you, the patch looks good.
Please claim the bounty and as soon as it gets merged, I'll pay the money.
Comment 18 Not Assigned 2013-02-08 12:21:27 UTC
Ruslan Kabatsayev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8880c773e779710dc0a08760e92afd709a73ca31

Resolves: fdo#43650 Disable tooltip when scrolling writer docs via mouse wheel



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 19 20feet 2013-04-08 06:03:06 UTC
I'm a bit out of my depth here.  Could someone explain in layman's terms how to implement this fix?  I'm using LibreOffice 4 on a Mac.  Thanks a lot.
Comment 20 Samuel Mehrbrodt (CIB) 2013-04-08 07:36:39 UTC
It is already implemented and will be available in LibreOffice 4.1.
You can download a Developer version to test it.
Comment 21 Robinson Tryon (qubit) 2015-12-15 23:24:42 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyInteresting SkillCpp SkillDebug TopicUI )
[NinjaEdit]