Bug Hunting Session
Bug 43681 - Odd stacked area chart
Summary: Odd stacked area chart
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium normal
Assignee: Kohei Yoshida
URL:
Whiteboard: target:3.5
Keywords:
: 49516 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-12-09 21:56 UTC by Kohei Yoshida
Modified: 2013-03-24 11:40 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kohei Yoshida 2011-12-09 21:56:32 UTC
Open this attachment

https://bugs.freedesktop.org/attachment.cgi?id=54073

from Bug 43467.

The first chart is supposed to be a stacked area chart, but it renders it in a very odd fashion.  Something is clearly wrong.
Comment 1 Kohei Yoshida 2011-12-13 08:46:49 UTC
Doh!  The X label data is not sorted:

10/01/11
03/15/11
09/21/11

and sorting them in ascending order makes the chart draw correctly.

I guess we need to sort the X label data before drawing the chart.
Comment 2 Kohei Yoshida 2011-12-13 13:23:46 UTC
The sorting issue is now resolved on both master and the 3.5 branch.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ccc59bc76f2d7cd5d6ccae47efc7e6633f01a70a

I'm now looking into the incorrect automatic Y-axis scaling issue, which is not related to this bug, but bothers me a little.
Comment 3 Kohei Yoshida 2011-12-13 16:54:40 UTC
Ok. Now the automatic scaling of the y-axis should work correctly too.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=70afe780231dc086a07494db97a2bac2ca0a0939

This concludes my work for this bug report.

Both fixes will go into master and the 3.5 branch.
Comment 4 Michael Meeks 2011-12-14 01:21:33 UTC
> I'm now looking into the incorrect automatic Y-axis scaling issue, which is
> not related to this bug, but bothers me a little.

wow - thanks for that :-) I've been annoyed by that quite a bit; particularly the change in vertical scale when you cut/paste a chart from eg. calc to impress - necessitating manually overriding the automatic-ness ...

Nice work !b
Comment 5 Katarina Behrens 2013-03-24 11:40:54 UTC
*** Bug 49516 has been marked as a duplicate of this bug. ***