Download it now!
Bug 43752 - VIEWING: Rotated flipped shapes in 3.4 drawings loose rotation opened in 3.5
Summary: VIEWING: Rotated flipped shapes in 3.4 drawings loose rotation opened in 3.5
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium major
Assignee: Muthu
URL:
Whiteboard: target:3.6.0 target:3.5.3
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-12 07:49 UTC by Rainer Bielefeld Retired
Modified: 2012-04-10 03:34 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample (29.83 KB, application/vnd.oasis.opendocument.graphics)
2011-12-12 07:51 UTC, Rainer Bielefeld Retired
Details
New Sample (29.74 KB, application/vnd.oasis.opendocument.graphics)
2011-12-12 08:05 UTC, Rainer Bielefeld Retired
Details
rotation of custom shape wrong (12.90 KB, application/vnd.oasis.opendocument.graphics)
2012-04-09 10:34 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-12-12 07:49:22 UTC
Steps how to reproduce with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta0-based - WIN7 Home Premium (64bit) German UI [Build-ID: f923851-7f15fca-1f1fd1a-ca8e46d-5bcbce4] Windows_Release_Configuration  11-Dec-2011 06:51":

Open attached sample3.odg with 3.4.4 and also 3.5.5 and compare view (you will find screenhshots in the document.
Expected: 3.5 looks like 3.4
Actual: A triangle created by rotating 180° (or flipping? I can't remember) 
        looses it's rotation.

May be that only very particular drawings will be affected (first creation with OOo 1.1 or similar), but for me hundreds of drawings can not be used with 3.5

I am pretty sure that we had something similar with OOo some years ago, but I can't find the Issue.
Comment 1 Rainer Bielefeld Retired 2011-12-12 07:51:00 UTC
Created attachment 54363 [details]
Sample

See original report.
Blocker potential if more users and drawings are affected.
Comment 2 Rainer Bielefeld Retired 2011-12-12 08:05:55 UTC
Created attachment 54364 [details]
New Sample

I am able to reproduce the problem from the scratch:
1. open 3.4.4 DRAW
2. Draw "isosceles triangle" shape
3. rotate 90° clockwise  
4. Copy - Paste
5. Flip copied shape horizontally
6. move a little to the right as you see in attached sample at the right end of
   new sample
7. Save
8. Reopen with 3.5
   Expected: looks like in 3.4:  |><|
   Actual: looks |>|>
Comment 3 Rainer Bielefeld Retired 2011-12-12 08:18:54 UTC
New result: Only rotated objects that have been flipped are affected.

Opening works fine with:
Server installation of  Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 130028f-b211287-090bcba-45cf606-05891e7]" Win-x86@9-Voreppe - 111130)

Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID:  2d0998f-090bcba-45cf606]" Win-x86@6 - 2011-12-01_08.37.54)

Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID:  a286353-090bcba-3bf3b94]" Win-x86@6 – 2011-12-02_22:36:35)

NinGW 12-11-08

Can it be that the problem came up with fix for "Bug 42227 FILEOPEN: rotated objects all in top left slide corner"?
Comment 4 Rainer Bielefeld Retired 2011-12-12 10:18:48 UTC
Good news, nothing will be damaged simply saving a document with 3.5. Reopening doc with 3.4 everything shows in the correct way (I only did a small sample)

Now I found the old related OOo 2.2 bug:
<https://issues.apache.org/ooo/show_bug.cgi?id=75086>
No idea whether it might help

Further investigations let me assume that in 3.5 flip and rotate operation for the base object will be done in wrong (inverted) order.
Comment 5 Roman Eisele 2011-12-13 05:37:53 UTC
Bug reproduced using the attachment 'New Sample' and/or the steps from Comment #2 with LOdev 3.6.0
Build ID: bedebfc-b204871-3e50423-4c1bcb5
Build Date: 2011-12-13
running on MacOS X 10.6.8 German

This bug was NOT present in 3.5.0 beta 0,
Build ID: ef91e38-b1d4df6-090bcba-45cf606-05891e7
running on the same machine.

-> Changing Platform from other/Windows to Other/All because the bug is also reproducible on MacOS X.
Comment 6 Roman Eisele 2011-12-14 02:40:40 UTC
Also reproducible using beta 1 on MacOS X 10.6.8:

LOdev 3.5.0 [should be: LibreOffice 3.5.0 beta 1; on MacOS, the file name of the beta 1 build is 'LOdev']
Build-ID: 1ce7995-7f15fca-1f1fd1a-ca8e46d-5bcbce4
Installation file: libreoffice-3-5~2011-12-13_04.48.06_LibO-Dev_3.5.0beta1_MacOS_x86_install_en-US

Therefore, this bug has been introduced between beta 0 and beta 1 -- maybe with some patch(es) fixing bug Bug 42227?!
Comment 7 Petr Mladek 2011-12-20 01:22:29 UTC
Radek, could you please have a look?
Comment 8 Stephan 2012-02-27 01:24:57 UTC
This is quite a showstopper bug! I just came across it myself (WinXP, Win7, LibreOffice 3.5.0rc3, Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735), many of the arrows I use in my slides are pointing the wrong way, which renders some presentations unusable under 3.5. If possible, please try to fix this quickly...

(On a side note: since the very first release LO has consistently managed to fix bugs that limit the use of its Impress component for professional use. But with every such release, new showstopping bugs were introduced. I hope that this uncomfortable state will soon be history, since it severely limits the acceptance of LO among semi-professional and professional users.)
Comment 9 Valek Filippov 2012-04-08 07:23:44 UTC
Could it be related to this fix:
https://bugs.freedesktop.org/show_bug.cgi?id=43193
?
Comment 10 Rainer Bielefeld Retired 2012-04-08 08:38:25 UTC
(In reply to comment #9)
> Could it be related to this fix:
> https://bugs.freedesktop.org/show_bug.cgi?id=43193

Indeed some symptoms look related, but the bug here (started 2011-12-11 or so) is definitively not a result of the fix (pushed 2012-01-18) 

@Ivan:
Can you check this, too? Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 11 Ivan Timofeev (retired) 2012-04-08 22:01:17 UTC
Just do a horizontal flip on a 90°-rotated triangle in 3.5 - it flips the yellow handle, but does not flip the triangle. So, I think this bug is not related to the import code.
Given the commit range ef91e38..1ce7995, I would start looking into it, but I don't know what module could be suspected. Maybe svx?..
Comment 12 Ivan Timofeev (retired) 2012-04-08 22:34:08 UTC
Aha!
http://cgit.freedesktop.org/libreoffice/core/commit/?id=704ee5bc859499f5fe824f66f9607b554c135c66 
changes svx/source/customshapes/EnhancedCustomShapeEngine.cxx and introduces the problem.
Comment 13 Ivan Timofeev (retired) 2012-04-09 00:42:26 UTC
(In reply to comment #4)
> Further investigations let me assume that in 3.5 flip and rotate operation for
> the base object will be done in wrong (inverted) order.

Yes, indeed.

I don't know how to fix this bug properly.
Muthu, Radek, can we revert the commit from Comment 12 and content ourselves with
http://cgit.freedesktop.org/libreoffice/core/commit/?id=30b052e7b65434d2a78ab36d8f4475abe0c86a2a ?
Comment 14 Muthu 2012-04-09 03:48:55 UTC
oh...will pick this up.
Comment 15 Muthu 2012-04-09 05:42:46 UTC
I hope I fixed it with: http://cgit.freedesktop.org/libreoffice/core/commit/?id=1c44b263d789b4c20e9178c6432300e301df94d6
Can someone verify it, please?
Comment 16 Ivan Timofeev (retired) 2012-04-09 07:25:41 UTC
The commit fixes the problem. Thank you Muthu!!! But I did not test the pptx import - n#719989 and n#719997 are not public.
Comment 17 Muthu 2012-04-09 08:03:54 UTC
@Ivan: Thank you so much! And sorry for the troubles :(

W.r.t the pptx bugs: I tested it, but if required i can create a test document (its the same scenario of flip+rotate, thou)

Marking this fixed.
Comment 18 Ivan Timofeev (retired) 2012-04-09 08:43:00 UTC
Cherry-picked to libreoffice-3-5. Will be in 3.5.3.
Comment 19 Regina Henschel 2012-04-09 10:31:19 UTC
I have tested it in daily master~2012-04-09_00.00.44_LibO-Dev_3.6.0alpha0_Win_x86_install_en-US.msi

The rotation is still wrong. The bounded rectangle and the text rotate correctly but the visual shape is wrong. It seems that there is somewhere a confusion in the orientation with UI-angle and transformation angle.

I'll attach a file with a classical path-object compared to a custom shape.
Comment 20 Regina Henschel 2012-04-09 10:34:49 UTC
Created attachment 59685 [details]
rotation of custom shape wrong
Comment 21 Ivan Timofeev (retired) 2012-04-09 11:00:15 UTC
(In reply to comment #19)
> I have tested it in daily
> master~2012-04-09_00.00.44_LibO-Dev_3.6.0alpha0_Win_x86_install_en-US.msi

Heh, this build is based on a2a982508f3424c552fe63433bc39ffda0d63604, it doesn't contain the fix:
http://dev-builds.libreoffice.org/daily/Win-x86@6-fast/master/2012-04-09_00.00.44/master~2012-04-09_00.00.44_build_info.txt
Comment 22 Rainer Bielefeld Retired 2012-04-09 21:50:15 UTC
(In reply to comment #21)
> > I have tested it in daily
> > master~2012-04-09_00.00.44_LibO-Dev_3.6.0alpha0_Win_x86_install_en-US.msi

Yes, if I understand all correctly Pull time 2012-04-09 00:00:44 of the build is before time of the commit.

I checked "New Sample" and "rotation of custom shape wrong" with parallel  installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: e194f5b-6299bf6-ec8645]" (tinderbox: Win-x86@6-fast pull time 2012-04-09 22:26:34), both look ok for me (same as in 3.4.5). So it seems Regina got an incapable build without fix.
Comment 23 Rainer Bielefeld Retired 2012-04-09 23:08:03 UTC
"Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug" looks a little similar to this one (or to "Bug 43193 - Invalid view victor image in DOC"?). May be someone can contribute some observations there?
Comment 24 Ivan Timofeev (retired) 2012-04-09 23:40:53 UTC
(In reply to comment #23)
> "Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept
> this Bug" looks a little similar to this one

??? copy-paste mistake? %-)
Comment 25 Rainer Bielefeld Retired 2012-04-10 00:16:14 UTC
> ??? copy-paste mistake? %-)

Yes, sorry, wrong Bug.
Comment 26 Regina Henschel 2012-04-10 03:34:59 UTC
(In reply to comment #21) 
Yes, I too see it fixed in a newer build. Sorry for the confusion.