Bug 43763 - EDITING: Text remains small if typed after footnote if text file was created in MS Word
Summary: EDITING: Text remains small if typed after footnote if text file was created ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: low minor
Assignee: Not Assigned
URL: http://vpk.cloudkill.org/site_media/o...
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Footnote-Endnote
  Show dependency treegraph
 
Reported: 2011-12-12 13:15 UTC by Ivan Kharlamov
Modified: 2019-12-05 13:56 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Doc file to test the bug (19.50 KB, application/msword)
2011-12-12 13:18 UTC, Ivan Kharlamov
Details
modified version of file to demonstrate a possible fix (24.50 KB, application/msword)
2011-12-14 13:25 UTC, peter Roots
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Kharlamov 2011-12-12 13:15:27 UTC
Problem description: 

If you are editing some files which were created in MS Word(it doesn't matter if you re-save them in .odt or not), which have superscript position in footnote character styles, text remains in superscript if inserted right after footnote characters.

Steps to reproduce:
1. Open an attached MS Word file
2. Type text right after footnote, see that it remains superscript

Current behavior:

Text style remains superscript if text is inserted right after footnote.

Expected behavior:

Text style must change to default.

Same issue was reported here by someone else: http://www.oooforum.org/forum/viewtopic.phtml?t=127834

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 1 Ivan Kharlamov 2011-12-12 13:18:03 UTC
Created attachment 54375 [details]
Doc file to test the bug
Comment 2 Ivan Kharlamov 2011-12-12 13:38:18 UTC
Here is a bug screencast: http://vpk.cloudkill.org/site_media/openoffice_bug.ogv

BTW, having a maximum of 3mb for attachments in bugzilla is very bad for bug reporting.
Comment 3 Ivan Kharlamov 2011-12-14 02:26:26 UTC
Little bit of history behind my bug report:
Few of my fellows have recently moved from Windows to Linux Mint(11.04). All of them say that LibreOffice Writer is a decent editor and they didn't have trouble adapting to it, but they are complaining about ONE SINGLE ANNOYANCE which is described in this bug report. They have hundreds of footnotes in their scientific papers and to change font style after every footnote seems insane. 

I have already installed MS Word via Wine for one of them. The issue is serious, it is pushing users away from your otherwise good product. Please, fix it ASAP.
Comment 4 Christopher M. Penalver 2011-12-14 03:02:36 UTC
1) lsb_release -rd
Description: Ubuntu 11.10
Release: 11.10

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.4.4-0ubuntu1
  Candidate: 1:3.4.4-0ubuntu1
  Version table:
 *** 1:3.4.4-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.4.3-3ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

3) What is expected to happen in LibreOffice Writer importing a Word created file via the Terminal:

cd ~/Desktop && wget -c https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/903608/+attachment/2630995/+files/footnoteformattingbug_1.doc -O example.doc && lowriter -nologo example.doc

on page 1 if one clicks immediately after superscript footnote 1 and begins to type, the characters are not superscript, as it would occur in Word.

4) What happens instead is the characters are superscript as shown in https://launchpadlibrarian.net/87353347/libreofficeformattingbug.ogv

WORKAROUND: Click immediately after the footnote and press Ctrl+Shift+P then begin typing as desired. This is documented at: http://help.libreoffice.org/Writer/Making_Text_Superscript_or_Subscript

Severity Normal > Minor
quoting from http://wiki.documentfoundation.org/BugReport_Details#Severity
"minor loss of function, or other problem where easy workaround is present"

Importance High > Low
This really should not be high on the developer to do list as the WORKAROUND is trivial to perform and well documented.

Platform All All > x86 (IA32) Linux (All)
Only documented test cases up or downstream are Linux, IA32.
Comment 5 Ivan Kharlamov 2011-12-14 04:36:00 UTC
Christopher, thanks for the info about workaround. 

However, the bug is all platform and is not architecture dependent. As I have written, the bug exists in Ubuntu 10.10 (x86_64) (default packages), Ubuntu 11.04 (x86_64) (default packages), Ubuntu 11.04 (x86_64) (packages from LibreOffice stable PPA). Just now I have tested the bug in LibreOffice 3.4.4 in virtualised Windows XP i386, and (unsurprisingly) the bug exists here too. So I am changing it back to all architectures and all platforms.

Best regards,
Ivan
Comment 6 peter Roots 2011-12-14 13:25:42 UTC
Created attachment 54437 [details]
modified version of file to demonstrate a possible fix

modification of the paragraph style 'footnote characters' to remove the indent and modification of the applied character style 'footnote characters' to change font position from superscript to normal removes the problem. Settings based on the default footnote style on a new LO 3.4.4 document.
file attached to demonstrate
Comment 7 QA Administrators 2014-10-24 03:18:26 UTC Comment hidden (obsolete)
Comment 8 Gordo 2015-06-06 18:09:48 UTC
Still reproducible.

The doc file can be created in LO, saved, closed, reopened, and the effect is the same.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16
Comment 9 QA Administrators 2016-09-20 09:46:36 UTC Comment hidden (obsolete, spam)
Comment 10 QA Administrators 2019-12-03 13:59:15 UTC Comment hidden (obsolete, spam)
Comment 11 Justin L 2019-12-05 13:56:19 UTC
Following the footnote is a tab, and after the tab any entered text (to modify the existing footnote) is normal. I can't imagine why text would need to be added before the tab. Anyway, it makes sense for text it inherit the format of the text preceding the cursor. So I don't see the problem here (and the video link is dead.) Lots of improvements have been made to footnote compatibility. I'm closing as works for me, since there haven't been any complaints for years.