Bug Hunting Session
Bug 43837 - SLIDESHOW CRASH on custom animation of particular objects
Summary: SLIDESHOW CRASH on custom animation of particular objects
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 Beta1
Hardware: x86 (IA32) Windows (All)
: medium blocker
Assignee: Radek Doulik
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-14 10:02 UTC by Regina Henschel
Modified: 2011-12-22 15:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Presentation with linked graphics crashes LO3.5 (1.31 MB, application/x-compressed)
2011-12-14 10:02 UTC, Regina Henschel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Regina Henschel 2011-12-14 10:02:49 UTC
Created attachment 54427 [details]
Presentation with linked graphics crashes LO3.5

Unpack attached presentation.
Open the presentation in LO3.5beta1
Show presentation from the beginning.
Click on first slide ==> crash.

The presentation does not crash in LO3.4.4.
Comment 1 Regina Henschel 2011-12-15 12:46:22 UTC
Investigating a little bit more, I have found, that the second slide crashes and that the third slide crashes. They crash even if the whole presentation has only such single slide. If you remove this slides, the presentation no longer crashes. So there must be something special with these slides
Comment 2 Regina Henschel 2011-12-15 13:12:18 UTC
Nailed it down to: It crashes if a presentation object has got a custom animation.

Take new presentation with a layout, that has outline text or title.
Write some lines into the outline text.
Apply a custom animation to the outline text, for example a "Fly in".
Start the presentation mode ==> crash
Comment 3 Rainer Bielefeld Retired 2011-12-15 23:28:13 UTC
[Reproducible] with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta1 - WIN7 Home Premium (64bit) German UI [Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4] Windows_Release_Configuration  11-Dec-2011 06:51" and own presentation created due to instructions in Comment 2. Crashes already during animation preview.

No crashes with animations for images.png with animation on empty pages.

Worked fine with 3.4.4, so Regression!

This is a blocker

@Radek:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 4 sasha.libreoffice 2011-12-16 07:06:04 UTC
LOdev 3.5.0 file: LibO-Dev_3.5.0beta1_Linux_x86-64_install-rpm_en-US.tar.gz
Build ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4
Fedora 64 bit KDE
not reproducible crash of presentation
Comment 5 Roman Eisele 2011-12-16 07:10:41 UTC
Additional observation: if I open the sample document with LibreOffice 3.5 beta
1 or Master on MacOS X 10.6.8 and show the presentation from the beginning, no
crash occurs. So (see comment #4) the crash is a Windows-specific problem.

But there are important problems with the custom animation on MacOS, too: the
three animated lines of text on slide 2 “fly in” not one by one, like in
LibreOffice 3.4.4, but all at once, and this for 3 times; the same happens for
the four animated lines of text on slide 4: they “fly in” all at once, but four
times. And there are some visual glitches when going to the next slides, too.

We should test these minor issues again once the main bug as reported by Regina
Henschel is fixed; maybe they have the same roots and are fixed by the same
patch. If they remain, a separate bug report ist necessary ...
Comment 6 Eliot the Cougar 2011-12-21 05:32:57 UTC
Confirmed on Windows 7 x64

The bug seems to be similar to bug 44011 I just reported... It has nothing to do with animations, but crashes occur with linked videos... Embedded videos do not play at all...
Comment 7 Thorsten Behrens (CIB) 2011-12-22 15:05:05 UTC
Fixed for beta3 and master.