Bug Hunting Session
Bug 43862 - Page FORMATTING: Margin settings information not compatible with 3.4.4
Summary: Page FORMATTING: Margin settings information not compatible with 3.4.4
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium blocker
Assignee: Cédric Bosdonnat
URL:
Whiteboard: odf
Keywords: regression
: 43978 44021 44209 44322 44770 44845 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-15 10:08 UTC by Rainer Bielefeld Retired
Modified: 2012-02-24 04:27 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
Test kit (2.74 MB, application/zip)
2011-12-15 10:08 UTC, Rainer Bielefeld Retired
Details
Correct test kit (375.83 KB, application/zip)
2011-12-15 21:53 UTC, Rainer Bielefeld Retired
Details
Wrong right margin of a 3.5.0 beta2 text document opened in 3.4.4 (14.45 KB, application/vnd.oasis.opendocument.text)
2011-12-28 14:47 UTC, Gustavo Pacheco
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-12-15 10:08:53 UTC
Created attachment 54471 [details]
Test kit

Steps how to reproduce with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta1 - WIN7 Home Premium (64bit) German UI [Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4] Windows_Release_Configuration  11-Dec-2011 06:51":

1. Open attached "sample1.odt" (has been created with Beta1), Page margin 
   settings should look as first screenshot shows (5mm all around)
2. Close document
3. Open with LibO 3.4.4
   Expected: page margins all 5mm
   Actual: 20-0-20-20mm

As expected, when you save document with 3.4.4, 3.5 will show 20-0-20-20mm margin.
LibO 3.3.3 portable and OOo 3.1.1 show the same margins as LibO 3.4.4 for "sample1.odt", so I am pretty sure that it's a Beta1/Master problem

Old problem with all my master versions back to July

Breaking version interoperability is a potential blocker!

Atached testkit contains
- "sample1.odt" (with that document I observed the problem the first time)
- "MASTER_110906.odt", a most simple document created with  
   Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) 
   English UI [(Build ID:  d3d1481-3f8994a-2ba0a9f)]" (110909)
- screenshots.pdf comparing view / page margin settings
Comment 1 Jean-Baptiste Faure 2011-12-15 10:57:19 UTC
Hi Rainer,

Are you sure you uploaded the right test kit? Your file is named "test - Kopie.zip" and it is in fact an .odt.

That said, I observed several time the problem you describe, but until now, I am not able to obtain a clear scenario.

Best regards. JBF
Comment 2 Cor Nouws 2011-12-15 11:54:34 UTC
me too has sometimes noticed that documents were opened with right margin == 0
not yet been able to reproduce..
Comment 3 Rainer Bielefeld Retired 2011-12-15 21:50:14 UTC
Comment on attachment 54471 [details]
Test kit

@Jean-Baptiste Faure:
Thank you for the hint, this is not the test kit for this report
Comment 4 Rainer Bielefeld Retired 2011-12-15 21:53:35 UTC
Created attachment 54483 [details]
Correct test kit
Comment 5 Rainer Bielefeld Retired 2011-12-15 21:54:47 UTC
Modify Version due to results (already observed in early Master versions
Comment 6 Roman Eisele 2011-12-16 06:51:06 UTC
CONFIRMED both with

-- LibreOffice 3.5.0 pre-beta 1
Build-ID: 1ce7995-7f15fca-1f1fd1a-ca8e46d-5bcbce4
Build Date: 2011-12-13
[libreoffice-3-5~2011-12-13_04.48.06_LibO-Dev_3.5.0beta1_MacOS_x86_install_en-US]

-- LibreOffice Master
Build ID: 0f44079-d46295c-6e20485-4c1bcb5-libreoffice-3-5-branch-point
Build Date: 2011-12-15
[master~2011-12-15_05.20.12_LibO-Dev_3.6.0beta0_MacOS_x86_install_en-US.dmg],

both running on MacOS X 10.6.8.

(1) The steps given by Rainer Bielefeld give the (wrong) result he describes: the margins of 5 mm all around get 20-0-20-20 mm margins when I open the sample document with LibreOffice 3.4.4.

(2) I get the same results if I create a new ODT document with LibreOffice 3.5 beta 1 or Master, set the margins to 5 mm all around, save the ODT file and then open the file with LibreOffice 3.4.4: I get 0-0-20-20 mm margins.

So,
-- changed Status to NEW
-- changed Platform to All because not only Windows is affected.
Comment 7 Rainer Bielefeld Retired 2011-12-16 07:36:52 UTC
Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 8 Pedro 2011-12-16 08:52:37 UTC
Modifying all margins to 0.5cm in 3.4.5 Beta1 produces a document that shows correctly in all versions of LO from 3.3.4 to 3.5.0B1

So this is indeed a regression on the way the page borders are saved.
Comment 9 Rainer Bielefeld Retired 2011-12-21 10:08:51 UTC
*** Bug 44021 has been marked as a duplicate of this bug. ***
Comment 10 Rainer Bielefeld Retired 2011-12-21 10:10:49 UTC
We already have several additional reports and discussions in mailing lists, this one is a blocker
Comment 11 Rainer Bielefeld Retired 2011-12-25 23:33:08 UTC
*** Bug 43978 has been marked as a duplicate of this bug. ***
Comment 12 Rainer Bielefeld Retired 2011-12-28 01:27:13 UTC
*** Bug 44209 has been marked as a duplicate of this bug. ***
Comment 13 Gustavo Pacheco 2011-12-28 14:46:01 UTC
Some additional info about this bug (on LibreOffice 350beta2/Ubuntu Linux):

I created the document in attachment (TOC test - 350beta2.odt) with some text, a heading and a table of contents.

In the 3.5.0 beta 2 version, the right margin looks ok (Format > Page > Right margin = 2). In the 3.4.4 version the right margin appears wrong (Format > Page > Right margin = 0).
Comment 14 Gustavo Pacheco 2011-12-28 14:47:10 UTC
Created attachment 54921 [details]
Wrong right margin of a 3.5.0 beta2 text document opened in 3.4.4
Comment 16 Michael Stahl (CIB) 2012-01-06 02:57:56 UTC
oops, didn't notice this bug earlier; i introduced this problem in some OOo 3.4 bugfix CWS, and fixed it in a different OOo 3.4 bugfix CWS; i wonder why isn't that fix in LO master?
Comment 17 Michael Stahl (CIB) 2012-01-06 03:22:21 UTC
ah yes, this:
https://issues.apache.org/ooo/show_bug.cgi?id=117696

was masterfixed in OOO340m0, which we haven't merged.

my fix never writes fo:margin, while Cedric's fix writes it in addition to 4 individual margins if all of them are equal; both seem correct to me.

the CWS that introduced the regression sw34bf04 does not seem to be in libreoffice-3.4, so no need to backport.

thanks for fixing it Cedric, and sorry that i didn't notice earlier.
Comment 18 Michael Stahl (CIB) 2012-01-06 06:28:23 UTC
*** Bug 44322 has been marked as a duplicate of this bug. ***
Comment 19 Lior Kaplan 2012-01-14 01:59:15 UTC
*** Bug 44770 has been marked as a duplicate of this bug. ***
Comment 20 sasha.libreoffice 2012-01-14 02:47:58 UTC
Thanks for FIX!
Comment 21 Rainer Bielefeld Retired 2012-01-16 23:27:25 UTC
*** Bug 44845 has been marked as a duplicate of this bug. ***