Download it now!
Bug 44322 - ODT management regression in LibO3.5: title borders and page numbers badly displayed in previous LibO versions.
Summary: ODT management regression in LibO3.5: title borders and page numbers badly di...
Status: CLOSED DUPLICATE of bug 43862
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: x86-64 (AMD64) All
: medium blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-30 08:41 UTC by William Gathoye
Modified: 2012-01-06 15:01 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Add a margin to a paragraph in LibO 3.4 which is well displayed in LibO 3.5 (8.72 KB, application/vnd.oasis.opendocument.text)
2012-01-05 08:15 UTC, William Gathoye
Details
Add a margin to a paragraph in LibO 3.5 which is bad displayed in LibO 3.4 (8.71 KB, application/vnd.oasis.opendocument.text)
2012-01-05 08:20 UTC, William Gathoye
Details
Borders added in LibO 3.5 to titles or paragraphs are badly displayed in LibO 3.4 (157.56 KB, image/png)
2012-01-05 08:21 UTC, William Gathoye
Details
Page numbers added in LibO 3.5 in page headers of footers are badly displayed in LibO 3.4 (156.42 KB, image/png)
2012-01-05 08:24 UTC, William Gathoye
Details

Note You need to log in before you can comment on or make changes to this bug.
Description William Gathoye 2011-12-30 08:41:21 UTC
Some features that were improved in LibO 3.5 are badly displayed in LibO 3.4.

The borders I've added to some titles in my odt document are displayed too far at the right.
Same problem with the page numbers I added at the bottom of the document pages.

Some screenshots are provided showing the file opening results in LibO 3.5 and 3.4:

- http://libreoffice.gathoye.be/Libreoffice_bug_report_3.5_regression_margins_odt_fr.png

- http://libreoffice.gathoye.be/Libreoffice_bug_report_3.5_regression_pages_number_odt_fr.png

I compiled latest LibO version (branch 3.5 and 3.6) (Linux X86_64), and saved the file with these versions, but I got the same results in LibO 3.4.


I found no display problem if I create the document with LibO 3.4.: it's well displayed in LibO 3.5.
If I re-save it with LibO 3.5 (you need to do a modification in the text -e.g. change a letter- to save with the Save CTRL+S button): well displayed in LibO 3.4.
But if I add (not remove) any border I applied AND I save the file with LibO 3.5: it's bad displayed in LibO 3.4.

My conclusion : I think the problem appears only if the 3.5 adding functions are called.


Word compatibility
-------------------

The ODT documents I've created with LibO 3.4 and 3.5 are still considered as invalid by Microsoft Office 2010. Word 2010 can recover most of the file content. After saving the recovered document in Word (still in ODT), the borders I had applied on titles and paragraphs are removed. If I reopen this recovered document in Word, it's no more considered as invalid, but the borders have disappeared.

http://libreoffice.gathoye.be/Libreoffice_bug_report_3.5_invalid_document_recovery_fr.png

If I re-add the missing borders in Word, they are saved in the document and well displayed in LibO (3.5 or 3.4) and Word 2010. Word is so managing this feature. If I save this document with LibO, Word considers it as invalid, but after a second recovery the borders are displayed in Word !
Comment 1 William Gathoye 2011-12-30 09:12:29 UTC
So well, I forgot to say. The problem is rapidly fixed in LibO 3.4 by changing the page right borders.
You see if you open the page dialog in LibO 3.4 that the right border is set to 0. Set it as the others (2 cm in my case) and the problem is fixed.

Which is a bit strange is that the dialog page border is displaying 2 cm as right border (in LibO 3.5). Which explains why the odt document appears correctly on this version.
Comment 2 William Gathoye 2011-12-30 09:23:37 UTC
Previously I said that :

"If I re-save it with LibO 3.5 (you need to do a modification in the text -e.g.
change a letter- to save with the Save CTRL+S button): well displayed in LibO
3.4."

If I change the name the problem remains the same: badly displayed in 3.4.
So no, it's appear due to the filters called when saving.
Comment 3 Petr Mladek 2012-01-05 02:57:41 UTC
William, could you please attach a test document created in LO-3.4 and LO-3.5 that shows the problem (difference)?

Also could you please open separate bug for the incompatibility with Word 2010? We should not discuss too many problems in a single bug, otherwise, it will be hard to understand.
Comment 4 William Gathoye 2012-01-05 08:15:47 UTC
Created attachment 55172 [details]
Add a margin to a paragraph in LibO 3.4 which is well displayed in LibO 3.5
Comment 5 William Gathoye 2012-01-05 08:18:20 UTC
According to the access logs of my webserver, it seems that you couldn't have access to the screenshots I made.

My hosting provider is experiencing some problem with the HDD where my data are stored. This latter crashed and my data are being restored from a backup they made.
Please be patient until the files come back.

As you asked me, I will provide you some other extra documents having such display problems with margins.
Comment 6 William Gathoye 2012-01-05 08:20:26 UTC
Created attachment 55173 [details]
Add a margin to a paragraph in LibO 3.5 which is bad displayed in LibO 3.4
Comment 7 William Gathoye 2012-01-05 08:21:51 UTC
Created attachment 55174 [details]
Borders added in LibO 3.5 to titles or paragraphs are badly displayed in LibO 3.4
Comment 8 William Gathoye 2012-01-05 08:24:19 UTC
Created attachment 55175 [details]
Page numbers added in LibO 3.5 in page headers of footers are badly displayed in LibO 3.4
Comment 9 William Gathoye 2012-01-05 09:20:20 UTC
I've reported a new bug https://bugs.freedesktop.org/show_bug.cgi?id=44498 for the Word compatibility section as Petr Mladek asked me.

Regards.
Comment 10 Petr Mladek 2012-01-06 05:39:42 UTC
Thanks for the test documents. It might affect many documents, so I have added this to the most annoying bugs.

Cedric, and other writer guys, please look at it. We should fix this before LO-3.5.0 is out.
Comment 11 Jean-Baptiste Faure 2012-01-06 05:53:12 UTC
Perhaps a duplicate of or linked to bug 43862 which has been fixed by Cédric today.

Best regards. JBF
Comment 12 Michael Stahl (CIB) 2012-01-06 06:28:23 UTC
margin problem is duplicate of bug 43862 and OOo issue 117696

actually the fo:margin cannot be read by old OOo/LO versions, and the weird 2cm left/top/bottom 0cm right margins are some kind of default.

*** This bug has been marked as a duplicate of bug 43862 ***
Comment 13 William Gathoye 2012-01-06 15:01:22 UTC
Confirmation:
-------------

The bug has been fixed with https://bugs.freedesktop.org/show_bug.cgi?id=43862
Thanks.