Bug Hunting Session
Bug 43967 - VIEWING: legacy report designer wizard improperly formats dates
Summary: VIEWING: legacy report designer wizard improperly formats dates
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Lionel Elie Mamane
URL:
Whiteboard: BSA target:3.6.0.0.beta2 target:3.7.0...
Keywords: regression
Depends on:
Blocks:
 
Reported: 2011-12-19 17:05 UTC by Ralph Peters
Modified: 2012-06-19 00:46 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot of report output showing poorly formatted dates (104.71 KB, image/jpeg)
2011-12-19 17:05 UTC, Ralph Peters
Details
snapshot of "query" for the same data as in the "report" snapshot (176.63 KB, image/jpeg)
2011-12-19 20:29 UTC, Ralph Peters
Details
OO 2.4.3 wizard makes a report that is OK!! (84.60 KB, image/jpeg)
2011-12-21 17:59 UTC, Ralph Peters
Details
Journal table snapshot showing dates are OK (248.84 KB, image/jpeg)
2011-12-24 09:51 UTC, Ralph Peters
Details
Journal report that shows "the number of days since 1900" instead of a "date". (162.68 KB, image/jpeg)
2011-12-24 09:52 UTC, Ralph Peters
Details
Database to test default-date-formatting problem and [Bug 49279] VIEWING: All reports fail to open!!!) (931 bytes, text/plain)
2012-05-08 12:09 UTC, Ralph Peters
Details
console logs (2.45 KB, text/plain)
2012-05-10 14:52 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Peters 2011-12-19 17:05:53 UTC
Created attachment 54585 [details]
Screenshot of report output showing poorly formatted dates

I build a query to my database which includes dates and other information in each row.

I use the report wizard to build a report from that query and the dates are formatted wrong.

Query Date      Report Date
07/01/94        34516
09/01/97        35674
11/01/98        36100
12/01/08        39783
12/01/09        40148

Note that the difference between "Report Date" values for 12/01/08 and 12/01/09 (40148 - 39783) is EXACTLY 365 (days) and the difference between "Report Date" values for 11/01/98 and 12/01/09 (40148 - 36100) is 4048 (days).  Both differences are EXACTLY the correct number of days.  So it seems obvious that the formatting is wonky -- its showing the number of days since about 1900, instead of a "date"
Comment 1 Ralph Peters 2011-12-19 20:29:06 UTC
Created attachment 54589 [details]
snapshot of "query" for the same data as in the "report" snapshot
Comment 2 Ralph Peters 2011-12-19 21:12:25 UTC
BTW,  I have been using this database in more or less the current form for about 4 years, and early 3.0 series OpenOffice software worked OK with regard to formatting dates properly in Reports.  I have some similar reports built with earlier "wizards" with previous OpenOffice versions (possibly LibreOffice versions) that give the properly formatted dates.  SO the problem is recent and its IN the wizard used to make Base reports.
Comment 3 Ralph Peters 2011-12-20 21:20:38 UTC
libreOffice 3.4.3 has the same problem -- reports made using its wizard improperly format dates in the same way.
Comment 4 Ralph Peters 2011-12-21 17:59:50 UTC
Created attachment 54661 [details]
OO 2.4.3 wizard makes a report that is OK!!

I uninstalled LO 3.4 and installed OpenOffice 2.4.3 and the date problem DISAPPEARED!

I used exactly the same database.  I used the wizard to create a report from a query.  The report was was made the same way as I did in the LibreOffice 3.4 software; I used the report wizard.  So the problem is in the wizard tha makes the report.  I have attached a snapshot of a section of the report.
Comment 5 Ralph Peters 2011-12-24 09:50:08 UTC
I dumped OO 2.4.3 and installed OO 3.3.0 and I see the same problem with report-dates being reported as "the number of days since 1900" instead of a "date".

I made a report from a simple "journal table" which contained only a date and text  This report also reported dates as "the number of days since 1900" instead of a "date".  I have attached screenshots of both the journal-table and the journal-report.
Comment 6 Ralph Peters 2011-12-24 09:51:30 UTC
Created attachment 54791 [details]
Journal table snapshot showing dates are OK
Comment 7 Ralph Peters 2011-12-24 09:52:49 UTC
Created attachment 54792 [details]
Journal report that shows "the number of days since 1900" instead of a "date".
Comment 8 Ralph Peters 2011-12-24 09:53:53 UTC
I can provide a simple database for testing if I am ever contacted by someone willing to look at thsi problem
Comment 9 Ralph Peters 2011-12-24 11:19:58 UTC
I stripped down my data base to a simple case that illustrates the report-wizard's date-formatting problem for versions later than about OO 2.4.3

If you look in "Reports" you will see 3 reports made with Open Office 2.4.3, OO 3.3, and LibreOffice 3.4.3.  ONLY the report made with OO 2.4.3 formats the dates PROPERLY!

Please fix this!

I am uploading this test case (ccts_tst.odb) to Google Documents and will share it with you.

HAPPY BUG HUNTING!
Ralph
Comment 10 Ralph Peters 2011-12-24 11:47:31 UTC
After some problems with Google Docs display of sharing, I think its properly shared with both email addresses listed above.  

A 4 MB limit on uploads is pretty small when working on Base-dataaase problems
Comment 11 Julien Nabet 2011-12-27 13:47:33 UTC
I contacted Ralph via email and told about Number format.

But here are some extra information.

On 3.4.4, I made this test :
- created a quick table via wizard with 2 date fields
- created a dynamic report
=> date fields show ko, number instead of dates (just to reproduce the pb)

On 3.5 branch, I made these tests :
1)
- created a quick table via wizard which includes 2 date fields
- added a line in the table
- created a dynamic report
=> report appeared and date fields showed ok without need to format them
There were error messages in console (same as https://bugs.freedesktop.org/attachment.cgi?id=54870&action=edit)

2)
- created a quick table via wizard with 2 date fields
- added a line in the table
- created a static report
=> report disappeared but when I reopened it, date fields showed ok without need to format them
There were error messages in console (same as https://bugs.freedesktop.org/attachment.cgi?id=54870&action=edit)

Idem for master branch (future 3.6)
Comment 12 sasha.libreoffice 2012-04-30 05:37:57 UTC
@ Lionel
What do You think about this bug?
Comment 13 Ralph Peters 2012-04-30 05:55:18 UTC
Hi,

The default formatting for dates shows the number of days since some
arbitrary date, not something like month/date/year.  So you must know about
the poor choice of default formatting and change it to something
reasonable.  This may nave been fixed in more recent versions (after 3.4.3)

Ralph


*If you look you can probably find this series of emails:*
___________________
Hi,

I used GIMP to take the screen shots of the actual report.

FIRST -- YOUR EDIT WORKS FOR ME!  THANKS!!!

In the past (e.g., OO 2.4.3), one didn't have to "edit" the wizard's REPORT
to format it to get a date out of it, so I didn't even know about the edit
that you talk about below (BTW, I've been using Base for over than 3.5
years).  In the past, I guess the wizard knew which "entries" were dates
and formatted them correctly for me.  The journal TABLE knows that they are
dates and shows them correctly!  Queries and Forms also know about DATES
and show them correctly.  This "update" to the report-wizard seems like a
regression.  Having the "Number Format" edit available is fine, but
requiring the user to find it to see dates seems like a step backwards to
me.

You may want to send a note to the "report wizard software people" that
this "regression" in capabilities should be fixed.

THANKS for your help!!!
Have a Happy New Year!
Ralph Peters (in sunny, 5C, Albuquerque, New Mexico  USA)



On Tue, Dec 27, 2011 at 1:27 PM, Julien Nabet <serval2412@yahoo.fr> wrote:
Hi,

I Got your file
I don't know how you get your screenshots (I don't know much about Base)
but I edited the report, right clicked on the field below date and chose
"Number Format" to put a date.
I attached a screenshot of what I got.

Julien.


On 27/12/2011 19:30, Ralph Peters wrote: Hi,

I thought it was supposed to send you a link via email.  Oh well...

Here's the link:
https://min.us/myUrwMc5A#1o

I tried it.  Firefox complained that the certificate was untrusted, but I
added a temporary exception and I was able to start a download.  The
download button is in the upper-right corner.

Give it a try,
Ralph


On Tue, Dec 27, 2011 at 11:15 AM, Julien Nabet <serval2412@yahoo.fr> wrote:
Hi,

Ok for minus. Perhaps I'm very tired but where's the link ?

Julien.

On 27/12/2011 19:07, Ralph Peters wrote: Hi,

The 404 error appears every once in a while --- irritating -- and then goes
away.  I uploaded it to "minus" and I shared it with you (I think ).

Drop me a note,
Ralph



On Tue, Dec 27, 2011 at 10:47 AM, Julien Nabet <serval2412@yahoo.fr> wrote:
Hi Ralph,

I clicked the link, I've got an 404 error.
Would you have a ftp location or something else to share the file ?

Julien.

On 27/12/2011 16:36, Ralph Peters (Google Docs) wrote:
  I've shared ccts_tst.odb<https://docs.google.com/open?id=0ByBRWqlLdWrBZjYwNWY2YzUtZTgzYS00MDBmLTliNDMtYmI3ZjA2Nzk2N2Zh&invite=CN6zsfMF>
Message from rpeters52@gmail.com:

Hi Julien,

I have shared it with you.  Questions? Problems?  Drop me a note.
I have not tried it with 3.5.0 beta2.
I am running Linux Mint 12 x86-64 on one laptop. The other 2 older
laptops are running Mint 11 and Mint 10.

NOTE! The report made with OO 2.4.3 is OK and works with all versions
of OpenOffice and LibreOffice.  Reports made with OO 3.3.0 and LO
3.4.3 fail.  All 3 reports are in the test database that I am sharing
with you.

Thanks!!,
Ralph in ABQ, NM  USA


___________________

On Mon, Apr 30, 2012 at 6:37 AM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=43967
>
> --- Comment #12 from sasha.libreoffice@gmail.com 2012-04-30 05:37:57 PDT
> ---
> @ Lionel
> What do You think about this bug?
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> You reported the bug.
>
Comment 14 Lionel Elie Mamane 2012-04-30 06:14:22 UTC
Fixed somewhere before 3.5.2.2 (so guessing in 3.5.0) according to my own testing and the testing of Julien Nabet.
Comment 15 Ralph Peters 2012-05-07 18:42:14 UTC
Hi,*

I DISAGREE!*

The default formatting for dates in reports is *STILL* an integer -- number
of days since 1970 or something -- not any kind of "standard" date.  To
quote an austrian friend, "this is foolishness"

Thanks for all the help,
Ralph Peters

On Mon, Apr 30, 2012 at 7:14 AM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=43967
>
> Lionel Elie Mamane <lionel@mamane.lu> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|NEW                         |RESOLVED
>         Resolution|                            |FIXED
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> You reported the bug.
>
Comment 16 sasha.libreoffice 2012-05-08 02:20:06 UTC
Due to last comment, changing status to reopened
Comment 17 Lionel Elie Mamane 2012-05-08 03:08:53 UTC
@Ralph Peters

(In reply to comment #15)

> The default formatting for dates in reports is *STILL* an integer -- number
> of days since 1970 or something -- not any kind of "standard" date.

Have you tested version 3.5.2.2 or later? Are you testing a report created in version 3.5.2.2, as opposed to opening in 3.5.2.2 (or later) a report created in a previous (e.g. 3.4.x) version?

Please confirm or infirm both these points.

If you answer "yes" to each of these two questions, please give exact reproduction instructions; neither me nor Julien Nabet could reproduce this bug with 3.5.x versions.
Comment 18 Ralph Peters 2012-05-08 08:10:14 UTC
Hi,

I am using 3.5.3.2 to make a report with my ccts_tst.odb file.  I make a
report from the journal table.  I don't sort or group. I use the Default
layout.  I get integers not dates.

Do you want  a copy of ccts_tst.odb to try?

Ralph



On Tue, May 8, 2012 at 4:08 AM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=43967
>
> --- Comment #17 from Lionel Elie Mamane <lionel@mamane.lu> 2012-05-08
> 03:08:53 PDT ---
> @Ralph Peters
>
> (In reply to comment #15)
>
> > The default formatting for dates in reports is *STILL* an integer --
> number
> > of days since 1970 or something -- not any kind of "standard" date.
>
> Have you tested version 3.5.2.2 or later? Are you testing a report created
> in
> version 3.5.2.2, as opposed to opening in 3.5.2.2 (or later) a report
> created
> in a previous (e.g. 3.4.x) version?
>
> Please confirm or infirm both these points.
>
> If you answer "yes" to each of these two questions, please give exact
> reproduction instructions; neither me nor Julien Nabet could reproduce
> this bug
> with 3.5.x versions.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> You reported the bug.
>
Comment 19 Julien Nabet 2012-05-08 10:49:06 UTC
(In reply to comment #18)
>...
> Do you want  a copy of ccts_tst.odb to try?
Yes, it could help you attach the file on the tracker to reproduce the problem.
Comment 20 Ralph Peters 2012-05-08 12:09:46 UTC
Created attachment 61249 [details]
Database to test default-date-formatting problem   and   [Bug 49279] VIEWING: All reports fail to open!!!)

Your server will not allow me to upload the test database (22.4 MB) file -- it fails or timeouts.  Contact me to get it!

INSTRUCTIONS:
1) Open database ccts_tst.odb, and go to Reports (I'm using LO 3.5.3.2)
2) Use wizard to make a report for table "journal"
3) use both "date" and and "entry" in report, no sort, no grouping, use default layout, dynamic update
4) see integers, not dates in the report
5) convert dates from "integers" to "dates" by editing the report and switching format to "date" format (Not a very good "feature" for new users!)

BTW, for "[Bug 49279] VIEWING: All reports fail to open!!!"
1) If you ask for a "sort" on the date in the Report made from the TABLE "journal", the report WORKS!
2) If you ask for a "sort" on the date in the Report made from the QUERY "Query_journal", the report FAILS!  

FYI, Query_journal has its own sort on date in it, which may cause some sort of "collision" in the report.
Comment 21 Ralph Peters 2012-05-08 12:17:06 UTC
HI,

I tried to attach the database file, but the upload
failed/timed-out/something.  Contact me to get it.  You can use it to work
on 2 bugs.

I submitted something so that my comments would not disappear.  Some of
them follow:

Ralph
in windy Albuquerque, New Mexico, USA


INSTRUCTIONS:
1) Open database ccts_tst.odb, and go to Reports (I'm using LO 3.5.3.2)
2) Use wizard to make a report for table "journal"
3) use both "date" and and "entry" in report, no sort, no grouping, use
default layout, dynamic update
4) see integers, not dates in the report
5) convert dates from "integers" to "dates" by editing the report and
switching format to "date" format (Not a very good "feature" for new users!)

BTW, for "[Bug 49279] VIEWING: All reports fail to open!!!"
1) If you ask for a "sort" on the date in the Report made from the TABLE
"journal", the report WORKS!
2) If you ask for a "sort" on the date in the Report made from the QUERY
"Query_journal", the report FAILS!

FYI, Query_journal has its own sort on date in it, which may cause some
sort of "collision" in the report.






On Tue, May 8, 2012 at 11:49 AM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=43967
>
> --- Comment #19 from Julien Nabet <serval2412@yahoo.fr> 2012-05-08
> 10:49:06 PDT ---
> (In reply to comment #18)
> >...
> > Do you want  a copy of ccts_tst.odb to try?
> Yes, it could help you attach the file on the tracker to reproduce the
> problem.
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> You reported the bug.
>
Comment 22 Julien Nabet 2012-05-10 14:52:40 UTC
Created attachment 61407 [details]
console logs

With the last report you sent, I've got the messages attached for 1 of the cases and it doesn't show all the dates, just one 20/05/16 (42510)
Comment 23 Ralph Peters 2012-05-11 07:14:10 UTC
Hi,

A few questions...

If you go to the *Tables* section, and open the table "journal" do you see
lots of dates and entries?

If you go to the *Forms* section, and open the form "Journal" do you see an
entry? Can you then move through the entries using the ">" button at the
bottom?

If you go to the *Reports* section, and open the report
"Query_journal_no_SORT_in_report" do you see a report with many entries?

Then:

INSTRUCTIONS:
1) Open database ccts_tst.odb, and go to Reports (I'm using LO 3.5.3.2)
2) Use wizard to make a report for *table* "journal"
3) use both "date" and and "entry" in report, no sort, no grouping, use
default layout, dynamic update
4) see integers, not dates in the report
5) convert dates from "integers" to "dates" by editing the report and
switching format to "date" format (Not a very good "feature" for new users!)

I just tried steps 1-4 and they work for me, giving me integers, not dates.

I got an email from bugzilla with the link:
http://nabble.documentfoundation.org/Workarounds-for-multiple-problems-with-the-legacy-Report-Designer-Wizard-under-LO-3-5-td3964175.html
that seems to say the Report Wizard is currently a mess.  My report bug ([Bug
49279] VIEWING: All reports fail to open!!!) is just part of a bigger
fiasco with report wizard.

 HTH,
Ralph

On Thu, May 10, 2012 at 3:52 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=43967
>
> --- Comment #22 from Julien Nabet <serval2412@yahoo.fr> 2012-05-10
> 14:52:40 PDT ---
> Created attachment 61407 [details]
>  --> https://bugs.freedesktop.org/attachment.cgi?id=61407
> console logs
>
> With the last report you sent, I've got the messages attached for 1 of the
> cases and it doesn't show all the dates, just one 20/05/16 (42510)
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are on the CC list for the bug.
> You reported the bug.
>
Comment 24 Lionel Elie Mamane 2012-06-18 06:24:22 UTC
The key observation is that this is about reports created with the legacy report design, not with report builder. I can reproduce with my libreoffice-3-5 development tree (beta of 3.5.5) with legacy report design (uninstall report builder to get legacy report design).
Comment 25 Not Assigned 2012-06-18 07:49:16 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fec488b9dc3018d421747fb887edee93ad3ed98e&g=libreoffice-3-6

fdo#43967 legacy report designer wizard formats dates improperly


It will be available in LibreOffice 3.6.
Comment 26 Not Assigned 2012-06-18 07:49:46 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b86f2147e496e3b7ca5a085b302f6144f338aa82

fdo#43967 legacy report designer wizard formats dates improperly
Comment 27 Lionel Elie Mamane 2012-06-18 07:56:35 UTC
Asked for review to apply my patch (and fix this) to 3.5.5 and 3.5.6; it can take several days for review to happen.
Comment 28 Not Assigned 2012-06-18 13:18:11 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7d0fbe9070ea01f3b650776edcb9ecfee7921bf4&g=libreoffice-3-5

fdo#43967 legacy report designer wizard formats dates improperly


It will be available in LibreOffice 3.5.6.
Comment 29 Not Assigned 2012-06-19 00:25:16 UTC
Lionel Elie Mamane committed a patch related to this issue.
It has been pushed to "libreoffice-3-5-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3de97fff254c369927216d341057dbad3b3fbde2&g=libreoffice-3-5-5

fdo#43967 legacy report designer wizard formats dates improperly


It will be available already in LibreOffice 3.5.5.