Download it now!
Bug 44025 - SEARCH does not go beyond prefetch window if row count is not final
Summary: SEARCH does not go beyond prefetch window if row count is not final
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.0 Beta1
Hardware: All Windows (All)
: medium major
Assignee: Lionel Elie Mamane
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2011-12-21 11:12 UTC by Rainer Bielefeld Retired
Modified: 2012-01-22 06:15 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2011-12-21 11:12:56 UTC
Steps how to reproduce with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta1 - WIN7 Home Premium (64bit) German UI [Build-ID: 7362ca8-b5a8e65-af86909-d471f98-61464c4] Windows_Release_Configuration  11-Dec-2011 06:51" 

1. open a BigAddressDatabase.odb
   (I have a spreadsheet based database with 1500 addresses
2. Select table with addresses
3. Click Search Icon, search for an existing string at the end of the address 
   list 'all fields, anywhere in the field'  <find>
   > Search starts
   Expected: Data set will be found
   Actual: Search only in first 20 records, message "not found"

Will work when you went to last record with navigation button before

This one might be related to "Bug 43921 MAILMERGE UI: Display of data sets with NEXT button limited to 10"

Worked with 3.4.4, so regression
Comment 1 Jochen 2012-01-17 12:33:35 UTC
Can confirm bug with Windows XP
Comment 2 Jochen 2012-01-17 12:37:52 UTC
Can confirm bug with Windows XP

Addition (sorry): LOdev 3.5.0beta3 (Build-ID: e40af8c-10029e3-615e522-88673a2-727f724)
Comment 3 Rainer Bielefeld Retired 2012-01-17 13:38:37 UTC
@Lionel:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 4 Lionel Elie Mamane 2012-01-17 23:51:42 UTC
How do I get or create a "BigAdressDatabase.odb" file for reproduction?
Comment 5 Rainer Bielefeld Retired 2012-01-18 03:04:26 UTC
@Lionel:
For me it's reproducible with Bibligraphy database:

1. open new text document
2. <f4> to show databases
   > shows only No of records = 40 although 59 are available
3. select Biblio Tables
4. Search for "9782844278340" 'anywhere' (that is ISBN No in last record No 59)
   > Will fin nothing
5. click end and back to first record
6. Search for "9782844278340" 'anywhere'
   > Now "9782844278340" will be found
Comment 6 Lionel Elie Mamane 2012-01-18 07:12:32 UTC
OK, reproduced. Plausibly caused by some more aggressive caching.
Comment 7 Jochen 2012-01-18 09:25:47 UTC
The German community respectively the de-discuss ML followed your efforts with regard to base with great interest. Thank you for that. Unfortunately none of us can program the source code. But there are some who are familiar with the application including macro programming very well. We would like to support you in your efforts. Please give us know how we can do this best (comments in Bugzilla, private mail, mailing list?).

We would like to ask if Bibligraphy database is an appropriate test-database for you.

Otherwise the following publicly accessible database has been proposed: list of all aircraft registered in the U.S. with their properties and owners. URL: www.faa.gov. Description: about 200 MB as an ASCII file, about 370 000 records. Look for FAA-master ...
Comment 8 Lionel Elie Mamane 2012-01-19 12:10:30 UTC
(In reply to comment #5)
> 1. open new text document
> 2. <f4> to show databases
>    > shows only No of records = 40 although 59 are available

It shows an asterisk (*) after the record count to say "there are at least that many records, but there may be more, I have not counted/loaded them all yet".

The bug was that it stopped searching at the end of the data it had already loaded, not going further and loading data till the end of the table. Fixed that in master (3.6) in commit 1234d599d4ee67bd725f0513431b2d4c56c9e09d. Patch awaits review to go into libreoffice-3-5.
Comment 9 Lionel Elie Mamane 2012-01-22 06:15:56 UTC
Reviewed and pushed to libreoffice-3-5 by Michael Stahl in http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-3-5&id=fd29a786e3e94710d1e79c0a6c510491ef461302