Bug 44112 - Papiament[uo] locale data needed, pap-AW, pap-BQ
Summary: Papiament[uo] locale data needed, pap-AW, pap-BQ
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-23 18:40 UTC by Ace Suares
Modified: 2015-06-01 17:21 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot 1: Papiament[uo] is not in Language Settings (57.14 KB, image/png)
2011-12-23 18:40 UTC, Ace Suares
Details
Screenshot 2: Papiament[uo] is in Character Language selector (55.24 KB, image/png)
2011-12-23 18:41 UTC, Ace Suares
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ace Suares 2011-12-23 18:40:04 UTC
Created attachment 54773 [details]
Screenshot 1: Papiament[uo]  is not in Language Settings

Problem description: 

Steps to reproduce:
See attachments.
1. Go to Tools->Language->For All Text->More.
2. At 'Default Language for Document' at 'Western' try choosing Papiamentu (Netherlands Antilles) or Papiamento (Aruba). It's not there. (Screenshot 1)


3. Now cancel this and type some words. Select the words and right-click, and from the context menu choose 'Character'. In the Language dropdown, the two languages are there! (Screenshot 2).

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Ubuntu; X11; Linux i686; rv:8.0) Gecko/20100101 Firefox/8.0
Comment 1 Ace Suares 2011-12-23 18:41:38 UTC
Created attachment 54774 [details]
Screenshot 2: Papiament[uo]  is in Character Language selector
Comment 2 A (Andy) 2014-08-02 11:17:38 UTC
reproducible with LO 4.3.0.4 (Win 8.1)

@Eike: Could this issue maybe be something for you?
Comment 3 Eike Rathke 2014-08-04 09:18:27 UTC
A language is only listed in the default document languages if locale data is available, which isn't the case for pap-AN, pap-AW or pap-BQ. Only pap-CW (Curaçao) has locale data.

For how to create locale data please see https://wiki.documentfoundation.org/LibreOffice_Localization_Guide/How_To_Submit_New_Locale_Data
Comment 4 Ace Suares 2014-08-04 09:48:10 UTC
pap-AN is an old denomination (for Netherlands Antilles, which ceased to exist 2010-10-10) and should be removed once pap-CW is properly working.

Since you state that pap-CW has locale data, although I can't remember if I submitted it or someone else, it would be okay to drop pap-AN and then I could release a new spellchekcer for pap-CW (instead of pap-AN).

pap-BQ could use a copy of pap-CW. For pap-AW work needs to be done, which I hope will happen in the forseeable future.

Please advice.
Comment 5 Eike Rathke 2014-08-04 10:15:18 UTC
(In reply to comment #4)
> pap-AN is an old denomination (for Netherlands Antilles, which ceased to
> exist 2010-10-10) and should be removed once pap-CW is properly working.

It should not be removed because there may be documents that use that language assignment and it maps to the defined MS-LCID 0x0479. Maybe there's a way to not offer a language in the list if it isn't already used in the document.

> Since you state that pap-CW has locale data, although I can't remember if I
> submitted it or someone else,

You did :)  with bug 51227

> pap-BQ could use a copy of pap-CW.

That's easy, we have a ref mechanism to refer to another locale's data. I'll do that. Do they share the same currency?

> For pap-AW work needs to be done, which I
> hope will happen in the forseeable future.

Thanks. Just attach the data file here once it's ready.
Comment 6 Ace Suares 2014-08-04 10:21:12 UTC
Thank you Elke, 

No, pap-BQ uses USD since 2010.

Should I submit a new locale or can you copy and change it?

cheers
ace
Comment 7 Eike Rathke 2014-08-04 10:47:39 UTC
I'll do, it doesn't need a full copy.
And btw my name is Eike not Elke ;-)
Comment 8 Ace Suares 2014-08-04 11:57:31 UTC
Sorry Eike... quite a difference I assume :-)
In any case related to Sven Rathke?

Thanks for copying the locale to pap-BQ, I will try to release the spellchecker (for now the same as pap-CW) soon.

Cheers
ace
Comment 9 Commit Notification 2014-08-04 12:25:41 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4189b715999bf9ebb0cd04a0c610a7b514e28d1b

suppress legacy locales, fdo#44112 related



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Eike Rathke 2014-08-04 12:42:58 UTC
(In reply to comment #8)
> Sorry Eike... quite a difference I assume :-)
Yep, i.e. like male and female ;-)
> In any case related to Sven Rathke?
No, also not to Mike Rathke (neither of them).
Comment 11 Commit Notification 2014-08-04 12:58:32 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=252cd689aca204e3437ac3fc7bd320330635f89d

add Papiamento (Bonaire) [pap-BQ] locale data, fdo#44112



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Eike Rathke 2014-08-05 12:30:38 UTC
(In reply to comment #8)
> Thanks for copying the locale to pap-BQ, I will try to release the
> spellchecker (for now the same as pap-CW) soon.

I don't know about your spell-checker, but if it is a LibreOffice dictionary extension you do not need a copy but instead just add the pap-BQ locale in the dictionaries.xcu file.
Comment 13 Adolfo Jayme 2015-05-24 23:49:04 UTC
Dunno why wasn’t this closed FIXED before… anything else to do here?
Comment 14 Eike Rathke 2015-06-01 15:50:52 UTC
Was left open as a reminder for when the dictionary mentioned supported both, pap-AN and pap-CW, as then we could mark pap-AN as legacy not to be displayed in the language list unless used in already existing documents. But the original reporter, Ace, never came back to this. It's fine to have this bug set to resolved.
Comment 15 Ace Suares 2015-06-01 17:21:12 UTC
Thank you,

It's been impossible to get someone 'official' to commit to some standards.
For instance, are we officially using . as thousands-seperator?

This year we will run a project financed by UNESCO and hopefully we will be able to get some people to understand why it is important to have the language well defined, so we can have it in all software applications.

For now, it's okay to close or 'resolve' this.

For your information: .an will cease to exist this month.

.cw is the new TLD for Curaçao (mind the ç in the official name!!)
.bq is for Bonaire
.aw for Aruba (it exists for a long time)
.sx is for St. Maarten

The language in Bonaire and Curaçao and Aruba is the same: Papiamento (in English). But Aruba has a different spelling then Curaçao and Bonaire, and Curaçao has some words different than Bonaire.

So, the language could be pap_AW, pap_CW and pap_BQ 
With those three we could probably do everything that is needed.

pap_AN is obsolete.

Many greetings,

Ace