Bug 44340 - undo does not work on images pasted into calc as a part of html document
Summary: undo does not work on images pasted into calc as a part of html document
Status: RESOLVED DUPLICATE of bug 39217
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-12-31 00:28 UTC by lvm
Modified: 2014-01-05 09:04 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lvm 2011-12-31 00:28:59 UTC
1. open an arbitrary web page with images e.g. http://www.libreoffice.org in a web browser

2. select all (^a)

3. copy to clipboard (^c)

4. open a new spreadsheet in libreoffice calc

5. paste html content with images into a spreadsheet with default options (^v, ok)

6. undo (^z)

text and formatting is undone but images remain - they should be undone too, the result should be an empty spreadsheet

browser used in testing: Mozilla/5.0 (X11; Linux i686; rv:9.0) Gecko/20111217 Firefox/9.0 SeaMonkey/2.6
Comment 1 sasha.libreoffice 2012-05-03 07:08:25 UTC
Thanks for bugreport
reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit and Windows 7 32 bit
(copied from Firefox and on Linux also from Konqueror)
Pictures not undoable and listed in Edit->Links

Changing version to 3.3.4 as most early reproducible
Comment 2 tommy27 2014-01-05 09:04:36 UTC

*** This bug has been marked as a duplicate of bug 39217 ***