Bug 44417 - shortcut left Alt-key behaves different form right Alt-key
Summary: shortcut left Alt-key behaves different form right Alt-key
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.4 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shortcuts-Accelerators
  Show dependency treegraph
 
Reported: 2012-01-03 03:46 UTC by Winfried Donkers
Modified: 2017-09-05 08:20 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers 2012-01-03 03:46:39 UTC
When moving a column, the expected behaviour is that dragging in combination with Alt produces cut/insert and in combination produces copy/insert.
On Windows however, the behaviour with left and right Alt-keys differ:
left Alt-key : move
right Alt-key : copy (as with Ctrl-key)

This behaviour does not occur with Linux, left and right Alt-keys both move and Ctrl-key copies.

For an example, see bug 44383.
Comment 1 Winfried Donkers 2012-01-03 04:00:38 UTC
Addition to first comment:
Ctrl-key copies the source-columns, but overwrites the destination-columns,
right Alt-key copies the source-culomns and inserts (i.e. does not overwrite the destination-columns).
This behaviour is not documented as far as I can see.

This behaviour seems welcome, but
-it should be documented,
-on Linux it should work as well.
Comment 2 QA Administrators 2014-06-25 17:37:58 UTC Comment hidden (obsolete)
Comment 3 Winfried Donkers (retired) 2014-06-26 06:07:15 UTC
Problem as decsribed in comment #0 still exists in version 4.2.5.2 on Windows7.

Steps to reproduce:
-open new calc document
-enter values in A1..A4
-select range A1:A4 
-press left Alt-key and drag selected range with mouse to C11:C14 ; the range is moved, as expected
-press Ctrl-Z to undo move
-select range A1:A4 
-press right Alt-key and drag selected range with mouse to C11:C14 ; the range is copied, which is not as expected
Comment 4 QA Administrators 2015-07-18 17:44:32 UTC Comment hidden (obsolete)
Comment 5 Winfried Donkers (retired) 2015-07-20 06:15:21 UTC
With version 4.4.4.3 the situation seems to be different (but not OK):
Left-Alt, Right-Alt and Left-Ctrl keys cannot be used for copying/moving selected range.
Right-Ctrl will move selected range when dragged with the mouse.

O/S Windows7 (Dutch), keyboard US.
Comment 6 Marek Dolezel 2015-07-21 14:44:06 UTC
I can confirm on win10

Version: 5.1.0.0.alpha1+ (x64)
Build ID: c18f11587d37f285a95447dd8996c8b605732e00
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2015-07-01_21:36:15
Locale: en-GB (en_GB)
Comment 7 QA Administrators 2017-09-01 11:20:41 UTC Comment hidden (obsolete)
Comment 8 Winfried Donkers (retired) 2017-09-05 08:20:30 UTC
I can no longer reproduce the problem with LO version 5.3.6.1 on Winsows10.

Dragging a column moves the column with both Left-Alt and Right-Alt,
dragging a column copies the column with both Left-Ctrl-Alt and Right-Ctrl-Alt.