Download it now!
Bug 44541 - FILEOPEN: Do not open Calc documents saved with password
Summary: FILEOPEN: Do not open Calc documents saved with password
Status: CLOSED DUPLICATE of bug 43868
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.4.5 RC1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-06 10:58 UTC by Ismael Cedillo
Modified: 2012-01-10 12:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ziped file containing two documents of Calc without and saved with password... (the password shoul be "123") (12.89 KB, application/zip)
2012-01-06 10:58 UTC, Ismael Cedillo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ismael Cedillo 2012-01-06 10:58:58 UTC
Created attachment 55220 [details]
ziped file containing two documents of Calc without and saved with password... (the password shoul be "123")

Problem description: 
LibO 3.4.5 RC2 -- Simply do not open Calc files saved with password

Steps to reproduce:
1. ....Into Calc, select <<File>>, <<Open>>
2. ....Select a file tha was saved with password (other version of cacl, i.e.)
3. ....Introduce the password (in the attached file the password is "123").
4. ....See the error message

Current behavior:
LibO 3.4.5 RC2 -- Simply do not open Calc files saved with password

Expected behavior:
Open Calc files saved with password

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Comment 1 Rainer Bielefeld Retired 2012-01-06 11:04:50 UTC
Sounds similar to "Bug 43868 - FILEOPEN document saved with password: correct password not recognized", but that should have been fixed for RC2.

I will test tomorrow.

@reporter:
It's intended that you mention different LibO versions in Version field (RC1) and report text (RC2)?
Comment 2 manj_k 2012-01-06 12:25:56 UTC
Not reproducible (on WinXP 32b · UI en-US) with LibO 3.4.5 RC2
[LibreOffice 3.4.5 · OOO340m1 (Build:502)]

The attached password protected file 'Calc__With_pass.ods' can be opened
with Calc (3.4.5 RC2): "Hola. Esta es una prueba de grabado de archivo con password."
Comment 3 Rainer Bielefeld Retired 2012-01-06 23:48:45 UTC
No longer reproducible with reporter's sample and with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta2- WIN7 Home Premium (64bit) German UI [Build-ID : 8589e48-760cc4d-f39cf3d-1b2857e-60db978]

but [Reproducible] with parallel installation of MinGW Master "LibO-dev 3.5.0 Beta1 – WIN7 Home Premium (64bit) English UI (Build ID: 8935521-b204871-3e50423-4c1bcb5) (daily/Win-x86@7-MinGW/master/2011-12-13_03.17.52)"

So this seems to be a DUP of "Bug 43868 - FILEOPEN document saved with password: correct password not recognized"

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here for 3.5.0Beta2 or later

*** This bug has been marked as a duplicate of bug 43868 ***
Comment 4 Ismael Cedillo 2012-01-10 09:01:09 UTC
I saw that the testes for this report were made on Windows 32b, and I really don't know if with a report for this bug in Windows-32b is enough... but I forgot to mark that it was identified on

Ubuntu 11.10
X86-64 system
and LibreOffice 3.4.5 OOO340m1 (Build:501)

Thanks,
Comment 5 Ismael Cedillo 2012-01-10 09:22:49 UTC
The bug was solved in the 3.4.5 RC2 build 502. 

Thanks
Comment 6 manj_k 2012-01-10 12:58:10 UTC

*** This bug has been marked as a duplicate of bug 43868 ***