Download it now!
Bug 44542 - FILEOPEN impossible for documents that were saved with password
Summary: FILEOPEN impossible for documents that were saved with password
Status: RESOLVED DUPLICATE of bug 43868
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.4.5 RC1
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 44543 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-06 11:04 UTC by Ismael Cedillo
Modified: 2012-01-24 09:02 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
the file saved with password ("123") (9.49 KB, application/vnd.oasis.opendocument.presentation)
2012-01-06 11:04 UTC, Ismael Cedillo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ismael Cedillo 2012-01-06 11:04:17 UTC
Created attachment 55221 [details]
the file saved with password ("123")

Problem description: 
LibO 3.4.5 RC2  -  Simply do not open files that were saved with password

Steps to reproduce:
1. ....open a file saved with password (attached file i.e.)
2. ....type the password required (in the attached file is "123"), but you can save any file with password and check it)
3. ....See the error message

Current behavior:
LibO 3.4.5 RC2  -  Simply do not open files that were saved with password
Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Ubuntu; X11; Linux x86_64; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Comment 1 manj_k 2012-01-06 12:00:39 UTC
Not reproducible (on WinXP 32b · UI en-US) with LibO 3.4.5 RC2
[LibreOffice 3.4.5 · OOO340m1 (Build:502)]

The attached password protected file 'Impress__With_pass.odp' can be opened
with Impress (3.4.5 RC2): "Hola. Esta es una prueba de grabado de archivo con password."

@Ismael Cedillo:
Do you mean RC1 or RC2?
In the summary: 'LibO 3.4.5 RC2',
marked version: 'LibO 3.4.5 RC1'.

Please have also a look at 'Bug 43868 - FILEOPEN document saved with password:
correct password not recognized'.
Comment 2 manj_k 2012-01-06 12:01:28 UTC
*** Bug 44543 has been marked as a duplicate of this bug. ***
Comment 3 Rainer Bielefeld Retired 2012-01-07 11:06:56 UTC
Pretty sure that this one is a DUP of "Bug 43868 - FILEOPEN document saved with password: correct password not recognized".

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 43868 ***
Comment 4 Ismael Cedillo 2012-01-10 08:31:21 UTC
I saw that the testes for this report were made on Windows 32b, and I really don't know if with a report for this bug in Windows-32b is enough... but I forgot to mark that it was identified on

Ubuntu 11.10
X86-64 system
and LibreOffice 3.4.5 OOO340m1 (Build:501)

Thanks,
Comment 5 Ismael Cedillo 2012-01-10 09:21:30 UTC
The bug was solved in the 3.4.5 RC2 build 502. 

Thanks
Comment 6 Rainer Bielefeld Retired 2012-01-10 10:11:37 UTC
I modify Version picker due to Comment 4

No new information that this one is not a DUP, so again DUPed

@Ismael Cedillo:
Please do not touch the Status pickers (and others) if you do not know for what they are. Simply describe your observations precisely!
With comment 5 you wanted to tell us that you were not able to reproduce the problem with 3.4.5 RC2?

If yes, correct status for this Bug would ave been "Resolved Worksforme"
 <https://bugs.freedesktop.org/page.cgi?id=fields.html#status>!
FIXED is only for Bugs with known fix.

But it remains a DUP!

*** This bug has been marked as a duplicate of bug 43868 ***
Comment 7 manj_k 2012-01-10 12:54:37 UTC
*** Bug 44543 has been marked as a duplicate of this bug. ***
Comment 8 Rainer Bielefeld Retired 2012-01-24 09:02:27 UTC
still [Reproducible] with reporter's sample and "LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit) .

Works fine with  "LibreOffice 3.5.0 RC1 German UI/Locale [Build-ID: b6c8ba5-8c0b455-0b5e650-d7f0dd3-b100c87] on German WIN7 Home Premium (64bit)

@Ismael Cedillo:
What's your result? T thougt fix for Bug 43868 - FILEOPEN document saved with password: correct password not recognized should be in 3.4.5?