Bug 44595 - EDITING: Crashing Libre Office by changing font
Summary: EDITING: Crashing Libre Office by changing font
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.4.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-09 05:42 UTC by xemec032010
Modified: 2013-02-05 21:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description xemec032010 2012-01-09 05:42:25 UTC
Problem description: 

Steps to reproduce:
1. Try to change font multiple times and scrolling font list while doing that

Current behavior:
Crash Libre Office

Expected behavior:
change font

Platform (if different from the browser): 
Windows 7 Ultimate 64-bit
Comment 1 Ángel Luis García García 2012-04-24 01:16:28 UTC
[Not Reproducible] with "LibreOffice 3.5.2.2 - Windows XP SP3 (32bit) Spanish UI"
Comment 2 sasha.libreoffice 2012-05-07 06:39:01 UTC
@ xemec032010@sci.fi
Thanks for bugreport
Please, try on another computer and tell result
Comment 3 Roman Eisele 2012-05-08 01:43:48 UTC
NOT REPRODUCIBLE with LibreOffice 3.5.3.2, German langpack installed, on MacOS X 10.6.8.

@ xemec032010@sci.fi:
Could you please tell us if you change the font to some specific font(s)? Which fonts are these? Thank you!

Background: we have some bugs related to specific fonts which crash Windows, e.g. bug 44094 and bug 47553.
Comment 4 Valek Filippov 2012-07-11 22:11:32 UTC
xemec, could you please reply to Roman's comment?
Comment 5 Adam Anderson 2012-12-03 00:27:14 UTC
Ran into this same problem today.

Windows 7 64-bit Ultimate
Libre Office 3.6.3 Win x86

Just upgraded from OOo to LibO.  Created a small Writer document and was completely successful in changing the font from Times New Roman to Calibri and saving the document.

Left that document open and created a new document.  Before adding any text tried to switch the font to Calibri, but upon clicking in the combo-box to select the new font, Libre Office informs me that an unexpected error occurred and begins saving my documents.  The program recoverst he documents just fine, but when I opt to change the font again, the process repeats.

I closed all Libre Office docs, ensured the process had been stopped and tried again with the same result.

When I use Format -> Character and select the font from the dialog, all is well and the program does not crash.  Hopefully thsi provides some useful information to track down this error.
Comment 6 sasha.libreoffice 2012-12-03 09:09:14 UTC
Thanks for additional testing and information
"Version" is most early version of LO where bug appears, not current version.
Changing back to 3.4.4 release
Comment 7 Adam Anderson 2012-12-13 03:18:09 UTC
Thanks for catching me on that.  Didn't know if it needed to be updated to "Still happening in version X" or what.

- A
Comment 8 sasha.libreoffice 2012-12-13 05:26:32 UTC
If bug disappears, we change status to WorksForMe. If bug still exist we just do nothing.
Comment 9 ydutrieux 2012-12-14 17:41:27 UTC
Not reproduced on Libo Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Win7 32bits.

Is this problem not due to a bad profile ?
@Adam, 
have you try to 
- stop libo
- rename your libreoffice direcotry in %appdata%
- and then retry

Regards.
Yves
Comment 10 leo.moons 2012-12-14 20:59:26 UTC
Hello,

I cannot reproduce this bug, did the test as outlined by Adam. I am testing in Windows 7 Home edition and using LibO version 4.0.0 Beta 1
Comment 11 Urmas 2012-12-15 03:15:12 UTC
Xemec, could you please attach the list of the fonts of your system? You can create it by this command in Command Prompt:

dir /a /b %systemroot%\fonts\*.ttf > a_filename_of_your_choice_here
Comment 12 Adam Anderson 2012-12-16 00:29:43 UTC
I can't seem to reproduce the environment that produced the bug either.  It occurred for me several times the day I experienced the issue but now I can't seem to find out how to get it to happen again.

I must have gotten the app into some odd state where it was occurring.  When I experienced the issue I was using a clean install and had only created one other document, with no customization or anything done to profiles.  I'll watch for it and if I can repeat the error, I'll post here again.

Sorry I can't be more help,

- Adam
Comment 13 Adam Anderson 2012-12-19 06:05:29 UTC
OK!  I can now reproduce this bug consistently!

Again just as a refresher - Libre Office v3.6.3.2, build ID: 58f22d5
Windows 7, 64-bit

Steps to reproduce:

1 - Open LibreOffice Writer.

2 - Hit Ctrl+N to open a second new document.

3 - In the second document, click the down arrow on the Font ComboBox in order to choose a new font (on my system, the default font is 'Times New Roman').

4 - Observe the LO crash.  This crash occurs instantly on clicking in the combobox, whether or not you release the mouse button.

5 - If the documents are recovered, attempting to choose a new font will repeat the crash cycle.

Hopefully this will help someone to reproduce the error on a similar system.  Thank you for your time/efforts.

- Adam
Comment 14 Roman Eisele 2012-12-19 08:05:50 UTC
(In reply to comment #13)
> OK! I can now reproduce this bug consistently!

Thank you for the steps to reproduce!

Just a hint: still not reproducible on Mac OS X with LibreOffice 3.6.4.3 (Build ID: 2ef5aff), not with the steps given in comment #13. So a Windows-only bug.

Can someone else please test Adam’s steps on Windows?
Comment 15 Julien Nabet 2012-12-29 08:53:21 UTC
On pc Debian x86-64 with 3.6 sources updated 2 days ago, I don't reproduce this.
I'll give a try to 3.6.4
Comment 16 Julien Nabet 2012-12-29 09:14:55 UTC
On Win7 with 3.6.4.3, I don't reproduce the crash.

xemec032010/Adam:
Did you install any specific fonts?
Do you reproduce this with 3.6.4 and a brand new LO profile (see https://wiki.documentfoundation.org/UserProfile)?
Comment 17 callforbuglibreoffice 2013-01-28 15:58:58 UTC
I've had this exact problem with problem with 3.4.2-ish version (don't remember exactly), now I've upgraded to 3.6.4.3, it seems to be fixed, the rest of my setup is the same. 
Can anybody else with the same problem confirm?
Comment 18 Kedar Bhise 2013-01-30 05:58:49 UTC
(In reply to comment #17)
> I've had this exact problem with problem with 3.4.2-ish version (don't
> remember exactly), now I've upgraded to 3.6.4.3, it seems to be fixed, the
> rest of my setup is the same. 
> Can anybody else with the same problem confirm?

I am using Version 3.6.4.3 (Build ID: 2ef5aff). Confirmed that the problem still exists on this version.

See my comment in bug 37449, comment 12
Comment 19 Julien Nabet 2013-01-30 21:59:58 UTC
Kedar:
After having reading comment of fdo#37449, it seems it's only due to font Roboto.
If it's not the case :
- Did you install any LO specific extensions?
- Did you install any specific fonts?
- What's your Java version?
- Did you try to rename your LO directory profile? (see https://wiki.documentfoundation.org/UserProfile)

I'll try to find some time to test with Roboto font.
Comment 20 Kedar Bhise 2013-01-31 06:04:03 UTC
(In reply to comment #19)
> Kedar:
> After having reading comment of fdo#37449, it seems it's only due to font
> Roboto.
> If it's not the case :
> - Did you install any LO specific extensions?
> - Did you install any specific fonts?
> - What's your Java version?
> - Did you try to rename your LO directory profile? (see
> https://wiki.documentfoundation.org/UserProfile)
> 
> I'll try to find some time to test with Roboto font.

Julien,

LO 4.0.0.2 works now with Roboto. Based on Caolán McNamara's suggestion in bug 37449, comment 30 I have filed a new bug 60102 for culprit font Samanata.ttf.

HTH.

Thanks!
Comment 21 Julien Nabet 2013-02-05 21:44:05 UTC
Kedar: thank you for your feedback.
Put it as WFM.

If someone has another font problem, please follow Caolán's advice https://bugs.freedesktop.org/show_bug.cgi?id=37449#c30