Bug Hunting Session
Bug 60102 - LibreOffice Crash on font preview
Summary: LibreOffice Crash on font preview
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.0.0.2 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-31 06:00 UTC by Kedar Bhise
Modified: 2013-03-08 16:36 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing successful scroll through font preview (57.29 KB, image/png)
2013-02-06 04:47 UTC, Kedar Bhise
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kedar Bhise 2013-01-31 06:00:38 UTC
LibreOffice crashes when scrolling through Fonts Combo Box, only when a specific font called samanata.ttf is installed on my system.

Win XP SP3
Libreoffice Version 4.0.0.2 (Build ID: 5991f37846fc3763493029c4958b57282c2597e)

This is similar to bug 37449 (fixed now, thanks!) and bug 44595.

The font can be obtained at:

http://code.google.com/p/blender-translation/downloads/detail?name=Samanata.ttf

Steps to reproduce:

- Install Samanata.ttf font.
- Open a a document (writer, calc ...) (or create a new one)
- Scroll through the list of fonts to display Samanata

Expected result : Preview of the font
Actual result: Crash

This font is a Devnagari font for Indian / Nepali languages.
Comment 1 Joel Madero 2013-01-31 17:02:48 UTC
No crash for me running the tinderbox build from last night on XP. 

I don't have Devnagari stuff installed on XP (only on Linux) so I'm running a basic English version of XP, when I scroll through font list I see Samanata with the font to the right (looks like Sanskrit or something similar).

I'm going to mark this as WFM, if you can reproduce on upcoming Release Candidate 3 please reopen. Also, please make sure to start with a fresh profile when testing out pre-releases as strange stuff tends to happen in there :-D


Thanks for reporting and for your patience!
Comment 2 Kedar Bhise 2013-02-04 06:44:01 UTC
Tested on Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89).

Crash still persists. Deleting the font Samanata.ttf from the system via Control Panel -> Fonts fixes the problem.

Fresh installation of 4.0.0.3 with no user installed extensions. Only "Installation Extensions" available via LibreOffice installer.
Comment 3 Joel Madero 2013-02-04 16:57:43 UTC
Kedar - please delete your user profile and start with a clean configuration, report back with your results. Thanks!
Comment 4 Julien Nabet 2013-02-04 21:08:36 UTC
Just for the record, I don't reproduce with 4.0 sources updated some days ago on pc Debian x86-64
(I copied the font in ~/.fonts then "fc-cache -fv")
Comment 5 Joel Madero 2013-02-04 21:09:39 UTC
Really makes me think it's the environment then if an experienced developer and an experienced QA member cannot reproduce....
Comment 6 Julien Nabet 2013-02-04 21:22:00 UTC
Kedar: if you still reproduce the crash even after following Joel's advice, could you, for the test, try with 3.6.5?

If you don't reproduce it with 3.6.5 it could give some hint
If you reproduce it with 3.6.5, do you know the last LO version when the preview of this font was ok?
Comment 7 Kedar Bhise 2013-02-05 07:38:26 UTC
(In reply to comment 3)
> Kedar - please delete your user profile and start with a clean configuration,
> report back with your results. Thanks!

Used the guideline at:

https://wiki.documentfoundation.org/UserProfile

to backup and rename my user profile and start LO 4.0.0.3 with a clean user profile. No improvement. Crash still persists.

(In reply to comment 4)
> Just for the record, I don't reproduce with 4.0 sources updated some days
> ago on pc Debian x86-64
> (I copied the font in ~/.fonts then "fc-cache -fv")

This is a follow-on from bug 37449. This behaviour is Windows only. Linux users do not seem to face this problem.

(In reply to comment 5)
> Really makes me think it's the environment then if an experienced developer
> and an experienced QA member cannot reproduce....

Possibly true!

(In reply to comment 6)
> Kedar: if you still reproduce the crash even after following Joel's advice,
> could you, for the test, try with 3.6.5?
> 
> If you don't reproduce it with 3.6.5 it could give some hint
> If you reproduce it with 3.6.5, do you know the last LO version when the
> preview of this font was ok?

Julien,

Tried with a parallel install of 3.6.5 as given in:
https://wiki.documentfoundation.org/Installing_in_parallel

No improvement. Crash still persists.

I had installed the font when I had updated to Version 3.6.4.3 (Build ID: 2ef5aff). Thus, I do not have the last LO version when the preview of this font was ok. Sorry, cannot help here.
Comment 8 Joel Madero 2013-02-05 15:40:14 UTC
Are you able to use the font outside of LibreOffice? This is becoming more and more difficult to track down :-/

I tested in Windows and had no problem
Comment 9 Kedar Bhise 2013-02-06 04:47:12 UTC
Created attachment 74269 [details]
Screenshot showing successful scroll through font preview

(In reply to comment 8)
> Are you able to use the font outside of LibreOffice? This is becoming
> more and more difficult to track down :-/
> 
> I tested in Windows and had no problem

Joel,

I tried other programs like Notepad and Wordpad. No issues there. Also, these programs do not have a font preview inline similar to LO. Do not have MS Office installed on my machine.

Here is some further digging around that I did:

Disabled Java in LO Version 4.0.0.3 (Build ID: 7545bee9c2a0782548772a21bc84a9dcc583b89) and restarted LO. Was able to scroll through the font list successfully without a crash. As can be seen from the attached screenshot, the culprit font Samanata is listed, without a preview. Is this similar to your experience?

Trying the same workaround in Version 3.6.5.2 (Build ID: 5b93205) does not work. Crash still persists.

At the moment, I am ok with the behaviour of 4.0.0.3, with Java disabled. The above experience does point to some mismatch of environment settings to be behind this issue.

Let me know if you need more information.
Comment 10 Caolán McNamara 2013-03-08 16:36:25 UTC
Closing as fixed in 4.0.0 given "I am ok with the behaviour of 4.0.0.3, with Java disabled." Though I still think there's more to this one, but if there is it isn't reproducible