Bug Hunting Session
Bug 44837 - EDITING 'Replace All' clears current selection
Summary: EDITING 'Replace All' clears current selection
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta2
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: target:6.3.0 target:6.4.0
Keywords:
: 90813 (view as bug list)
Depends on:
Blocks: Find&Replace-Dialog
  Show dependency treegraph
 
Reported: 2012-01-16 09:58 UTC by Urmas
Modified: 2019-06-04 13:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
printscreen (94.65 KB, application/vnd.oasis.opendocument.text)
2019-05-30 04:53 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Urmas 2012-01-16 09:58:01 UTC
When replace dialog used with selected text, and 'limit to selection only' checkbox is set, the 'Replace all' button causes current selection to get lost.
Comment 1 Buovjaga 2014-11-07 09:51:33 UTC
Confirmed and set as enhancement, keeping as NEW, because I like the idea of the selection not getting lost.

I wonder if bug 81442 is the same or different?

Win 7 64-bit Version: 4.4.0.0.alpha1+
Build ID: 8b21b5cbe78945b27525b4ce78ae3d981f90590f
TinderBox: Win-x86@39, Branch:master, Time: 2014-11-06_03:55:51
Comment 2 Buovjaga 2015-04-25 15:09:12 UTC
*** Bug 90813 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2019-02-01 07:33:26 UTC
Martin van Zijl committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/9a7d9366125374df07f6a0369a96ee2978f7f24c%5E%21

tdf#44837 fix bug where replace all clears selection

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 Xisco Faulí 2019-03-13 18:41:04 UTC
A polite ping to Martin van Zijl:
Is this bug fixed? if so, could you please close it as RESOLVED FIXED ? Otherwise, Could you please explain what's missing?
Thanks
Comment 5 Xisco Faulí 2019-05-16 10:46:26 UTC
it seems to be fixed in

Version: 6.3.0.0.alpha1+
Build ID: f897342320ad3a29cf4be1437c8e3ce888bdb3cb
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

Closing as VERIFIED FIXED
Comment 6 Xisco Faulí 2019-05-16 10:48:54 UTC
@Martin van Zijl, thanks for fixing this issue!!
Comment 7 raal 2019-05-30 04:53:22 UTC
Created attachment 151770 [details]
printscreen

Hello, please can you retest it? For me the first letter in selection is lost. See prinstcreens

steps>
write  bsdbsd
select all
find and replace: b > a ; current selection only
after "replace all" only the string "sdasd" is select

string "asdasd" should be selected.
Comment 8 Xisco Faulí 2019-06-03 09:57:15 UTC
(In reply to raal from comment #7)
> Created attachment 151770 [details]
> printscreen
> 
> Hello, please can you retest it? For me the first letter in selection is
> lost. See prinstcreens
> 
> steps>
> write  bsdbsd
> select all
> find and replace: b > a ; current selection only
> after "replace all" only the string "sdasd" is select
> 
> string "asdasd" should be selected.

I can reproduce it in

Version: 6.3.0.0.beta1+
Build ID: 219e128553645911685b6061f7c5ea359a4c551c
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); UI-Language: en-US
Calc: threaded

@Raal, could you please create a follow-up bug ?
Comment 9 Commit Notification 2019-06-04 13:17:28 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/5c96421607dadca284902d127004fcc12fd89b84%5E%21

uitest for bug tdf#44837

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.