Download it now!
Bug 90813 - Selected Text *Deselected* after Find & Replace Operation
Summary: Selected Text *Deselected* after Find & Replace Operation
Status: RESOLVED DUPLICATE of bug 44837
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.2.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-04-23 13:32 UTC by Patrick Gillespie
Modified: 2015-04-25 15:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Gillespie 2015-04-23 13:32:42 UTC
If, in a larger document, I select a block of text in which repeated search & replace operations are required, I'm presently forced to *re*-select the text after each operation.

For example, I select several pages in a deocument of several hundred:

Search    $ (Regular expression checked)
Replace   % (Replace Hard Returns with Percentage Symbol)

All text is deselected with S&R completes. I then have to manually reselect all the same text:

Search    %% (All double hard returns have been replaced with double %%)
Replace   %  (Replace double with single.)

All text is deselected. Wash. Rinse Repeat.

In the end, the point of this particular example is to replace all double hard returns with single hard returns, but I'm forced to reselect the text numerous times. 

The expected behavior is this: Selected Text remains selected until I manually deselect it.

Work Around: Copy selected text into separate window, make all changes there, then paste back into source document. This is currently much quicker but an inelegant solution.
Comment 1 Buovjaga 2015-04-25 15:09:12 UTC

*** This bug has been marked as a duplicate of bug 44837 ***