Bug Hunting Session
Bug 44838 - FORMATTING: Position, size, word wrap wrong for WRITER OLE Object in CALC
Summary: FORMATTING: Position, size, word wrap wrong for WRITER OLE Object in CALC
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta3
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: preBibisect, regression
Depends on:
Blocks: OLE-Object-Interoperability
  Show dependency treegraph
 
Reported: 2012-01-16 10:33 UTC by Rainer Bielefeld Retired
Modified: 2017-01-03 23:47 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
test kit (847.90 KB, application/x-zip-compressed)
2012-01-16 10:33 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-01-16 10:33:16 UTC
Created attachment 55648 [details]
test kit

Steps to reproduce with Parallel Dev-Installation of  "LibreOffice 3.5.0 Beta3- WIN7 Home Premium (64bit) German UI [Build-ID: e40af8c-10029e3-615e522-88673a2-727f724] :
1. download and unzip attached test kit
2. Start LibO
3. Open Calc document from LibO Start Center File dialog
4. Open Writer document from File dialog
5. compare view of OLE object in Spreadsheet first sheet with
   View of WRITER source of OLE object
  

Current behavior: : in  Calc Object is truncated at top and right, contour wrap does not work correctly (some text behind picture 
Expected behavior: should look identical

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20111221 Firefox/9.0.1 SeaMonkey/2.6.1
Comment 1 sasha.libreoffice 2012-02-17 06:04:51 UTC
reproduced problem in 3.5.0 and 3.6.0 master 97fdf02-9eed775-f061262 on Fedora 64 bit.
Spreadsheet contains 3 pages, first page contains OLE, others contains screenshot
What is interesting: when I created new spreadsheet and inserted odt file from attachment by Insert->Object->Ole->from file, all was OK. But after double click on object and attempt to resize, appears problem with picture in top righthand corner.
not reproducible in 3.3.4, so my be regression
Comment 2 sasha.libreoffice 2012-02-17 06:10:18 UTC
Experiments with inserting ole into Calc and resizing object on Windows XP 32 bit:
3.4.2 no problem
3.5.0 beta 3: picture on top righthand becomes corrupted, as if overwrited by text.
so regression is since 3.4 version
Comment 3 Rainer Bielefeld Retired 2012-03-11 03:05:27 UTC
Bug 47197 - VIEWING of OLE objects destroyed in other LibO applications is concerning very similar problems, but those ones also exist with LibO 3.3.0

Michael:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug.
Comment 4 Rainer Bielefeld Retired 2012-03-11 03:28:53 UTC
I see an other effect, IMHO related, ok with 3.3.0, broken in 3.4.6RC1, 3.4.1RC, OK in 3.3.0

0. Select "Text for copy / paste" below, <control+c> for copy
1. open new CALC document
2. Click A1, insert new WRITER OLE object
3. <control+v> to paste text from below into OLE object after click into object
4. Click outside object
   Expected: First paragraph of text shown filling cell range A1:G3 
             (more or less), not exceeding object (control points)
   Actual: Text contents shown in B1:H5, starts with "pppp..." instead 
           of "aa...", wide left empty margin, text exceeds object at the right
           
WRITER OLE objet handling seems to be completely broken.

Text for copy / paste:
Aaaaaaaaaaaaaaaaaaaaaaaaaa bbbbbbbbbbbbbbbbb cccccccccccccccccccc dddddddddd eeeeeeeeeeee ffffffffffff gggggggggggg hhhhhhhhhhhhhhhh iiiiiiiiiiiiiiiiiii jjjjjjjjjjjjjjj kkkkkkkkkkkkkkkk lllllllllllllll mmmmmmmmmmmmm nnnnnnnnnnnnnn ooooooooooooo ppppppppppppp qqqqqqqqqqqq rrrrrrrrrrrrr ssssssssssssssss ttttttttttttt.
Aaaaaaaaaaaaaaaaaaaaaaaaaa bbbbbbbbbbbbbbbbb cccccccccccccccccccc dddddddddd eeeeeeeeeeee ffffffffffff gggggggggggg hhhhhhhhhhhhhhhh iiiiiiiiiiiiiiiiiii jjjjjjjjjjjjjjj kkkkkkkkkkkkkkkk lllllllllllllll mmmmmmmmmmmmm nnnnnnnnnnnnnn ooooooooooooo ppppppppppppp qqqqqqqqqqqq rrrrrrrrrrrrr ssssssssssssssss ttttttttttttt.
Aaaaaaaaaaaaaaaaaaaaaaaaaa bbbbbbbbbbbbbbbbb cccccccccccccccccccc dddddddddd eeeeeeeeeeee ffffffffffff gggggggggggg hhhhhhhhhhhhhhhh iiiiiiiiiiiiiiiiiii jjjjjjjjjjjjjjj kkkkkkkkkkkkkkkk lllllllllllllll mmmmmmmmmmmmm nnnnnnnnnnnnnn ooooooooooooo ppppppppppppp qqqqqqqqqqqq rrrrrrrrrrrrr ssssssssssssssss ttttttttttttt.
Comment 5 Korrawit Pruegsanusak 2012-05-05 04:41:03 UTC
For the problem of incorrect view in comment 0, bibisected35 and bibisected35older.
Comment 6 sasha.libreoffice 2012-06-18 03:31:09 UTC
*** Bug 47737 has been marked as a duplicate of this bug. ***
Comment 7 Joel Madero 2013-02-12 22:31:22 UTC
Maybe it's just me but looking at this in LibreOffice 4, they look identical to me....am I missing something?

Removing from MAB for now, Rainer if you could clarify that it's still a bug in LibreOffice 4 and then you can decide if we want it on 3.6 MAB. Not sure if this affects enough people to constitute as a MAB but it's your call.


Thanks!
Comment 8 sasha.libreoffice 2013-09-23 10:36:55 UTC
LO 4.1.1.2 on Fedora (RFR) 64 bit:
[Reproduced] using this:
when I created new spreadsheet and inserted odt file from attachment by Insert->Object->Ole->from file, all was OK. But after double click on object and attempt to resize, appears problem with picture in top righthand corner.
Comment 9 Robinson Tryon (qubit) 2015-12-14 05:41:29 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2017-01-03 19:50:59 UTC Comment hidden (obsolete)
Comment 11 Hans Deragon 2017-01-03 23:47:42 UTC
As of version: 5.2.3.2 Build ID: 1:5.2.3~rc2-0ubuntu1~xenial, this issue has been magically fixed. Closing it.