Bug Hunting Session
Bug 44887 (coretext) - Enhancement request: Coretext rendering on Mac OS X
Summary: Enhancement request: Coretext rendering on Mac OS X
Status: RESOLVED FIXED
Alias: coretext
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other Mac OS X (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist 56932 33302 57256
  Show dependency treegraph
 
Reported: 2012-01-18 01:26 UTC by Emir Sarı (away)
Modified: 2013-08-16 06:01 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı (away) 2012-01-18 01:26:43 UTC
Currently text rendering on Mac OS X is very buggy and unreliable. I am sure nearly all Mac OS X LibreOffice users will relate, there are lots of problems. Distorted text, not displayed typefaces, not rendered glyphs... 

My humble opinion is switching to Coretext would really be a good idea.
Comment 1 Michael Meeks 2012-01-18 05:33:08 UTC
Which makes me wonder: in extremis would it be better to simply re-use the Linux / fontconfig / freetype rendering for Mac :-)
Comment 2 Emir Sarı (away) 2012-01-18 09:28:01 UTC
Under Mac, it should be the Mac way.
Comment 3 Ni 2013-01-23 23:19:15 UTC
I agree that the current font rendering is not optimal. The text looks more blurry than in other Mac applications using CoreText. Migrating to CoreText would be very useful to Mac users.
Comment 4 Handyman 2013-03-18 21:22:04 UTC
I find the screen text rendering a bit fuzzy. Enough so to switch back to NeoOffice. I would prefer to use LibreOffice, but the rendering is not up to par. Note: I'm using a non-retina Macbook screen. I would imagine the issue is even worse on a retina screen.
Comment 5 Don't use this account, use tml@iki.fi 2013-06-24 08:19:16 UTC
CoreText can now be used.
Comment 6 Handyman 2013-08-16 03:59:57 UTC
I see no improvement in text fuzziness after upgrading to LibreOffice v4.1.
Comment 7 Don't use this account, use tml@iki.fi 2013-08-16 06:01:07 UTC
*This* bug report is already resolved, will stay that way as LibreOffice now does use CoreText. Handyman, please open a detailed new bug specifically for your fuzziness issue, and please provide a screenshot.

Note that nobody else has mentioned any fuzziness problem in relation to the CoreText code. The known problems with (CoreText-based) text rendering in some contexts in LibreOffice, some of which might already be fixed, are all related to placement of glyphs, that is suboptimal, "jumpy" when text is edited or added, or broken, especially for complex text (Arabic etc).