Download it now!
Bug 57256 - [Writer] [RTL] [Mac] Arabic letters not connecting
Summary: [Writer] [RTL] [Mac] Arabic letters not connecting
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: x86 (IA32) Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on: coretext
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2012-11-18 19:04 UTC by Emir Sarı
Modified: 2013-05-29 05:45 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Arabic letters with Tahoma font (121.42 KB, image/png)
2012-11-18 19:04 UTC, Emir Sarı
Details
Arabic letters with Geeza Pro typeface (121.67 KB, image/png)
2012-11-18 19:04 UTC, Emir Sarı
Details
LO 4.0.0.0 alpha 1 screenshot (13.21 KB, image/png)
2012-11-22 21:06 UTC, Emir Sarı
Details
sample arabic text (16.15 KB, application/vnd.oasis.opendocument.text)
2012-11-27 10:48 UTC, Emir Sarı
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emir Sarı 2012-11-18 19:04:17 UTC
Created attachment 70229 [details]
Arabic letters with Tahoma font

Hello,

OS X 10.7.5

Steps to reproduce:

1. Open LO Writer
2. Switch to an Arabic keyboard layout 
3. Type something
Expected behaviour: Letters should be connected to each other
Received behaviour: Letters do not connect. 

Possible workaround: This happens with Tahoma font. If the font is changed to Geeza Pro, letters do connect. But with Tahoma font it is broken. 

Changing the default Mac RTL font to Geeza Pro may temporarily solve this problem, but this is definitely an important bug. In NeoOffice both letters with both fonts do connect fine.
Comment 1 Emir Sarı 2012-11-18 19:04:58 UTC
Created attachment 70230 [details]
Arabic letters with Geeza Pro typeface
Comment 2 Emir Sarı 2012-11-22 21:06:35 UTC
Created attachment 70457 [details]
LO 4.0.0.0 alpha 1 screenshot
Comment 3 Roman Eisele 2012-11-27 09:58:57 UTC
@ Emir Sarı:
Thank you for your bug report! Could you please attach a simple sample file in .odt format, just containing some (correct) Arabic words? Because typing Arabic is difficult for us ignorant Europeans and Americans who are used to Latin (and maybe Greek and/or Cyrillic) letters only ... ;-)
Comment 4 Emir Sarı 2012-11-27 10:48:53 UTC
Created attachment 70649 [details]
sample arabic text

@Roman Eisele,

Adding some sample text, first two lines are formatted with Geeza Pro typeface, and the last two lines are formatted with Tahoma Arabic.
Comment 5 Roman Eisele 2012-11-27 16:54:25 UTC
Thank you very much for the sample file!

Using Emir Sarı’s sample file, this bug is easily REPRODUCIBLE with LibreOffice 3.6.4.1 on Mac OS X (10.6.8).

The bug is already reproducible with the same results in LibreOffice 3.3.0 (and all following versions), and also reproducible in AOO 3.4.0, so this bug is probably inherited from OOo.

The bug is also still reproducible in the newest master builds.


Which fonts work and which don’t? I tested the fonts installed on my machine which include complete Arabic character sets, and found:

LibreOffice connects letters (correct) with
* Al Bayan
* Baghdad
* DecoType Nashkh
* Geeza Pro
* Kufi Standard GK
* Nadeem

LibreOffice fails to connect letters (wrong) with
* Arial
* Arial Unicode MS
* Microsoft Sans Serif
* Tahoma
* Times New Roman

(This suggests to me a simple idea: IIRC, all fonts in the former (correct) group are installed by Apple/Mac OS X itself; all fonts in the later (wrong) group come from Microsoft (Office etc.) :-) No, I don’t want to blame Microsoft; my idea is rather that ATSUI (and thus LibreOffice?) may *know* about the fonts in the correct group, i.e. recognize them correctly as Arabic fonts, but does *not* know about the latter group, and therefore does not know about these fonts. Is this possible? I don’t know, but a developer experienced in this area could tell us about that ...)
Comment 6 Ahmad Harthi 2013-05-29 05:45:40 UTC
Fixed in LO 4.1 Beta1.