Bug 44911 - [es_ES] Keyboard shortcut Ctrl-B/Cmd-B used 2 times in Spanish localization, for "File > New" and "bold style", so only one of them works
Summary: [es_ES] Keyboard shortcut Ctrl-B/Cmd-B used 2 times in Spanish localization, ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.3.4 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-18 12:20 UTC by Wild Nomad
Modified: 2014-08-15 09:27 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wild Nomad 2012-01-18 12:20:28 UTC
Problem description: 
The default shortcut for "bold-style" in Spanish MacOS X LibreOffice suite is Cmd+N, but when you use it a new document window is created instead.

Steps to reproduce:
1. Open LibreOffice Writer/Impress/etc with Spanish localization.
2. Type some text
3. Put the cursor over any word
4. Press Cmd+N to turn it bold
5. A new document is open instead

Current behavior:
A new document windows gets open.

Expected behavior:
Bold-style is toggled.

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0) Gecko/20100101 Firefox/10.0

Additional information:
Looking at keyboard preferences, it seems that the default keyboard shortcut for "New document" is Cmd+U, which is OK, but it doesn't get honored by the OS: if you dig into the menu bar looking for "Archivo (File) | Nuevo (New) | Documento de texto (Text document)" you can see that the shortcut asigned is Cmd+N (which is, by the way, the default system-wide MacOS shortcut for New document).
Comment 1 Benjamín Valero Espinosa 2012-01-29 15:57:58 UTC
I have the same problem in Mac. Curiously in Linux (Fedora) Ctrl+N makes bold but Ctrl+Shift+N opens New Document.
Comment 2 Christian Finnberg 2012-02-08 00:33:33 UTC
Notice that the default Cmd+N shortcut in Mac is to open a new window but I don't know if Libreoffice is meant to overpass that.

Anyway I have the same problem and it have been hard to assign a new key because the shortcut list seems to have the less preference. For example: If I assign the "Bold" function to the cmd-B key, when I try to use it, what comes up is the Find ("Buscar" in spanish). For the record, I have first cleared the cmd-B field in the keyboard shortcuts table.
So I tried with other key combinations that **are free** in the keyboard shortcuts table but was always binded to any other function of the Mac OS X system or the LibreOffice Suite. Finally I managed to find the Shift-cmd-C combination (very intuitive ;-D) that seems to work well.
Comment 3 Roman Eisele 2012-09-25 14:37:48 UTC
Reset version number to original value -- 3.3.4. Please note that the Version field should always contain the number of the FIRST version which is known to contain the bug, and NOT the last one. Thank you!
Comment 4 Roman Eisele 2012-09-25 15:04:58 UTC
Still REPRODUCIBLE with LibreOffice 3.6.2.1 (Build ID: ba822cc) on Mac OS X 10.6.8 (Intel).

* The tooltip for the bold button in the toolbar says: “Negrita (Cmd-N)”.
* But the menu “File > New > ...” (in Spanish: “Archivo > Nuevo > ...” also says, depending on which component is active, that Command-N is used for a new Writer document (if Writer is active), a new presentation (if Impress is active), etc.

So there is a clear keyboard shortcut conflict, and the menu shortcut (new document) wins.

This seems even reasonable, given that Command-N is the “new document” shortcut in many other languages. But it also means that there is by default no working keyboard shortcut for bold text (negrita), which is probably one of the most often used commands, and therefore definitely *should* have a working keyboard shortcut by default.

Pressing Command-B (the default “bold” shortcut in many languages) does open the “Find” toolbar (because of “buscar” = find). But pressing Command-F also opens the “Find” toolbar, which is an unnecesary duplication.

So a reasonable solution would be to use:
* Command-B for bold text
* Command-N for new document
* Command-F for the find toolbar.
This would follow the international (English) standard, and it would at least work (unlike the status quo).

But we should also check what are the most common keyboard shortcuts in other Spanish applications. E.g., which keyboard shortcuts does MS Office use with Spanish UI?
Comment 5 Roman Eisele 2012-09-29 09:07:58 UTC
I have tested this issue with LibreOffice 3.5.7.1 on Win XP, and there is the same issue: Control-B is used two times:

* The tooltip for the bold button in the toolbar says: “Negrita (Ctrl-N)”.
* But the menu “File > New > ...” (in Spanish: “Archivo > Nuevo > ...”) also says, depending on which component is active, that Ctrl-N is used for a new Writer document (if Writer is active), a new presentation (if Impress is active), and so on.

The only difference is that on Mac OS X the “File > New >...” action wins, while on Windows the “bold text” action wins. This makes the situation even worse: when you switch between Windows and Mac OS X, the same keyboard shortcut (Ctrl-B = Command-B) triggers two completely different actions.

So I suggest at least to remove one of the two identical shortcuts.

I have checked the French localization of LibO, and there the international (English) standard is used:
* Command-B for bold text
* Command-N for new document
* Command-F for the find toolbar.
So, if even the French localization uses the English shortcuts, I would suggest that the Spanish should do the same.

Another reasonable solution would be to change one of the two Ctlr-N/Cmd-N shortcuts to Ctrl-Shift-N/Cmd-Shift-N.

Some Spanish experts should decide this. Again: which keyboard shortcuts does MS Office use with Spanish UI?
Comment 6 Julien Nabet 2013-07-22 11:42:18 UTC
Adolfo: you might be interested in this bugtracker.
Comment 7 Herminio García 2013-11-05 11:21:55 UTC
Still happening in LibreOffice 4.1.2.3 in Windows 8.1.

When I press Ctrl+N bold-style is toggled but there is no way to create a new document with this shortcut.

With Ctrl+Shift+N a document can be created by choosing a template in the template
manager, so this shortcut is taken.

In MS Office 2013 there is not a new document shortcut, in Spanish version. Ctrl+N is only mapped to bold-style.
Comment 8 Adolfo Jayme Barrientos 2013-11-09 23:07:53 UTC
(In reply to comment #5)
> Some Spanish experts should decide this. Again: which keyboard shortcuts
> does MS Office use with Spanish UI?

Ctrl+U is used in Spanish-language MS Office.
Comment 9 Julien Nabet 2014-06-13 22:38:44 UTC
On pc Debian x86-64 with master sources updated today and on 4.2.4 LO Debian package with Spanish UI, I've got exactly this:
ctrl+n = Bold (Negrita)
ctrl+s = Underline (Subrayado)
ctrl+k = Italic (Cursiva because ctrl+c is used ^-^)
ctrl+u = New Document

(as https://bugs.freedesktop.org/show_bug.cgi?id=79933#c8 indicated).

Adolfo: may we close this one?
Comment 10 Adolfo Jayme Barrientos 2014-08-15 09:27:07 UTC
Sorry for taking so long to get back to you, I must have missed the notification. So it works as Julien describes, in 4.3.