Download it now!
Bug 45049 - Non-standard caption number and reference do not appear in the insert cross-reference dialog
Summary: Non-standard caption number and reference do not appear in the insert cross-r...
Status: RESOLVED DUPLICATE of bug 50139
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: x86 (IA32) All
: medium major
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
: 45629 46663 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-01-21 12:02 UTC by andis.lazdins
Modified: 2012-06-05 12:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Cross-reference error (205.56 KB, application/vnd.oasis.opendocument.text)
2012-01-21 12:02 UTC, andis.lazdins
Details
Another example of error in insert cross-references dialogue (383.00 KB, application/vnd.oasis.opendocument.text)
2012-02-05 00:30 UTC, andis.lazdins
Details
Cross-reference dialogue in Libreoffice 3.3.4 and 3.5 RC3 (74.65 KB, application/vnd.oasis.opendocument.text)
2012-02-06 05:26 UTC, andis.lazdins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andis.lazdins 2012-01-21 12:02:28 UTC
Created attachment 55924 [details]
Cross-reference error

I use Insert > Fields > Variables > Numbered range function to add number and label to captions to images in Writer, because it is not possible to insert captions to images and charts without frame (in contrast to tables).
In Libreoffice 3.5 b3 Writer I do not see reference to non-standard captions (for instance "1. Attēls". The same happens with automated insert captions in frames, if number is before reference. If non-standard reference is before number (Attēls 1 un example) in appears in the cross reference dialog incomplete.
Comment 1 andis.lazdins 2012-01-21 23:59:26 UTC
The problem persist in Libreoffice 3.5 RC1. I would say it is critical bug.
Comment 2 andis.lazdins 2012-01-28 05:53:46 UTC
The error still persists in the Libreoffice 3.5 RC2. Is there anybody looking for the Writer bugs? 

As soon as the Calc becomes useful again in version 3.5, something horrible is introduced in Writer. It's time to split those applications so the useful things can be used otherwise every new release introduces critical bugs somewhere making useless the whole suite.
Comment 3 andis.lazdins 2012-02-05 00:30:34 UTC
Created attachment 56614 [details]
Another example of error in insert cross-references dialogue

The error persist in Libreoffice 3.5 RC3 under Ubuntu 11.10. It is critical problem making the whole suite useless for document writing.
Comment 4 andis.lazdins 2012-02-05 07:43:29 UTC
The problem appears also in Libreoffice 3.5 RC3 on Windows XP SP3
Comment 5 andis.lazdins 2012-02-05 07:44:28 UTC
The bug is relevant to this one: https://bugs.freedesktop.org/show_bug.cgi?id=45629
Comment 6 Cor Nouws 2012-02-06 05:06:46 UTC
Hi Andis,

The document looks the same when I open it in 3.5.0 and 3.4.5 and 3.3.0.
But that's not the problem, if I understand you correct.

Looking at the Cros reference dialog, field 'Selection' that shows

  1
  Attëls 2

in 3.3.0 and 3.4.5

and 
      (blanc)
  ttëls 2

in 3.5.0


(I remember vaguely that I've seem a post about this before..)
Comment 7 Cor Nouws 2012-02-06 05:07:40 UTC
PS Sorry for not having looked earlier !
Comment 8 Cor Nouws 2012-02-06 05:08:30 UTC
*** Bug 45629 has been marked as a duplicate of this bug. ***
Comment 9 andis.lazdins 2012-02-06 05:26:42 UTC
Created attachment 56667 [details]
Cross-reference dialogue in Libreoffice 3.3.4 and 3.5 RC3
Comment 10 andis.lazdins 2012-02-06 05:30:40 UTC
(In reply to comment #6)
> Hi Andis,
> 
> The document looks the same when I open it in 3.5.0 and 3.4.5 and 3.3.0.
> But that's not the problem, if I understand you correct.
> 
> Looking at the Cros reference dialog, field 'Selection' that shows
> 
>   1
>   Attëls 2
> 
> in 3.3.0 and 3.4.5
> 
> and 
>       (blanc)
>   ttëls 2
> 
> in 3.5.0
> 
> 
> (I remember vaguely that I've seem a post about this before..)

Hello!

The problem indeed is in the insert cross-reference dialogue. The 3rd attachment shows, how it looks for the same file in Libreoffice 3.3.4 and 3.5 RC3. I don't know about 3.4, because I don't use it due to major bug in opening complex spreadsheets, which is somehow solved in 3.5. I suppose that the problem with cross-referencing is quite serious.
Comment 11 Michael Meeks 2012-02-17 09:07:24 UTC
> As soon as the Calc becomes useful again in version 3.5, something horrible
> is introduced in Writer. It's time to split those applications ...

So - the reason Calc is useful again is that we have rather comprehensive unit tests that prove that we havn't regressed in hundreds of common ways :-) We also didn't merge a ton of code of very mixed quality from Oracle just before the 3.5 release as we did for 3.4. So I expect calc quality to stay high going forward.

Writer on the other hand has very, very few-to-no unit tests at all, which means we will get more problems there going forward.

The solution to that is not moaning about it, but encouraging people to write unit tests, and making that process as easy as possible. This is a good example - it should be quite possible to write a unit test for it. If you'd like to work on that contact me for some help.
Comment 12 andis.lazdins 2012-02-18 23:36:23 UTC
(In reply to comment #11)

> The solution to that is not moaning about it, but encouraging people to write unit tests, and making that process as easy as possible. This is a good example -
> it should be quite possible to write a unit test for it. If you'd like to work on that contact me for some help.

Good morning!

Unfortunately, I'm not a programmer at all and I'm afraid I can't contribute to writing code of the program. I'm trying to compensate it with monetary donations. 
However, if I can contribute with writing tests (as I understand tests are sample documents, containing routine or some more advanced operations used in everyday work, to check behaviour of the program) I would be happy to help. I'm working mostly with calc and writer, for more than 10 years, using automation as much as I can with my skills.

Regards,

Andis
Comment 13 andis.lazdins 2012-02-28 01:45:18 UTC
Hi!

The problem persist also in 3.5.1 RC1.
Comment 14 vitruss 2012-03-01 08:56:56 UTC
*** Bug 46663 has been marked as a duplicate of this bug. ***
Comment 15 andis.lazdins 2012-03-07 08:32:48 UTC
Hi!

The problem persist in 3.5.1 RC2

Ubuntu 11.10
Comment 16 andis.lazdins 2012-03-19 00:07:51 UTC
The problem persists also in 3.6 alfa branch on Ubuntu 11.10 32 bit
Comment 17 andis.lazdins 2012-03-20 23:17:01 UTC
The problem persists in LibreOffice 3.5.2.1. Is there any proposals to try to solve it? This is basic function of writer!
Comment 18 andis.lazdins 2012-03-24 00:23:53 UTC
The problems is still there - LOdev 3.6.0alpha0+ Build ID: 9e890ae-1ac6932-6299bf6-879ce36-638d9c; Ubuntu 11.10 32 bit
Comment 19 andis.lazdins 2012-04-20 11:46:43 UTC
The problem is still there LibreOffice 3.5.3.1 Build ID: 21cb047-d7e6025-9ba54fc-b4a51a8-f42372b

Ubuntu 11.10 32 bit
Comment 20 andis.lazdins 2012-04-30 20:00:08 UTC
The problem is not solved in LibreOffice 3.5.3.2, Build ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80. Ubuntu 12.04
Comment 21 andis.lazdins 2012-05-10 00:06:22 UTC
Openoffice.org 3.4 do not have this problem, having at the same time all new features (not bugs) in Calc. It is also more stable working with complex spreadsheet documents. So I'm moving to openoffice.org until better times.
Comment 22 andis.lazdins 2012-05-10 01:43:52 UTC
But they have something even worse now - font colour is not appearing in writer and calc :(
Comment 23 andis.lazdins 2012-05-17 07:30:45 UTC
The problem is not solved in 3.5.4.1 
Build ID: 7306755-f4f605c-738527d-1cf4bc1-9930dc8
Ubuntu linux 12.04
Comment 24 andis.lazdins 2012-05-24 00:02:29 UTC
The problem is still there, Ubuntu 12.04 LibreOffice 3.5.4.2 Build ID: 165a79a-7059095-e13bb37-fef39a4-9503d18
Comment 25 Andras Timar 2012-06-05 12:57:00 UTC

*** This bug has been marked as a duplicate of bug 50139 ***