Download it now!
Bug 50139 - UI: Cross-references -> index tab "selection" -> "illustration" field contents is cut at left
Summary: UI: Cross-references -> index tab "selection" -> "illustration" field content...
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Andras Timar
URL:
Whiteboard: target:3.6.0.0.beta1 target:3.7.0 tar...
Keywords: regression
: 45049 45619 46714 46929 47042 48847 50305 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-20 01:43 UTC by Jochen
Modified: 2013-08-01 15:15 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
problem shown in german version (59.74 KB, image/jpeg)
2012-05-20 01:43 UTC, Jochen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jochen 2012-05-20 01:43:17 UTC
Created attachment 61876 [details]
problem shown in german version

First step:
In Writer-menue click on "Insert" -> "Picture" -> "From File" -> insert <example picture> with style "Graphics" -> right mouseclick on inserted picture ->  "Caption..." ->  insert e.g. "example-text" using category "Illustration".

Second step:
In Writer-menue click on "Fields" -> "Other..." -> "cross-references" -> select Type "Illustration"

Problem:
In selection "llustration 1" is shown, i.e. the "I" is missing.
The same behavior in the German version (here: "bbildung" instead of "Abbildung"; s. attach")
Comment 1 Florian Reisinger 2012-05-20 01:48:02 UTC
Yes,I can confirm this... It is quite annoying IMHO...
Comment 2 Rainer Bielefeld Retired 2012-05-20 03:05:20 UTC
[Reproducible] with "LibreOffice 3.5.4.1 (RC1) German UI/Locale [Build-ID: 7306755-f4f605c-738527d-1cf4bc1-9930dc8] on German WIN7 Home Premium (64bit) 

Problem started very early in Master, already [Reproducible] with Server installation of Master "LibO-dev 3.5.0  – WIN7 Home Premium (64bit) English UI 
[(Build ID:d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf)]"  
in (July 2011)

Also reproducible with Ubuntu Linux / LibO 3.5.2 (VirtualBox)

Was not a problem in OOo 3.2, LibO 3.3.1, LibO 3.4.5

@Michael:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.
Comment 3 Christian Lohmaier 2012-05-20 04:30:22 UTC
*** Bug 45619 has been marked as a duplicate of this bug. ***
Comment 4 Anonymous Helper 2012-05-20 07:37:33 UTC
Confirmed for LibreOffice 3.5.3.2 german in Win XP.
Comment 5 Rainer Bielefeld Retired 2012-05-24 07:14:24 UTC
*** Bug 50305 has been marked as a duplicate of this bug. ***
Comment 6 Rainer Bielefeld Retired 2012-05-24 07:15:27 UTC
Seems to be a more general Caption problem due to "Bug 50305 - 'T' missing from Table in Cross-references Selection box - EDITING"
Comment 7 Andras Timar 2012-06-05 12:54:46 UTC
*** Bug 47042 has been marked as a duplicate of this bug. ***
Comment 8 Andras Timar 2012-06-05 12:55:39 UTC
*** Bug 46714 has been marked as a duplicate of this bug. ***
Comment 9 Not Assigned 2012-06-05 12:55:56 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=89fbb7fc5a71a98f187ebb159ace053f7a28d291&g=libreoffice-3-6

fdo#50139 do not cut first character of field text


It will be available in LibreOffice 3.6.
Comment 10 Not Assigned 2012-06-05 12:56:22 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f2bcd32bfd92f85ad4d94b4e40542dc419b3e2c2

fdo#50139 do not cut first character of field text
Comment 11 Andras Timar 2012-06-05 12:57:00 UTC
*** Bug 45049 has been marked as a duplicate of this bug. ***
Comment 12 Andras Timar 2012-06-05 12:57:46 UTC
*** Bug 48847 has been marked as a duplicate of this bug. ***
Comment 13 andis.lazdins 2012-06-05 22:15:59 UTC
(In reply to comment #11)
> *** Bug 45049 has been marked as a duplicate of this bug. ***

The problem is not only cutting first character, but complete disappearing of all references including numbers in the Insert cross-reference dialogue, it caption text stays before caption number. Cutting first letter is not a problem, it makes some discomfort, but disappearing of the whole reference list, like it is described here https://bugs.freedesktop.org/show_bug.cgi?id=45049 is real problem. At the same time it would be reasonable to take care for this https://bugs.freedesktop.org/show_bug.cgi?id=50144 because it is really  inconvenient not to see text of captions, but only numbers in the reference and look for right number every time.

By the way, the problem still persist in version 3.6.0alpha1 (Build ID: 66f01b5)
Comment 14 andis.lazdins 2012-06-05 23:52:57 UTC
> By the way, the problem still persist in version 3.6.0alpha1 (Build ID:
> 66f01b5)

and in version 3.6.0alpha1+ (Build ID: 27cd915)
Comment 15 Andras Timar 2012-06-06 00:06:28 UTC
(In reply to comment #14)
> > By the way, the problem still persist in version 3.6.0alpha1 (Build ID:
> > 66f01b5)
> 
> and in version 3.6.0alpha1+ (Build ID: 27cd915)

I pushed the fix last night, see comment 9 and comment 10. Try a later build, or wait for 3.6 beta1.
I agree with you regarding the bug #50144, it would be a nice improvement. In Hungarian "<number>. <type>" format is the default, therefore I understand the issue well. However, it looks to me that the code was designed with "<type> <number>" format in mind, and it is not that easy to change that.
Comment 16 andis.lazdins 2012-06-06 00:23:01 UTC
> I agree with you regarding the bug #50144, it would be a nice improvement. In
> Hungarian "<number>. <type>" format is the default, therefore I understand the
> issue well. However, it looks to me that the code was designed with "<type>
> <number>" format in mind, and it is not that easy to change that.

Thank you for understanding! The same is in Latvian - text should follow to number.

I don't know if the principle of inserting cross-references is completely different for headings, numbered paragraphs, footnotes from one side (where text after number is visible) and captions from other side. This is really annoying to scroll large documents every time to insert reference to right table or chart.

Regards
Comment 17 Not Assigned 2012-06-06 00:26:53 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5215a544dacc1acc1ddb6017df551b04dfc2f458&g=libreoffice-3-5

fdo#50139 do not cut first character of field text


It will be available in LibreOffice 3.5.5.
Comment 18 andis.lazdins 2012-06-07 23:11:38 UTC
I can confirm that this regression is solved, both in case of identifier of caption after and before number (Ubuntu 12.04, Version 3.6.0beta1 (Build ID: 1f1cdd8)).

This was the ugliest regression for me in Libreoffice. Taking in account improvements in pivot table and other functions 3.5.5 and 3.6 seems to be the best releases of the Libreoffice.

Thanks to Andras Timar and others pointing to this issue and good luck in future to Libreoffice!
Comment 19 Rainer Bielefeld Retired 2012-08-03 09:21:54 UTC
We need exact and correct target information for automated lists in Wiki and LibO Web Site.
Comment 20 Cor Nouws 2012-10-22 09:05:50 UTC
conform comment#18 (and my own notifications..) > close
Comment 21 Cor Nouws 2013-08-01 15:15:03 UTC
*** Bug 46929 has been marked as a duplicate of this bug. ***