Bug Hunting Session
Bug 45068 - Update from 3.4 to 3.5rc1 is not working
Summary: Update from 3.4 to 3.5rc1 is not working
Status: RESOLVED DUPLICATE of bug 36677
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Installation (show other bugs)
Version:
(earliest affected)
3.5.0 RC1
Hardware: All Windows (All)
: highest blocker
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-21 23:42 UTC by Florian Reisinger
Modified: 2012-01-23 08:23 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Florian Reisinger 2012-01-21 23:42:00 UTC
Hi!
If you try to update an existing LibreOffice ( In the test most 3.4.4) the installation stops after warning, that all components of 3.4.x should be closed (In fact, they are...)

On the German-ML tested with:
LibreOffice 3,4,4 --> 3,5rc1 (windows 7 hp x64) HANG
LibreOffice 3,4,4 --> 3,5rc1 (windows XP x86) OK
LibreOffice 3,4,x --> 3,5rc1 (windows 7 pro x?) HANG
LibreOffice 3,4,x --> 3,5rc1 (windows Vista hp x86) HANG

ML Thread: http://listarchives.libreoffice.org/de/discuss/msg10673.html
Comment 1 Lionel Elie Mamane 2012-01-22 06:23:30 UTC
This looks like bug 36677 (and its many dupes). See in particular comment 3 of bug 43454:

 > It is impossible to fix this, because LibreOffice 3.4.4 is released and the bug is in LibreOffice 3.4.4 installer. It was fixed for 3.4.5, see bug 36677.

> Workaround: First you need to uninstall 3.4.4. It usually works in interactive mode, or you can use uninstaller tools such as Perfect Uninstaller.

I suppose we now have another work-around: upgrade to LibreOffice 3.4.5 and *then* upgrade to LibreOffice 3.5.

It remains very annoying that we cannot "fix" this in the *new* installer.

*** This bug has been marked as a duplicate of bug 36677 ***
Comment 2 Petr Mladek 2012-01-23 08:23:09 UTC
I have mentioned it at http://wiki.documentfoundation.org/ReleaseNotes/3.5#Most_annoying_bugs