Bug Hunting Session
Bug 45107 - GUI: Rectangles instead of Characters for Tamil and Dogri
Summary: GUI: Rectangles instead of Characters for Tamil and Dogri
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other Windows (All)
: medium normal
Assignee: Andras Timar
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-01-22 22:50 UTC by A S Alam
Modified: 2012-01-26 14:58 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
attached with Junk Characters on Libreoffice GUI, while system browser showing correct locale (te_IN) (171.12 KB, image/png)
2012-01-22 22:50 UTC, A S Alam
Details
Dogri Interface with Junk Characters (90.34 KB, image/png)
2012-01-22 22:51 UTC, A S Alam
Details
Tamil Interface (73.76 KB, image/png)
2012-01-22 22:51 UTC, A S Alam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description A S Alam 2012-01-22 22:50:32 UTC
Created attachment 56007 [details]
attached with Junk Characters on Libreoffice GUI, while system browser showing correct locale (te_IN)

while testing GUI in various Indian locales, there are Junk Character in interface. Somewhere Characters are mixed up with Each other. Other Places there Blocks without any glyphs. 

Tested Windows Build only.

LibreOffice 3.5.0rc1 
Build ID: b6c8ba5-8c0b455-0b5e650-d7f0dd3-b100c87

Tested locales with Problem:
Dogri
Kannada (kn_IN)
Tamil (ta_IN)
Telugu (te_IN)


Change language interface with Tools->Option->Language-GUI [http://help.libreoffice.org/Common/Selecting_the_Document_Language]


Is there any chance that there will be No (or wrong) Font Selection in Libreoffice's configration file for those languages (on Windows OS)?
Comment 1 A S Alam 2012-01-22 22:51:10 UTC
Created attachment 56008 [details]
Dogri Interface with Junk Characters

Dogri Interface
Comment 2 A S Alam 2012-01-22 22:51:53 UTC
Created attachment 56009 [details]
Tamil Interface

Tamil Interface
Comment 3 Rainer Bielefeld Retired 2012-01-23 10:02:37 UTC
NOT reproducible with "LibreOffice 3.4.5 Dogri UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit); that's the only

NOT reproducible with with "LibreOffice 3.5.0 RC1 Tamil UI/ German Locale [Build-ID: b6c8ba5-8c0b455-0b5e650-d7f0dd3-b100c87] on German WIN7 Home Premium (64bit) in a Recovery dialog.

I did not do many tests because of "Bug 45137 - UI: TAMIL / DOGRI CRASH in menu Tools - Options"
Comment 4 Rainer Bielefeld Retired 2012-01-24 02:15:33 UTC
[Reproducible] with "LibreOffice 3.4.5 Tamil (or Dogri) UI German Locale [Build ID: OOO340m1 (Build:502)]" on German WIN XP Home 32Bit (VirtualBox) in LibO Window headers and various menus and dialogs.

@András:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 5 Andras Timar 2012-01-24 02:27:17 UTC
I'm pretty sure that these garbage characters cause the crash in bug 44208. I'm investigating it.
Comment 6 Andras Timar 2012-01-25 02:53:40 UTC
fixed on master
reviev pending for 3-4, 3-5, 3-5-0
Comment 7 Caolán McNamara 2012-01-26 14:58:22 UTC
committed for 3-4, 3-5. 3-5-0 pending extra review