Bug 45117 - Input window to ask if save in docx or odf format looks unequilibrated
Summary: Input window to ask if save in docx or odf format looks unequilibrated
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.0 Beta3
Hardware: Other All
: high major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
: 45330 46649 (view as bug list)
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-01-23 04:04 UTC by soymalo
Modified: 2012-02-27 03:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot showing the problem (74.95 KB, image/png)
2012-02-07 06:09 UTC, Petr Mladek
Details
Suggested fix for this bug (450 bytes, patch)
2012-02-07 21:49 UTC, Josh Heidenreich
Details
Fix for the bug. Tested. (946 bytes, patch)
2012-02-08 00:22 UTC, Josh Heidenreich
Details

Note You need to log in before you can comment on or make changes to this bug.
Description soymalo 2012-01-23 04:04:02 UTC
Using LibO 3.5.0 Beta3, German Version.
Want to save document in docx format. A window pops up and asks me if I want to save as docx or odf. Obviously the control boxes here change size due to the length of the text, while the inputwindow does not. So the rightmost control box doesn't have any margin to the right.
Comment 1 tester8 2012-01-26 13:15:59 UTC
LOdev 3.5.0rc1
e40af8c-10029e3-615e522-88673a2-727f724
Ubuntu 10.04.3 x86
Linux 2.6.32-37-generic

Reproduced with both Russian & English UI
Comment 2 Petr Mladek 2012-02-07 06:09:56 UTC
Created attachment 56709 [details]
Screenshot showing the problem
Comment 3 Petr Mladek 2012-02-07 06:10:41 UTC
The bug is visible to many users, so increase severity and priority.
Comment 4 Josh Heidenreich 2012-02-07 21:49:13 UTC
Created attachment 56735 [details]
Suggested fix for this bug

I had a quick look at the code (I've seen it before when I did work on this dialog, so I know it a little)

I have attached a suggested fix, although it's not yet tested because I'm still waiting for my build to compile.

I'll post on the mailing-list (a full git format-patch) once the compile is done, unless if someone takes my fix and merges it earlier :)
Comment 5 Josh Heidenreich 2012-02-08 00:22:36 UTC
Created attachment 56738 [details]
Fix for the bug. Tested.

This is a proper patch (using format-patch).

I have also posted on the mailing list.
Comment 6 Andras Timar 2012-02-08 03:32:03 UTC
*** Bug 45330 has been marked as a duplicate of this bug. ***
Comment 8 manj_k 2012-02-27 03:08:29 UTC
*** Bug 46649 has been marked as a duplicate of this bug. ***