Download it now!
Bug 45182 - FILEOPEN rtf - bad text encoding
Summary: FILEOPEN rtf - bad text encoding
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.0 Beta3
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: target:3.6.0 target:3.5.3
Keywords: filter:rtf, regression
: 47397 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-01-24 09:05 UTC by Pavel Kysilka
Modified: 2015-12-17 11:53 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample document (156.41 KB, application/rtf)
2012-01-24 09:05 UTC, Pavel Kysilka
Details
source file (4.78 KB, application/rtf)
2012-03-21 05:14 UTC, František
Details
saved file (33.27 KB, application/rtf)
2012-03-21 05:20 UTC, František
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pavel Kysilka 2012-01-24 09:05:37 UTC
Created attachment 56090 [details]
Sample document

Part of the document has bad encoding.
Comment 1 s-joyemusequna 2012-01-25 08:44:15 UTC
Document is OK in Word 2003 and 2007.

LibO 3.5 RC1: Footnotes have bad encoding. In some cases the font and/or the font size are not correct.

LibO 3.4.4: The document is a mess, but the encoding is OK.
Comment 2 s-joyemusequna 2012-02-22 09:40:15 UTC
Tested with LibO 3.3.4 on Windows XP. The document is nearly perfect (compared to Word 2007).

So this is a regression.
Comment 3 František 2012-03-21 05:14:15 UTC
Created attachment 58806 [details]
source file
Comment 4 František 2012-03-21 05:19:13 UTC
I Can confirm encoding problem. Saving edited RTF file resulted in lost of accented characters. Saved file contains no info about encoding/charset.

Begining of saved file:
{\rtf1\ansi\deff3\adeflang1025
{\fonttbl{\f0\froman\fprq2\fcharset0 Times New Roman;}

Source file:
{\rtf1\ansi\ansicpg1250\deff0\deflang1029\deflangfe1029{\fonttbl{\f0\froman\fprq2\fcharset238{\*\fname Times New Roman;}

Both are attached.

F.
Comment 5 František 2012-03-21 05:20:30 UTC
Created attachment 58808 [details]
saved file

File I saved that has lost encoding.
Comment 6 Jean-Baptiste Faure 2012-03-21 06:09:44 UTC
I guess this bug is a duplicate of bug 44529.
Miklos, do you agree ?

Best regards. JBF
Comment 7 Miklos Vajna 2012-04-03 07:27:43 UTC
JBF,

No, this is something I can reproduce. I think it'll be a problem \deff setting only the font name, but not the encoding, I'll look into it.

Miklos
Comment 8 Not Assigned 2012-04-03 09:01:48 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f4e0cbaa15c2861e87149a62c9c80a9e9b4094b3

fdo#45182 fix RTF import of character encoding in footnotes
Comment 9 Miklos Vajna 2012-04-03 09:05:41 UTC
Fixed in master, the commit message details the two independent issues we had here. Also added to my backport queue, as usual.
Comment 10 Miklos Vajna 2012-04-10 07:18:24 UTC
*** Bug 47397 has been marked as a duplicate of this bug. ***
Comment 11 Not Assigned 2012-04-13 07:17:05 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5e7f26787c6025ec1dffa9eee17405220325f7ae&g=libreoffice-3-5

fdo#45182 fix RTF import of character encoding in footnotes


It will be available in LibreOffice 3.5.3.
Comment 12 Robinson Tryon (qubit) 2015-12-17 11:53:41 UTC
Migrating Whiteboard tags to Keywords: (filter:rtf)
Replace rtf_filter -> filter:rtf.
[NinjaEdit]