Bug Hunting Session
Bug 45255 - FILEOPEN .doc comments are missing
Summary: FILEOPEN .doc comments are missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All All
: high critical
Assignee: Cédric Bosdonnat
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-01-25 23:39 UTC by sasha.libreoffice
Modified: 2012-01-31 05:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test case for comments in doc (354.50 KB, application/msword)
2012-01-25 23:39 UTC, sasha.libreoffice
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sasha.libreoffice 2012-01-25 23:39:51 UTC
Created attachment 56167 [details]
test case for comments in doc

When I have tried open file from Bug 37794, I see that there is no comment

Reproduced in LibO 3.5.0 beta on Fedora 64 bit and Windows XP 32 bit
and in LibO 3.6.0 master
(in LibO 3.4.3 opens correctly)
Comment 1 Rainer Bielefeld Retired 2012-01-26 03:09:43 UTC
I still see comments (sometimes with other damages) with 
"LibreOffice Daly based on 3.4.2 RC - WIN7  Home Premium (64bit) German UI [OOO340m1 (Build:201) from libreoffice-3-4~2011-07-22_15.35.00_LibO_3.4.2rc1_Win_x86_install_multi.exe]" 
and
"LibreOffice 3.4.5 German UI [Build ID: OOO340m1 (Build:502)]" parallel Server installation on German WIN7 Home Premium (64bit) 

My Master latest available version with comments visible
Build ID: 
	d337f79-a24c961-2865670-9752b71-7f8fd43
	2fdd60d-fd28b6a-fd7bf20-aa369cb-28da3fb
	6a9633a-931d089-ecd263f-c9b55e9-b31b807
	82ff335-599f7e9-bc6a545-1926fdf

My first Master version with missing comments:
Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  d3d1481-3f8994a-2ba0a9f)]" (110909)

Regression comparing to 3.4

@Cédric:
Please feel free to reassign (or reset Assignee to default) if it’s not your area or if provided information is not sufficient. Please set Status to ASSIGNED if you accept this Bug.
Comment 2 Petr Mladek 2012-01-26 05:14:14 UTC
I reproduce this problem with 3.5.0-rc1 on SLED11-SP1-i586.

It looks like a data loss => increasing the severity and adding to most annoying bugs.
Comment 3 Luboš Luňák 2012-01-30 09:02:06 UTC
The regression is triggered by 8434a6966914547451489db6828b31ae86901186 . However re-saving the document using the LO version that works makes it work also in the current version, so there's a fair chance the document is corrupted.
Comment 4 Luboš Luňák 2012-01-30 14:00:58 UTC
Fixed.
Comment 5 tommy27 2012-01-30 21:33:06 UTC
@Lubos

is that a real "code fix" or just a workaround?
Comment 6 Luboš Luňák 2012-01-31 05:51:43 UTC
Code fix.